5ちゃんねる ★スマホ版★ ■掲示板に戻る■ 全部 1- 最新50  

■ このスレッドは過去ログ倉庫に格納されています

Debian GNU/Linux スレッド Ver. 15

1 :login:Penguin:03/02/14 07:50 ID:MlROUXan
過去ログは多分>>2-3

Debian GNU/Linux スレッド 過去ログ検索 (Ver. 11: 382氏提供)
http://debian.dtdns.net/2ch-debian/

Debian関連サイト、Tips および FAQ はこちら
http://debian.fam.cx/ (templa948氏提供 : メイン)
http://debian2ch.fc2web.com/ (templa948氏提供 : ミラー)

     * 質問の前には必ず参照の事 *

800 :login:Penguin:03/04/15 22:56 ID:b3V+ubqI
mozillaでjava appletを読めるようにしたいのですが、うまくいきません。
どのようにすればよいでしょうか。

僕がためした方法
2. deb http://ftp.tux.org/pub/java/debian unstable main non-free
として、apt-get install j2re1.4とする。

1. mozillaのヘルプ->Plug-inについてから行けるページ↓から
http://cgi.netscape.com/cgi-bin/pi_moreinfo.cgi?PID=10048
ダウンロードする。

よろしくおねがいします。

801 :login:Penguin:03/04/15 23:15 ID:oLIlS5C9
>>799
apt-cache show apache-perl

802 :logon:Penguin:03/04/15 23:54 ID:Ij9U4j38
>>801
さんクスコ

803 :login:Penguin:03/04/16 00:04 ID:AeObIEay
>>800 どのように上手くいかなかったか書いてくれないと、ちょっと
手も足もでないかもだ。stderr に何か吐いたり、エラーダイアログが
出たりしなかった?


804 :800:03/04/16 01:18 ID:+8XrqSku
>>803
ターミナルからmozillaを起動したところ特にメッセージは出てませんでした。
プラグインはいくつかいれているのですが、mozillaのヘルプ->プラグインについて
を見るとjava関連のみ表示されません。
ちょいとgaleonをいれてみようかと思います。

ls -l /usr/lib/mozilla/plugins
合計 1492
drwxr-xr-x 6 root root 4096 2003-04-15 22:41 java2/
-rw-r--r-- 1 root root 1456196 2003-03-07 19:36 libflashplayer.so
lrwxrwxrwx 1 root root 69 2003-04-15 22:36 libjavaplugin_oji.so -> /usr/lib/mozilla/plugins/java2/plugin/i386/ns600/libjavaplugin_oji.so*
-rw-r--r-- 1 root root 18480 2003-03-27 12:09 libnullplugin.so
-rw-r--r-- 1 root root 29200 2003-04-04 00:51 mplayerplug-in.so
lrwxrwxrwx 1 root root 43 2003-03-16 16:36 nppdf.so -> ../../Acrobat5/Browsers/intellinux/nppdf.so
-rw-r--r-- 1 root root 856 2003-03-07 19:36 flashplayer.xpt


805 :login:Penguin:03/04/16 01:40 ID:J3BuXIJH
>>804
sidのmozilla使ってるの?
GCC 3.2 でコンパイルした blackdown のjava 使えってのではないのかな。
sidのmozillaどうなってるかよくわからんので未確認なんだけど、、、。



806 :800:03/04/16 02:43 ID:+8XrqSku
>>804
sidのmozillaです。
deb http://ftp.tux.org/pub/java/debian unstable main non-free
から apt-get install j2re1.4 としたものでも試したのですが、
うまくいきませんでした。
自分の環境でコンパイルしないとダメということでしょうか。
ところで、galeonを起動するとmozillaでは表示されなかったエラーが表示されました
ので書かせていただきます。

LoadPlugin: failed to initialize shared library /usr/lib/j2se/1.4/jre/plugin/i386/mozilla/javaplugin_oji.so [/usr/lib/j2se/1.4/jre/plugin/i386/mozilla/javaplugin_oji.so: undefined symbol: GetGlobalServiceManager__16nsServiceManagerPP17nsIServiceManager]

ちなみに、mozillaのヘルプ->プラグインについて からダウンロードしたものでは、
次のようなエラーが出ました。なんかこっちの方が致命的な感じがしますが。

LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/java2/plugin/i386/ns600/libjavaplugin_oji.so [libstdc++-libc6.1-1.so.2: 共有オブジェクトファイルを開けません: そのようなファイルやディレクトリはありません]

807 :login:Penguin:03/04/16 04:58 ID:ptk9pr/o
たしかにgcc3.2で最適化コンパイルしたMozillaでは
_ふつうの_Javaプラグインは動かないなー。

# 最近Java使ってるWeb頁少ないからそれほど不便ではないけど。
# Flashは大丈夫だし...

808 :login:Penguin:03/04/16 05:33 ID:ptk9pr/o
libstdc++云々はたぶん"ライブラリのバージョンがちょっとちがう"とかだろうけど
symlinkしてもたぶんエラーになりそう。

コマンドラインで
${JAVA_HOME}/bin/appletviewer <URL>
して見るのがいちばん安直であろうと思う。


809 :login:Penguin:03/04/16 05:55 ID:ptk9pr/o
ちなみにlibstdc++-libc6.1-l.so.2はsargeにはある....

$ locate libstdc++-libc6
/usr/lib/libstdc++-libc6.2-2.so.3
/usr/lib/libstdc++-libc6.2-2.a.3
/usr/lib/libstdc++-libc6.1-1.so.2
/usr/lib/libstdc++-libc6.1-2.so.3

$ dpkg -S /usr/lib/libstdc++-libc6.1-1.so.2
libstdc++2.9-glibc2.1: /usr/lib/libstdc++-libc6.1-1.so.2
















...と思ったら廃止だそうで

─────── oldlibs セクションの廃止/ローカル任意パッケージ ───────
*** 任 oldlibs libstdc++2.9 2.91.66-4 <なし>


810 :807:03/04/16 10:58 ID:ptk9pr/o
http://java.sun.com/j2se/1.4.2/download.html
から入手できる"J2SE v 1.4.2 Beta b19"の

jre/plugin/i386/ns610-gcc32/libjavaplugin_oji.soであれば

"-O3 -march=i686"とかでコンパイルしたモジラでも
ばっちり使えることを確認しました。

連発スマソ。暇で。

811 :login:Penguin:03/04/16 12:56 ID:AS5onu6K
Debian系のLinuxつかっています。
jmanがはいっていないのでjmanをいれようとおもうのですが、
必要なパッケージがいまいちわかりません。
http://packages.debian.org/stable/doc/
どなたかよろしくお願いします。。

812 :login:Penguin:03/04/16 14:04 ID:DEqm4Ft1
>>811
manpages-ja

813 :login:Penguin:03/04/16 15:50 ID:hV2yvePC
gcc-3.3キタ━━━━━━(゚∀゚)━━━━━━ !!!!!

814 :aaa:03/04/16 16:12 ID:G0ykgCzu
woodyからsargeに移行しようと思っているのですが、
/etc/apt/apt.conf.d/99target を
APT::Default-Release "testing";
としてapt-get update;apt-get upgrade
でOKですか?いろいろトラぶりますか?

815 :login:Penguin:03/04/16 17:41 ID:PA2g+v8J
>>814
/etc/apt/sources.list は?

> いろいろトラぶりますか?
"testing" ってどういう意味かわかる?

816 :aaa:03/04/16 17:46 ID:6yt7DWlp
>>814
sources.listはも変えてですね。
それよりapt-get dist-upgradeなのかなあ
どう違うのかわからないっす。

いや、移行すると今までの設定とかがおかしくなって現状復帰が素人には大変ってことはあるかなと思ってね。

817 :login:Penguin:03/04/16 22:46 ID:2AoWtJ4h
>>816
>いや、移行すると今までの設定とかがおかしくなって現状復帰が素人には大変ってことはあるかなと思ってね。

あたり前田のクラッカー

818 :800:03/04/16 23:02 ID:+8XrqSku
>>807

>/java.sun.com/j2se/1.4.2/download.html
>から入手できる"J2SE v 1.4.2 Beta b19"
が、今ダウンロードできないようですが、あとで試してみようと思います。

appletviewerで、とりあえず目的を達成することができました。
ありがとうございました。

819 :803:03/04/17 01:12 ID:enOMXthN
>>818 guru のパッケージはどうだろう?
ttp://ftp.debian.gr.jp/pool/non-free/j/j2se1.4-i386/
にあるやつ。


264 KB
★スマホ版★ 掲示板に戻る 全部 前100 次100 最新50

read.cgi ver 05.04.02 2018/11/22 Walang Kapalit ★
FOX ★ DSO(Dynamic Shared Object)