5ちゃんねる ★スマホ版★ ■掲示板に戻る■ 全部 1- 最新50  

■ このスレッドは過去ログ倉庫に格納されています

くだらねえ質問はここに書きこめ! Part46

609 :login:Penguin:03/05/17 03:01 ID:HJTnolG9
pppoe を kernel mode で動かしたくて、rp-pppoe-3.5 を
--enable-plugin=/tmp/ppp-cvs-20030512 や
--enable-plugin=/tmp/ppp-2.4.1 等、ppp を変更したりして
コンパイルしようとしていますが、以下のようなエラーになります。
何か考えられる原因はありますでしょうか?

gcc-2.95.3 '-DRP_VERSION="3.5"' -g -O2 -Wall -Wstrict-prototypes -ansi \
-pedantic '-DPPPOE_PATH="/usr/sbin/pppoe"' '-DPPPD_PATH="/usr/sbin/pppd"' \
'-DPLUGIN_PATH="/etc/ppp/plugins/rp-pppoe.so"' \
'-DPPPOE_SERVER_OPTIONS="/etc/ppp/pppoe-server-options"' -Ilibevent \
-I/tmp/ppp-2.4.1/ -c -o plugin/ plugin.o -fPIC plugin.c
In file included from plugin.c:34:
/tmp/ppp-2.4.1/pppd/pppd.h:75: warning: comma at end of enumerator list
In file included from /usr/include/linux/if_pppox.h:21,
from plugin.c:57:
/usr/include/asm/byteorder.h:38: parse error before `__u64'
/usr/include/asm/byteorder.h:38: parse error before `val'


271 KB
★スマホ版★ 掲示板に戻る 全部 前100 次100 最新50

read.cgi ver 05.04.00 2017/10/04 Walang Kapalit ★
FOX ★ DSO(Dynamic Shared Object)