5ちゃんねる ★スマホ版★ ■掲示板に戻る■ 全部 1- 最新50  

■ このスレッドは過去ログ倉庫に格納されています

Debian GNU/Linux スレッド Ver. 18

1 : ◆YqFReVf3.c :03/08/23 10:01 ID:eqLhPyLa
過去ログは多分>>2-3

Debian GNU/Linux スレッド過去ログ検索 (namazuTamer 氏提供)
http://debian.dtdns.net/2ch-debian/

Debian の基本的な設定、関連サイト、Tips および FAQ はこちら (templa948 氏提供)
http://debian.fam.cx/

     * 質問の前には必ず参照の事 *

2 : ◆YqFReVf3.c :03/08/23 10:01 ID:eqLhPyLa
前スレ
http://debian.fam.cx/pc.2ch.net/test/read.cgi/linux/1056885910/
http://pc.2ch.net/test/read.cgi/linux/1056885910/

過去ログ
00 http://cocoa.2ch.net/unix/kako/970/970632381.html
01 http://cocoa.2ch.net/linux/kako/980/980163775.html
02 http://cocoa.2ch.net/linux/kako/992/992323048.html
03 http://pc.2ch.net/linux/kako/999/999724231.html
04 http://pc.2ch.net/linux/kako/1006/10062/1006278960.html
05 http://pc.2ch.net/linux/kako/1011/10117/1011766081.html
06 http://pc.2ch.net/linux/kako/1015/10151/1015174417.html
07 http://pc.2ch.net/linux/kako/1018/10184/1018445203.html
08 http://pc.2ch.net/linux/kako/1020/10209/1020967965.html

3 : ◆YqFReVf3.c :03/08/23 10:02 ID:eqLhPyLa
09 http://pc.2ch.net/linux/kako/1024/10240/1024031354.html
10 http://pc.2ch.net/linux/kako/1027/10274/1027442221.html
11 http://pc.2ch.net/linux/kako/1030/10301/1030178687.html
12 http://pc.2ch.net/linux/kako/1033/10330/1033049225.html
13 http://pc.2ch.net/linux/kako/1036/10361/1036184754.html
14 http://debian.fam.cx/pc.2ch.net/test/read.cgi/linux/1040637707/
15 http://debian.fam.cx/pc.2ch.net/test/read.cgi/linux/1045176646/
16 http://debian.fam.cx/pc.2ch.net/test/read.cgi/linux/1051790435/

4 :login:Penguin:03/08/23 11:29 ID:gVGvLfhg
sarge12月リリースに関するAnthony Townsのメッセージ
http://lists.debian.org/debian-devel-announce/2003/debian-devel-announce-200308/msg00010.html

5 :login:Penguin:03/08/23 12:28 ID:locPvGrg
>>1

6 :login:Penguin:03/08/23 16:18 ID:UUDsj1tE
>>1


次のスレ立ては980でもいい希ガス。

7 :login:Penguin:03/08/23 18:05 ID:59bHKS5L
Bruce Perence氏って何やった人なの?
以前debianに関わってたと言う事しか分からなかった。

8 :login:Penguin:03/08/23 19:29 ID:ZBTwmGbf
>>7
OSIのえらい人じゃなかったっけ?


9 :login:Penguin:03/08/23 19:55 ID:nBsROiGm
OSDがDFSGを基にして作られているのは、彼が元々
Debianな人だったというのが大きいと思う。

あと、Bruce Perensと言えばElectric Fenceの原作者
としても有名だよね。

10 :login:Penguin:03/08/23 21:28 ID:d12Y/Nwc
woody使わせていただいていまっす。
apt-getでインスコしたパッケージに含まれているファイルを知りたいのですが、
どうすればいいでしょうか?

11 :login:Penguin:03/08/23 21:34 ID:SuITQCWb
>>10
dpkg -L hoge


12 :login:Penguin:03/08/23 21:43 ID:d12Y/Nwc
>>11
ありがとうございます、できますた。

13 :login:Penguin:03/08/24 13:13 ID:/QaDB4RR
apt-getでバイナリパッケージをダウンロードしたいのですが、
コマンドがわかりません。インストールはしたくないんです。
ダウンロードだけです。教えてください・

14 :login:Penguin:03/08/24 13:26 ID:MWZGxFT6
>>13
$ man apt-get
したか?

15 :login:Penguin:03/08/24 13:37 ID:/QaDB4RR
>>14
しましたが、--download-onlyしてもエラーになります。

16 :login:Penguin:03/08/24 13:48 ID:lbuEU3Fc
>>15
エラー内容を書かないのは宗教上の理由かなにか?

17 :login:Penguin:03/08/24 13:56 ID:/QaDB4RR
# apt-get --download-only lpr
E: Invalid operation lpr

18 :login:Penguin:03/08/24 14:00 ID:H8Et70oL
>>17
本当に man apt-get したのかなあ。
apt-get --download-only install lpr


19 :login:Penguin:03/08/24 15:11 ID:/QaDB4RR
>>18
できました。
ありがとうございまつ。

20 :login:Penguin:03/08/24 15:16 ID:KPZLPosb
Sarge の nfs-kernel-server でnfsクライアントから
nfsマウントしたディレクトリをアンマウントしようとすると
> BAD UMNT RPC: RPC: タイムアウトしました
と表示されて鯖のrpc.mountdが固まります。何故でしょう?

マウントすることはとりあえず可能です。


** nfs アンマウント時 tcpdump (失敗する)
14:56:54.900826 192.168.0.126.1016 > 192.168.0.10.111: udp 56 (DF)
14:56:54.901236 192.168.0.10.111 > 192.168.0.126.1016: udp 28 (DF)
14:56:54.901561 192.168.0.126.1017 > 192.168.0.10.620: udp 80 (DF)
14:56:57.906072 192.168.0.126.1017 > 192.168.0.10.620: udp 80 (DF)
14:57:00.915366 192.168.0.126.1017 > 192.168.0.10.620: udp 80 (DF)
14:57:03.924722 192.168.0.126.1017 > 192.168.0.10.620: udp 80 (DF)
14:57:06.934006 192.168.0.126.1017 > 192.168.0.10.620: udp 80 (DF)
14:57:09.943352 192.168.0.126.1017 > 192.168.0.10.620: udp 80 (DF)
14:57:12.952696 192.168.0.126.1017 > 192.168.0.10.620: udp 80 (DF)


*** アンマウント失敗時のシステム負荷
 PID USER   PR NI VIRT RES SHR S %CPU %MEM  TIME+ Command
1716 root   15  0 1008 1008 856 R 85.7 0.3  1:11.90 rpc.mountd
1509 root    9  0  864 864 768 S 0.0 0.3  0:00.00 rpc.statd
1708 root    9  0   0  0  0 S 0.0 0.0  0:00.00 rpciod

ii liblockfile1 1.05 NFS-safe locking library, includes dotlockfi
ii nfs-common 1.0.3-2 NFS support files common to client and serve
ii nfs-kernel-ser 1.0.3-2 Kernel NFS server support


21 :login:Penguin:03/08/24 17:17 ID:d8EvG2ud
一昨日あたりからATOKXのアップグレードに失敗する・・・
sidです。

# apt-get dist-upgrade
Setting up atokx (1.0-12) ...
Stopping ATOKX server: htt atokmngdaemon.
Starting ATOKX server: atokmngdaemon htt.
Starting ATOKX server: invoke-rc.d: initscript atokx, action "start" failed.
dpkg: error processing atokx (--configure):
subprocess post-installation script returned error exit status 1
Setting up xlibmesa3-gl (4.2.1-10) ...

Setting up xlibmesa3-glu (4.2.1-10) ...

Errors were encountered while processing:
atokx
E: Sub-process /usr/bin/dpkg returned an error code (1)


22 :20:03/08/24 17:26 ID:KPZLPosb
>>20 ですが、ひとしきりあうあうやったあとで、
Sid のパッケージをひっぱってきたらなおりました。
おさわがせしました。


ii liblockfile1 1.05 NFS-safe locking library, includes dotlockfi
ii nfs-common 1.0.5-2 NFS support files common to client and serve
ii nfs-kernel-ser 1.0.5-2 Kernel NFS server support
ii nhfsstone 1.0.5-2 NFS benchmark program.


23 :login:Penguin:03/08/24 18:44 ID:S/dFSA7e
>>20,22
nfs-kernel-server-1.0.3は挙動がぁゃιぃので、そのせいでしょう。
漏れもはまった。


24 :login:Penguin:03/08/24 21:16 ID:tWgJyOPC
>>17
そんなやり方どこで覚えたんだ。

25 :login:Penguin:03/08/24 23:51 ID:Q2Pz+qbz
だれか、これにインストールしてどこでもLinux作ってください〜〜
ttp://www.watch.impress.co.jp/akiba/hotline/20030823/etc_wam.html

つーかFDLinuxみたいな感じですかねぇ

26 :login:Penguin:03/08/25 03:43 ID:FtFCAwIU
>>21
dpkg -P atokx してから、
apt-get install atokx してみそ。

command not found が文字化けする上、kterm上で漢字変換出来ても確定後文字が消えるのが鬱だ。

27 :login:Penguin:03/08/25 06:19 ID:tI7w40OJ
sarge使ってますがpinを使って一部のパッケージをsidにしています。
それでどのパッケージをsidのものにしたか忘れてしまったのですが、
それを知るにはどうすればよいのでしょうか?

28 :login:Penguin:03/08/25 06:41 ID:g9NrPR1R
>>27
apt-show-versions | grep unstable

29 :login:Penguin:03/08/25 10:17 ID:Rt/cgyhs
>>25
スパイ大作戦か007になれそうだな藁

30 :前スレ959:03/08/25 16:01 ID:4K03OWCe
すいません。フレームバッファを正しく無効にするには
boot: bf24 video=vga16:off
でした。これだとインストーラもちゃんと動きます。


31 :login:Penguin:03/08/25 19:02 ID:0OurCz87
apt-listbugs が w3m から www-browser を使うようになったけど不便だな。
update-alternatives --config www-browser する以外に w3m を使うよう
にできる方法はありませんか。これをやってもソースが見える状態になって
しまうけど

32 :login:Penguin:03/08/25 19:37 ID:3VGfKa1T
alternative には www-browser の他に x-www-browser というのがあるんだね。

33 :login:Penguin:03/08/25 23:12 ID:dVQuvBpC
今日sargeでapt-get update;apt-get upgrade
したら、Xがバージョンアップして2.4.8とかなんとかなりました。
が、タイトルバーの英語が全てロになってしまいました。日本語はきちんと表示されます。
なにか設定がかわってのでしょうか?

34 :login:Penguin:03/08/26 00:31 ID:6SaOdJsZ
今日のunstableのGNU inetutilsはsyslogdとinetdがインストール不能か…。
にしても、メンテナいったいなに考えとんのじゃ?

35 :login:Penguin:03/08/26 00:57 ID:r9CBi45T
>>34
アフォはsid使わない方がいいよ

36 :login:Penguin:03/08/26 02:05 ID:Jy2tQ053
アフォじゃない人は inetutils はまだ入れないようにしてる訳?

37 :login:Penguin:03/08/26 02:07 ID:r9CBi45T
アフォはstable使ってろってこと

38 :login:Penguin:03/08/26 09:04 ID:LCUyMo+q
アフォじゃない人は自分で修正して入れてます。


39 :login:Penguin:03/08/26 10:25 ID:yqZO37va
アフォじゃない人はアフォな人からメンテナンスを引き継いでホスィ。


40 :login:Penguin:03/08/26 10:48 ID:PXj6EfQ6
アフォじゃない人はまずBTSをチェックします。

41 :login:Penguin:03/08/26 16:18 ID:/CicXveL
はい、それから〜


42 :login:Penguin:03/08/26 19:06 ID:HYd+AolY
BTSのアドレスきぼんぬ

43 :login:Penguin:03/08/26 19:12 ID:7VYamiz4
BTS
http://www.debian.org/Bugs/

44 :login:Penguin:03/08/26 19:13 ID:HYd+AolY
Thanks

45 :login:Penguin:03/08/26 21:23 ID:6SaOdJsZ
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=207292 どうにかならんかね。
おかげでinetutils-syslogd & inetutils-inetdのアンインストールすらできない。

46 :login:Penguin:03/08/26 22:24 ID:vG8taSbW
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=207066
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=206754

BTSのチェックもできないなら、おとなしくstable使ってろよ。

47 :login:Penguin:03/08/26 22:42 ID:juslZvLo
常時BTSチェックするような神経の細い奴こそstable使うべきだと思うが。
apt-get -y dist-upgradeを押し地雷を踏んでからBTS見に行くようなズ太い奴の方が人柱には向いてる。

どうでもいいけどinetdなんか使う?

48 :login:Penguin:03/08/26 22:56 ID:4TRQasUQ
使ってます

49 :login:Penguin:03/08/26 23:00 ID:XWuXRL2X
つかunstable使いは普通apt-listchangesとapt-listbugsくらいは
入れるだろ。それはそれとして、xinetdはDebian使いには人気
ないのかな?

50 :login:Penguin:03/08/26 23:04 ID:CFLgoFEN
>>47
地雷を踏む確率が低いからこそ「stable使え」だと思うのだが。
地雷地帯に自分から足を踏み込んだくせに、踏んだ時に無駄に騒ぐ香具師。
地雷を踏んだ後の事故処理もできない香具師がunstableなんか使うなよ。

漏れはinetdは使わないな。
削除できるようになるか、xinetdと差し変えられるようにしてくれるとうれしいかも。

51 :login:Penguin:03/08/26 23:10 ID:juslZvLo
>>50
なんかあった時に調べず騒ぐ奴はそもそもLinuxが向いてない罠。

tcpserverで全部済ませて(x)inetdは使わないのは少数派か……
まあDebianのdjb物は使う気の失せるメンテ状況ではあるけど。

52 :login:Penguin:03/08/26 23:15 ID:SO5PgZvH
>なんかあった時に調べず騒ぐ奴はそもそもLinuxが向いてない罠。
だからといってWindowsが向いているわけでもないが。


53 :login:Penguin:03/08/27 00:54 ID:lO9PC/O/
漏れxinetd使ってるよ。stableだけどね。インストール時に
既存のinetd.confから雛型を作ってくれて感激したなぁ


54 :login:Penguin:03/08/27 01:12 ID:LBIq5qfU
>>51
漏れも(x)inetdは使わないです。

55 :login:Penguin:03/08/27 04:47 ID:lkVuXzap
FDDなし&ハードウェアRAIDなマシンにwoodyを入れようとしているんだけど、
インストールCDには使っているRAIDカードのドライバが入っていなくて、
インストーラがHDDを認識してくれませぬ。

RAIDカードのドライバは http://people.debian.org/~blade/install/preload/
にあるのを見つけたけど、FDDがないので読み込む術もなし。
自分でドライバを追加したインストールCDってどうやって作ったらいいんでしょ?

56 :login:Penguin:03/08/27 05:41 ID:lO9PC/O/
>>55 boot-floppiesにboot-floppies-3.0.23/i386-specials/mini-iso.sh
があるので、他にLinux環境を用意できるならカーネルイメージ差し替えで
上手くいくんじゃないかな。

ただ漏れはboot-floppiesで上手くカーネル差し替えられたことないがな。
ヘタレですまん...∧‖∧


57 :55:03/08/27 07:57 ID:lkVuXzap
>>56
朝っぱらからありがトン

結局、ヘタレなので手近のマシンからFDDを引っこ抜いてつなぐことで解決して
しまいますた。

しかし力技に頼った罰か、baseをインストールし終わって再起動したところで
“init : must be superuser.”と出てだんまり。
テクノロジーの神に与えられた試練と思ってがんばりまする。

58 :login:Penguin:03/08/27 10:19 ID:Zvq3c7P4
やっぱりこういうの出たか……

http://debtoo.org/
DebToo: Debian, Gentoo-style
Debian recompiled for your system

59 :login:Penguin:03/08/27 11:36 ID:WM8qXdAv
全部apt-get sourceじゃ駄目なんだろうかとかそういう話でもないのかなぁ。

60 :login:Penguin:03/08/27 11:47 ID:QDgEG/HS
debianでapt-build worldするのとはやっぱ違うのかね。
既存のツールだとビルドする時の自由度が低くて魅力ないし。
そこらへんを開拓するつもりだろうか。

61 :login:Penguin:03/08/27 14:10 ID:gyHtNtXl
再コンパイルするだけなら apt-build でじゅうぶんだよね。
Gentoo としては USE フラグや etc-update が便利(これらは
Gentoo のウリというよりは元の ports/pkgsrc にあったもの
だが)なのに、そっちじゃなくて再コンパイルするってほうだ
けが強調されるのはなんだかなぁ。

Debian は自分でコンパイルのフラグ(CFLAGS とかじゃなくて
configure に渡すフラグ)変えたくても面倒だし、なにより設
定ファイルに更新があったとき全部置き換えるかそのままに
するか手動で置き換えるかしかないのが嫌。まあ mergemaster
や etcupdate/etc-update みたいなインタフェースが最高と
までは言わないが、その場で逐次編集できるのはよい。

62 :login:Penguin:03/08/27 14:46 ID:augBsdqm
詳しいことはよく分からんが、2chではきっと
"デブ痛"とか言われるんだろうな

63 :login:Penguin:03/08/27 14:49 ID:xCVUahkS
今日sidのlibxml2が2.5.10-1にupgradeされたが
おちゅ〜しゃがセグファで落ちるようになった
2.5.8-2に戻すとOK
明日には直ってるだろ
ああ、debian楽だわ

64 :login:Penguin:03/08/27 15:09 ID:YDF+ksoj
つぅか、おちゅ〜しゃを起動して板を開こうとすると落ちる…。
今回の騒動でキャッシュがおかしくなったっぽヽ(`Д´)ノワアァーン

このスレは何事もなかったようなのでヨカッターネー

65 : ◆xbDYs2z1ow :03/08/27 15:59 ID:12ALcr4f
Debianのtinは日本語通らんのか。MIMEがおかしい。
tin.orgの新しいやつも同じだ(フム

66 :login:Penguin:03/08/27 16:45 ID:c5QTxcJw
/usr/share/emacs21/site-lisp の下に *.el がないのが不便。
C-h f でリンクがたどれない。
これついて議論されたことある?


67 :login:Penguin:03/08/27 17:22 ID:+cDV8J8N
>>66
emacs*-el 入れてないってオチじゃねーだろな。

68 :login:Penguin:03/08/27 17:23 ID:Jj3pKY6s
>>66
/usr/share/emacs/site-lisp にあるよ
って話じゃなくて?

69 :login:Penguin:03/08/27 17:56 ID:c5QTxcJw
あれ、こんなはずじゃ...
>>67 はい、入れてます。
>>66 はい、あります。
C-h f isearch-forward でソースへジャンプできるけど、
C-h f mew とかではできないということでした。
あまり使われてない機能なのかな。


70 :login:Penguin:03/08/27 18:03 ID:Jj3pKY6s
>>69
woody の emacs21 で
C-h f wl から
/usr/share/emacs/site-lisp/wl/wl/wl.el に飛べたよ。

;; mew は入れてない。

71 :login:Penguin:03/08/27 18:48 ID:+cDV8J8N
>>69
あ、思い出した。emacs21 だけ使ってて/usr/share/emacs/site-lisp 以下に
load-path が通ってなくね? 昔のことで記憶曖昧だけど、emacs20 入れないと
/usr/share/emacs/site-lisp/subdirs.el が用意されなくてload-path が通ら
なかった記憶が… もしそうだったら手動で subdirs.el を用意してみ。

> あまり使われてない機能なのかな。
んなこたーない。

72 :login:Penguin:03/08/27 20:17 ID:psD0DEOr
うちでは emacs21 に入ってる .el については
きちんとたどれるが、別パッケージとして入れたやつは
たどれない。
.elc があるディレクトリを探すんだろうけど、
別パッケージとして入れたのは .elc だけ別の場所に
入れられるから、そのせいかと思ってた。

>>71
うちには subdirs.el はあるけど、駄目だよ。



73 :login:Penguin:03/08/27 20:36 ID:0gOF10Wh
うちは .el が置かれてるとこにも load-path 通したらちゃんと飛ぶようになったよ。
他に、 find-function-source-path 設定してもいけそうだけど。

74 :login:Penguin:03/08/27 20:42 ID:m0Vuu2NX
apt-listbugs死亡中?

75 :login:Penguin:03/08/27 20:56 ID:HtvhnLV6
こんなサイトがあったんだが、既出?
http://www.fasp.tv/debian/

76 :login:Penguin:03/08/27 21:05 ID:kiKQgYhz
おおっ。丁寧なインストールマニュアルだ。素晴らしい。
とはいえ「簡易」というには少々詳細に過ぎるかな。


77 :login:Penguin:03/08/27 21:09 ID:lO9PC/O/
>>74 アクセス多すぎじゃゴルァということで、
master.debian.orgに出入り禁止になりますた。


78 :login:Penguin:03/08/27 21:44 ID:lO9PC/O/
>>71 emacs-w3mのMLでもこの前出てた。emacs20がsubdirs.elを
含んでいる模様。
ttp://emacs-w3m.namazu.org/ml/msg05616.html 以降のスレッド
Debian Emacs Policyにも明文化されてない領域らしい。投げる
としたらemacs20にBTSか?(それともdebian-policy@orgで聞いてみるか)


79 :login:Penguin:03/08/27 22:12 ID:mKHSHkO4
www.debian.org
トップページの声明文(?)の翻訳きぼんぬ

80 :login:Penguin:03/08/27 22:17 ID:+cDV8J8N
>>73
> 他に、 find-function-source-path 設定してもいけそうだけど。
あれ、Emacs21 だとその変数見つかんなかった。XEmacs ?

>>78
なるほど。emacsen-common あたりに含まれてれば丸く治まりそうだけどね。

81 :login:Penguin:03/08/27 22:17 ID:RAIASapl
>>79
9/1に欧州議会で採決されるソフトウェア特許への抗議キャンペーン


82 :login:Penguin:03/08/27 22:37 ID:ZHBqu/Cb
ふーん。
GPLが著作権を利用してソフトウェアの自由を守っているように、
特許を利用して自由を守る方法はないのかな。
と言ってみる。


83 :login:Penguin:03/08/27 23:05 ID:lO9PC/O/
>>79
directive validatingが上手く訳せなかったけど、どうぞ

-----------------------------------------------------------
ソフトウェア特許に抗議しよう

9月1日に欧州議会で採決されるソフトウェア特許の支配的な認可
に対して、私達は抗議することに決めました。

欧州議会加盟国の市民の皆さん、どうか8月27日(水)に行なわれる
予定のデモを支持してください。Software Patent Free Europe の
請願書に署名することでも良いです。


84 :login:Penguin:03/08/28 01:20 ID:jmBnlOwQ
woodyを古いノートにインストールしようと考えています。
Pentium 75Mhz RAM24MBです。
LANカードはPCMCIA接続のDP8390チップが載ったものしかもっていません。
古さからもわかるようにCD-ROMもついていません。

FDからインストーラを起動してその後はFTPからインスコになると思うのですが、
どのFDイメージをDLすればいいのかわかりません。
教えていただけないでしょうか?

85 :login:Penguin:03/08/28 01:22 ID:DzFDmD2/
>>84
idepciが無難な予感。ダメだったら他も試してくれ。
ちなみにpcmciaだとdrivers.binも必要。

86 :login:Penguin:03/08/28 01:40 ID:0o4QHt4r
>>84 rescue.bin root.bin drivers1-4.binの6枚が必要かな。
因みに3.0.23-2002-05-21だとpcmciaでネットワークの設定が
反映されないというしょーもないバグがあるので、Baseの
インストールの前に一旦shellに落ちて手動で設定する必要
がある。詳しくはMLのアーカイブを見て。


87 :login:Penguin:03/08/28 03:49 ID:l/W0JqF9
compact だったら drivers.bin は2枚でいいかな。
でも PCMCIA カードが対応しているかどうかだよね。

88 :login:Penguin:03/08/28 04:05 ID:f1wNHM4L
あまりにもSobig.Fが多いんでふと調べてみたら,ほとんどが
thizlinux.com.tw [210.202.28.1]
というサーバ発であることが判明。
詐称アドレスから,どうも Debian 関係者っぽいんですが…皆さんとこはどうです?

89 :login:Penguin:03/08/28 04:07 ID:f1wNHM4L
あまりにもSobig.Fが多いんでふと調べてみたら,ほとんどが
SANGER (thizlinux.com.tw [210.202.28.1])
というサーバ発であることが判明。
皆さんとこはどうです?
# 詐称アドレスに d.o なアドレスが多かったんで,とりあえずここに。

90 :login:Penguin:03/08/28 04:08 ID:f1wNHM4L
oops...重複カキコすまそ

91 :login:Penguin:03/08/28 04:13 ID:1SueVddW
http://www.topstudio.co.jp/~kmuto/d/?200308c&to=2003082716#2003082716
おまいらはWnnとかんな どっちつかっとるんや?

92 :login:Penguin:03/08/28 04:19 ID:Aig803ps
>>91 atokx

93 :73:03/08/28 06:11 ID:7pG3IPfF
>>80
うちも Emacs21 だけど…どうしてだろ?
最近更新されたとかなのかな…
とりあえず、 find-func.el の日付は 2002/09/06 だけど…

94 :login:Penguin:03/08/28 07:59 ID:0o4QHt4r
>>93 単にfind-funcがロードされてないだけじゃないかな。
M-x load-library find-funcしてみるとどうだろう


95 :login:Penguin:03/08/28 09:36 ID:dBW2N2Ej
>>91
skk


96 :login:Penguin:03/08/28 09:48 ID:DzFDmD2/
debianにも欲しいな。(つーか俺は野良で入れたけど)
ttp://www.freebsd.org/cgi/query-pr.cgi?pr=55951

97 :80:03/08/28 10:02 ID:TddFrJH5
>>93
ごめん、ボケてた、>>94の言うとおりだった、逝ってくる…


98 :login:Penguin:03/08/28 10:44 ID:GLbP7FQB
>>91
anthy


99 :login:Penguin:03/08/28 11:33 ID:AToyD8Dh
apt-listbugs(0.0.21.1) でPinすると
Pin-Priority: -1

ってされるんですけど、bugですよね?

100 :login:Penguin:03/08/28 13:13 ID:dmpO5bEo
pppのメンテナが代わって鬼のように溜ったバグがfixされてますな。
すてき。

101 :質問箱:03/08/28 15:32 ID:Ogsj+tk8
>>100 おめ

102 :84:03/08/28 18:46 ID:4kSY8zPN
みなさん、ありがとうございます。
driver-1.bin
driver-2.bin
driver-3.bin
driver-4.bin
rescue.bin
root.bin
をddでかきこみました。
起動できるのはroot.binですか?

103 :login:Penguin:03/08/28 18:52 ID:ip7nPAiV
>>102
rescue.bin

104 : :03/08/28 19:11 ID:KRIe7tG8
ftp://ftp.gnu.org/gnu/dotgnu/pnet/debian/

DotGNU のパッケージが全滅なんですが…
どなたかほかにミラーご存知ありませんか??

105 :84:03/08/28 19:25 ID:4kSY8zPN
>>103
ありがとうございます。
起動できています。

あと、別件なんですがputtyのパッケージを見つけたんですがこれって
Xで動くんですか?

106 :login:Penguin:03/08/28 19:42 ID:Ogsj+tk8
>>105
X で動く
Windows のように使えるよ

107 :login:Penguin:03/08/28 19:47 ID:LDYKMfXh
そだよ
$ apt-cache show putty
xlibsにdependしてるでしょ。

108 :84:03/08/28 20:18 ID:2gj0lwkf
みなさん、親切にありがとうございます。
せっかく皆さんに教えていただいたのですがPCMCIAコントーローラを
Linuxがサポートしていなかったようです。debianは何度も別のマシンでインスコしたことがあるのですが、
ちゃんとPCMCIAの設定をやっても駄目でした。

>>106-107
今から別のマシンのwoodyで試してみます。
もとがEUCなのでEUCパッチは必要ないですかね?

109 :login:Penguin:03/08/28 23:55 ID:QdsyvlSA
>>108
bf24でも駄目?
http://www.t.ring.gr.jp/pub/linux/debian/debian/dists/woody/main/disks-i386/current/images-1.44/bf2.4/


110 :login:Penguin:03/08/29 00:47 ID:8S8IYG2f
>>84=108
どうして具体的なメーカ名,型番を出さないのでしょう.

111 :84:03/08/29 01:14 ID:5eBul728
>>109
最初にbf24で試しました。
他は試していません。

>>110
PCMCIAコントーローラはメーカー/型番ともにわかりません。
申し訳ありません。
NICは三菱のB8895というものです。
三つ同じ物を持っていて一つ分解したところ三菱のチップと
DP83902・・・・というのが載っていました。

PC自体は、M3464-C3C0という三菱apricotです。

112 :login:Penguin:03/08/29 01:18 ID:I2Ez66tj
>>111
$ cat /proc/pci
には何も出てないの?

113 :84:03/08/29 01:33 ID:5eBul728
/proc/pciは見てません。
/proc/bus/にpciとあとpcmcia(cardだったかな?)があってその中に
00 と 01があってその中のを適当にcatしたらVT*****ってかいてありました。(VIAと認識しているようです)
しかし、今Windowsで確認したところCirrus LogicのPCICコンパチブルPCMCIA コントローラとなっていました。
woodyインスコ時はWindowsは入っていません。
WindowsではちゃんとLANカードも使えます。
が、640X480しかでません。ドライバ無理やり入れたらsafeモードしか起動しなくなりました。
ってことで65540チップをXがサポートしているみたいなのでwoodyを入れようと考えたわけですが。
べつにLinuxなら何でもいんですが。使い慣れてるほうがいいかと。

114 :login:Penguin:03/08/29 02:35 ID:+Ii5K2eY
>>111
DP83902だったらpc_netで動く。
あとは/proc/pciの結果だろう。
CirrusのPCICならそこに出てくるはず。


115 :login:Penguin:03/08/29 03:50 ID:HT9SLZ7q
厨質なんですが...

vimで日本語入力を支援してくれる
im_cutomというパッチを当てたいのですが、
このような場合にDebian流のやり方があるのでしょうか?

116 :login:Penguin:03/08/29 04:01 ID:x+vXdEo4
configure の後にパッチを当てるっていう変態的なパッチだよね。
まあそのように書けばいいんではないかと……。

117 :login:Penguin:03/08/29 04:13 ID:HT9SLZ7q
>>116ありがとうございます。
それが
http://hp.vector.co.jp/authors/VA020411/Vim/im_custom/readme.txt
を見ると、061以降はconfigureの前にパッチを当てろ、とのことらしいので、
そのようにして、vim61 で zcat im_custom064.diff.gz| patch -p0
とすると、

can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -Nru src.org/Make_mvc.mak src/Make_mvc.mak
|--- src.org/Make_mvc.mak 2003-07-14 09:35:23.000000000 +0900
|+++ src/Make_mvc.mak 2003-07-14 09:15:40.000000000 +0900
--------------------------
File to patch:

と出てしまうんですが...

118 :login:Penguin:03/08/29 05:30 ID:ypJvnu4Z
>>117vimのバージョンは?ソースはどこから持ってきたやつ?


119 :login:Penguin:03/08/29 07:08 ID:6gNq+YPQ
im_custome を使いたいだけという事なら、woody 用がある
ttp://detroit.ddo.jp/index.php?%5B%5BLinux%2FDebian%5D%5D

120 :login:Penguin:03/08/29 07:25 ID:R5GeT5PM
情報を不足させてしまってごめんなさい。

debianはsargeを使っています。

Vimは
Version: 1:6.1-474+2
です。

>>119ありがとうございます。しかしsargeです。
今ちょっと強引に入れてみましたが、
http://hp.vector.co.jp/authors/VA020411/Vim/im_custom/readme.txt
にあるとおりにvimで
:set imoptions=skk
としても
未知のオプションです: imoptions=skk
と怒られてしまいまつた...

121 :login:Penguin:03/08/29 08:45 ID:ypJvnu4Z
>>120 debianのvimはpatch沢山当たっているから、そのままじゃ
上手く当たらないね。とりあえず手元でリビルドした感じでは上
手く動作している模様。dbs likeにupstream のソースをtar.gzで
置いているので、リビルドするにはちょっと癖がある。以下手順

1. apt-get source vim; sudo apt-get build-dep vim
2. cd vim-6.1でソースツリーのトップに移動
3. fakeroot make -f debian/rules extract でソースを展開
vim61というディレクトリができる
4. cp -r vim61 vim61.origとして元の状態を保存
5. cd vim61して、このディレクトリに対し
zcat im_custom064.diff.gz | patch -p0 でパッチを当てる。
いくつかrejができるので、それらを手パッチ
(src/mbyte.cでどうしても分からないパッチがあって無視して
リビルドしてみたけど、動作しているので無問題?)
6. cd ..でソースツリーのトップに戻って、
diff -urN vim61.orig vim61 > debian/patches/15im_custom
でパッチを作成
7. rm -rf vim61.origで後片付
8. dch -iでchangelog弄ってdebuild -rfakeroot

とりあえずskkは動いてる模様


122 :login:Penguin:03/08/29 09:39 ID:UVsjjJ9j
Safety Linux
http://www.dnki.co.jp/linuxbox/SafetyLinux/

123 :login:Penguin:03/08/29 09:40 ID:5okre87M
woodyで、unstableなどは入れてないです。
X上でALTの挙動がおかしいので質問させて下さい。

xtermなどのターミナルや、emacs(-nwは勿論、メニューからのものも)において
左右Altが動いてくれないです。Alt-xをやろうとしたらbeepがきます。
(非Xなemacsでは、左Altは正常に動作しました。)

MozillaやKonquerorでは Alt+(何か) でメニューに行けますし、Ctrl+Alt+BSも動作し、
xevで見ても正常に動作しているように見えます。上の状況下でピンポイントに
ダメな感じです一体何がおかしいのでしょう?

正常な振舞いも見せるので、設定その他が変とは思えないです。pc104のus配列で、
妙な設定もしていません。キーボードはIBM space saver II(英語)です。

ワラをもすがる思いで xmodmap -e "add mod1 = Meta_L" とすると、メニュー起動の
emacsはちゃんと動いてくれましたが、-nwなやつは相変らずダメでありました。


色々調べてはみたのですが、浅学の身、原因不明五里霧中な状態でして、
皆様のお力に頼るべくやってきた次第です。何卒お知恵をば頂きたく存じます。。。。

# x-window-system のバージョンは4.1.0-16でした。
# インストールしたてだというのに、悲しい。。。

124 :login:Penguin:03/08/29 09:45 ID:aDyMrN84
>>115
手軽にvimでskk入力がしたいなら
skkfepを使うのがいい。
Esc を押すと同時にskkも無効にするオプションがある。
あとskkfepと統合したvimがあったと記憶している。


125 : :03/08/29 10:03 ID:9cj63ZvX
>>122
激しくダメのヨカン

126 :login:Penguin:03/08/29 11:24 ID:ugnzzVVH
>>124
skkfep って不安定じゃない?
しょうがなく使ってることも多いけど。

127 :login:Penguin:03/08/29 11:58 ID:HkV6FY2V
スレの皆さん少し教えてください。
先日手持ちのマシンにDebianをインストールしてみました。
それまでは良かったのですがXを起動させてみたところ、
640x480でしか起動してくれません。
いったい何か問題なのかさっぱり分かりません。
こうしたら高解像度で表示されるよという解決策をご存じの方
おられましたら教えて頂けないでしょうか。
お願い致します。
ちなみに、Xfree86 4.3.0でKenrel2.4.20の環境です。
ビデオのチップセットはi845オンボードです。

128 :login:Penguin:03/08/29 12:16 ID:enFElXrV
>>127
俺は直接 /etc/X11/XF86Config を編集しちゃうけど、Debian 的にどうするの
が正しいのかは知らないのでパス。

ところで、
> ちなみに、Xfree86 4.3.0で
これって experimetal から持ってきてんの?

129 :login:Penguin:03/08/29 12:32 ID:Ql+7r1En
>>127
# dpkg-reconfigure xserver-xfree86
すれば、debconfにどの解像度を使うか聞かれると思うのだが。
Xはそこで選んだ一番大きい解像度で起動するはず。

XF86Config-4の手動編集その他ものもろはくだ質あたりでどうぞ。

130 :login:Penguin:03/08/29 13:00 ID:rTI8TUuU
>>123
xmodmap で何も設定しない状態で xmodmap -pm した結果を貼ってくだされ

131 :login:Penguin:03/08/29 13:25 ID:ypZTEHyB
woodyに7-zipのパッケージありますか?

132 :login:Penguin:03/08/29 13:45 ID:ypJvnu4Z
>>131 ないと思う。ITPは出てるみたいだけど、まだ
sidにもない
ttp://lists.debian.org/debian-devel/2002/debian-devel-200209/msg01027.html

133 :login:Penguin:03/08/29 14:20 ID:+Ii5K2eY
>>123
たぶん。
XTerm.VT100.EightBitInput: false


134 :login:Penguin:03/08/29 14:37 ID:3ZGmKp/J
>>121
亀レスですが、ありがとうございます。
今ちょっとできないので、夜やってみます。
ご丁寧にありがとうございました。

135 :login:Penguin:03/08/29 14:57 ID:+yvslqGl
>>124
> あとskkfepと統合したvimがあったと記憶している。

ttp://www1.interq.or.jp/%7Edeton/jvim-skk/
これのことかな。jvim 3.0 がベースだけど。

136 :login:Penguin:03/08/29 15:37 ID:UicOAuF9
>>86
そうだったのかーーーー⊂⌒~⊃ xДx)⊃

どうもFDインストールしているときネットワーク設定がうまく反映しねーなと思ってたら
そんなバグ持ちだったのか。
コンソールで手動設定して続行したから大して気にも留めてなかった

137 :84:03/08/29 16:28 ID:5eBul728
/proc/pciを見ましたがALiのチップセット関係とF65545しかありませんでした。
もう、駄目なのでしょうか?

138 :login:Penguin:03/08/29 16:54 ID:+Ii5K2eY
>>137
ISAにぶら下がってるコントローラは見えないよ。
時期的にはPCIでも良さそうなんだが。

ISAでPCIC互換なら普通にpcmcia-csで見えそうな気がするけど。




139 :84:03/08/29 17:22 ID:5eBul728
>>86さんがいう手動設定をML検索で探していたのですが見つけ出すことができませんでした。
だれかポイントしてもらえないでしょうか?

140 :84:03/08/29 17:37 ID:5eBul728
自力で見つけることができました。
それ通りにDHCPで設定してcardmgrを再起動したんですがifconfigはloしかありませんでした。
ためしに/var/logを見たところ

/*
Aug 29 17:31:01 (none) daemon.info cardmgr[1417]: starting, version is 3.1.33
Aug 29 17:31:01 (none) daemon.info cardmgr[1417]: watching 2 sockets
Aug 29 17:31:01 (none) daemon.info cardmgr[1417]: unsupported card in socket 0
Aug 29 17:31:02 (none) daemon.info cardmgr[1417]: product info: "MITSUBISHI ELECTRIC CORPORATION", "B8895", "**"
*/
らしいです。もうだめですかね。ここまできたら。

141 :84:03/08/29 17:39 ID:5eBul728
もうひとつ、メルコのLANカードがあるのですが試してみる価値はあるでしょうか?
10Mbpsです。チップはわかりません。型番はLPC3-CLTです

142 :login:Penguin:03/08/29 18:11 ID:vscMp5+l
ある
つか、PCMCIAコントラ自体は認識されてんじゃん。

143 :84:03/08/29 18:33 ID:5eBul728
はい、皆様のおかげでなんとかコントローラを認識させることはできました。
いまからメルコで試してみます。Win用のドライバを逆汗してみたところNe2000みたいな感じです。

144 :127:03/08/29 18:38 ID:HkV6FY2V
127でつ。
皆さんありがとうございます。
実は、
# dpkg-reconfigure xserver-xfree86

XF86Config-4の手動編集もしてみたんですが変わらないのです。
で、もうダメポでヘルプと相成ったわけでございます。
噂によると、i845チップセットでは物によっては640x480しか表示されないと
という噂を聞いたんですが、情報ご存じの方おられるでしょうか?

>>128
http://www/debian.orgからapt-getできますよ。
詳しいことは事務所に帰ってソースみてここにカキコします。
(いま出先なもので・・・)




145 : :03/08/29 19:25 ID:9cj63ZvX
X の設定、俺はいつも xf86cfg -textmode を使っているよ。

146 : :03/08/29 19:26 ID:9cj63ZvX
あと、ビデオカードの種類は
cat /proc/pci で見てる。

147 :login:Penguin:03/08/29 19:30 ID:UE+wjMh+
>>144
http://www.xfree86.org/~dawes/845driver.html

それとapt-lineは本家じゃなくてミラー使ってね。
本家は開発者のために空けておくのがマナー。

148 :84:03/08/29 20:42 ID:5eBul728
メルコも試しましたが駄目でした。

149 :login:Penguin:03/08/29 21:15 ID:+Ii5K2eY
>>148
/etc/pcmcia/config.opts直さないと無理。
カードの名前でぐぐれば引っかかる。


150 :login:Penguin:03/08/29 21:19 ID:VGEAdcff
>>149
/etc/pcmcia/configじゃない?

151 :84:03/08/29 21:23 ID:5eBul728
ttp://pc.spo.to/chip/chip.html#LPC3−CLT
には/etc/pcmcia/configとかいてるのですが。
まぁ今から試してみまつ。

152 :84:03/08/30 00:05 ID:qlam/TMU
今、試してみたのですがメルコはちゃんと認識させることができました。
ping,DHCP全部OKです。
問題の三菱なんですがメルコのように/etc/pcmcia/configに設定したら認識はしたのですが、
モジュールが足りないようです。そこでぐぐったらoaknet.oなるモジュールがいるようなのですが
標準で入っていません。2.4.18用でもっておられる方おりましたらうpしてもらえないでしょうか?

153 :84:03/08/30 00:07 ID:qlam/TMU
sage忘れました。すいません。

154 :login:Penguin:03/08/30 00:11 ID:T7qwsfr6
>>150
最後でincludeしているのでどっちでもいいはず。


155 :login:Penguin:03/08/30 00:46 ID:AlVXfmQs
ところでカーネル2.2系で起動時にでてくるペンギンが手に持ってるのは何?

156 :login:Penguin:03/08/30 01:00 ID:Fx9CvJaf
>>155
素敵なサムシング

157 :84:03/08/30 01:16 ID:qlam/TMU
結局、いろいろしてみた結果三菱は駄目でした。
pcnet_csでも駄目です。
BUFFALOはpcnet_csで問題なく動きました。
今、それを使ってインスコ中です。
Pentium 75だけあってかなり遅いです。

みなさんありがとうございました。

158 :login:Penguin:03/08/30 02:00 ID:n9+sYsQI
>>155
free beer

159 :123:03/08/30 05:58 ID:TYLQNIk8
みなさま、お返事ありがとうございます。
>>133
試してみたけど、変化なしでした。これって、HOMEの.Xresourcesに追加で
いいんですよね?

>>130
xmodmap -pmしてみました。

xmodmap: up to 2 keys per modifier, (keycodes in parentheses):

shift Shift_L (0x32), Shift_R (0x3e)
lock Caps_Lock (0x25)
control Control_L (0x42), Control_R (0x6d)
mod1 Alt_L (0x40), Alt_R (0x71)
mod2 Num_Lock (0x4d)
mod3
mod4 Meta_L (0x73)
mod5 Scroll_Lock (0x4e)

と出ましたが。。。
知らない間にヘンテコなことでもしてしまったのでしょうか?

すみませんが、引き続きよろしくお願いいたします。

160 : :03/08/30 06:53 ID:2PcuRiJx
Folding@Home の様なプロセスが死んでいないか一定時間ごとにチェックして
死んでいたら起動してくれるようにするには
自分で ps の出力結果をパースするようなスクリプトを作って
crontab に登録するということでいいんでしょうか?

それとも Debian 流になにか統一的な手法が用意されているのでしょうか?

標準的なフレームワークが用意されているのであればそちらに従おうと思いまして。

161 :login:Penguin:03/08/30 11:52 ID:ROKzJALZ
>>160
<ぼそ>daemontools</ぼそ>

162 :login:Penguin:03/08/30 12:56 ID:sy1UWggE
XFree86.0.logとXFree86.8.logの違いって何?

163 :login:Penguin:03/08/30 14:04 ID:LE05Ca8B
xf86cfg -textmode で成功した試しがない。


164 :login:Penguin:03/08/30 15:50 ID:wBJShq3Q
>>162
0とか8ってスクリーン番号じゃネーノ?

XFree86をアップグレードする時にイジったXF86Config-4は上書きされないようになったな。
debconfがオリジナルファイルのmd5を保存しておいて比べてる?

165 :login:Penguin:03/08/30 19:03 ID:mNMZkZ6D
>>1 のサイト見ての非公式パッケージ mozilla-(browser|psm|xft) (1.4) を sarge
に入れました。
Bookmark Manager で移動とか削除とかしても何も反応がないんですが何がお
かしいんでしょうか?追加とか rename とかはできました。


166 :login:Penguin:03/08/30 20:06 ID:iyPbOwgV
>>165
sidの最新バージョンで修正された

167 :165:03/08/30 20:30 ID:mNMZkZ6D
>>166
既知の bug ということですね。sid のを入れようとすると libc6 のバージョ
ンも上げなきゃいけなさそうなので firebird を代わりに使っておくことにし
ます。


168 :login:Penguin:03/08/30 20:45 ID:UVf5b+UL
>>159
xmodmap -pke の結果を見ないと左右 Alt キーにどう割付けているのか
正確には判らないが、Meta 扱いされているかどうかよりも、Alt キーが押下
されたときは Esc として扱うように端末エミュレータの設定をすればよかろう

169 :login:Penguin:03/08/30 21:00 ID:UVf5b+UL
むむ、なんか文章がおかしくなってしまった。普通は >>133 の設定で
Esc を送るようになる筈だが、うまくいかないとすれば Alt が Meta 扱い
されてないのかもしれない。>>159 の結果だけを見るとその可能性が高い。

>>159 の状況でも xmodmap -pke したときに keycode 64 = Alt_L Meta_L の
ような行があれば Meta 扱いされるはず。そうなってなかったら
xmodmap -e 'keycode 64 = Alt_L Meta_L' などとして試してみる

170 :login:Penguin:03/08/30 21:09 ID:oZ0X00/E
root環境で
.xsessionに
kterm &
kinput2 &
exec startkde
ってやってるんだけど
kterm,kinput2がたちあがんない
たぶんkdeもここから立ち上がっていないのかもしれない

本来、rootでやることではないんだが
どうすればいいですか

お願いいたします、おしえてください

171 :login:Penguin:03/08/30 21:11 ID:NbXr/2Ld
debconfからshowoldが無くなったんだね。
どうも不便だ、、。

172 :login:Penguin:03/08/30 21:15 ID:uEbMWtmy
>>170
>たぶんkdeもここから立ち上がっていないのかもしれない
.xsessionをリネームしてみれば分かるだろ。
後はくだ質あたりでどうぞ。

173 :123:03/08/30 21:37 ID:TYLQNIk8
>>169
お返事ありがとうございます。
指摘のとおり、
$ xmodmap -pke | grep 64
keycode 64 = Alt_L
keycode 164 =
とでました。そこで、/etc/X11/Xmodmapに
keycode 64 = Alt_L Meta_L
と記述して解決です。無事にMetaとして動作します。

回答して下さった皆様、本当にありがとうございました

174 :login:Penguin:03/08/30 23:31 ID:yhoE/12Y
testing/xfree86 に次のパッチを当ててパケジを
作り直そうとしてるのですが
http://bugs.xfree86.org/show_bug.cgi?id=618

テンプレ通りに展開してみたところ、パケジ名の
ディレクトリ下にはxfree86本体のソースはなく、
upstreamという中にtar.gzに固められたままに
なってます。これを展開していじれば良いのか、
debianディレクトリ下のpatchというそれっぽい
中にdiffを入れるのか、教えてください。


175 :login:Penguin:03/08/31 00:10 ID:lWc6ZLvp
>>174 debian/patches/以下にdiffを置く。運が良ければ
適当にリネームしたパッチを放りこむだけでリビルドできる。
でもdebianのxserver-xfree86は大量にパッチが当たってるんで、
そのままじゃ上手く当たらない可能性も高い。その場合は>>121
みたいな感じでパッチを作り直す必要がある。


176 :login:Penguin:03/08/31 01:04 ID:KJ6UgO5s
>>175
ありがとうございました。一番最後の番号を
付けてpatchに入れてみたのですがやはり
当たらずエラーで止まったので、直後の出来かけ
build_tree下の(若い番号のパッチの当たった)該当
ファイルと差分をとり直してうまくいきました。


177 :login:Penguin:03/08/31 02:55 ID:gdJ3LLJm
>>173
もう解決したみたいだけど、
emacs は meta があると alt を meta として
扱ってくれなくなる。

178 :176:03/08/31 03:09 ID:KJ6UgO5s
あれからリビルド2時間後、エラーで終了しますた。

4.2.1のツリーは壊れてるので4.3.0を使えですと(がびーん
http://lists.debian.org/debian-x/2003/debian-x-200305/msg00119.html

179 :login:Penguin:03/08/31 03:17 ID:KJ6UgO5s
>>178
よく読むと壊れてるぢゃなくて is dead ですた。
あと、 flex-old を使うという選択肢もあると書いて
ありますた。deb-srcがリビルド出来ない状態の
場合もあるってことを初めて知りますた (´・ω・`)


180 :login:Penguin:03/08/31 03:28 ID:lWc6ZLvp
>>178 あぁ、flex絡みか。御愁傷様です。
パッケージがアーカイブに入ったあとにbuild-depends
しているパッケージが下位互換なしに上がったりすると、
どうにもしようがないからなぁ...

flex-oldでしのぐのが手っ取り早いんかな


181 :Sh-Route:03/08/31 23:54 ID:a4bb4FOD
Debian woody3 にて CASIO カシオペア206VLを使っているどす。halt で自動電源オフを実現させようと頑張っておりますが、power off と表示されてからは、手動で電源を落さなくてはいけない状態がなお続いております。

kernel-source は 2.5.0 を使ってます。設定では、General setup 以下にある Power Management support を y 、Advanced Power Management BIOS support 以下は、Make CPU Idle calls when idle は y、それ以外は n に設定し、コンパイル&インストール済です。

また、lilo の該当設定部分は以下のとおりです。

 # Boot up Linux by default.
 #
 default=Linux
 
 image=/vmlinuz
 label=Linux
 read-only
 append="apm=power-off"
 #restricted
 #alias=1

Anti M$ の大変さ(求められる能力の高さ)を痛感しておりますです…。めげそうですが、なんとか頑張って行きたい。

どなたかお心あたりのある先達、どうかご教示を…。

182 :login:Penguin:03/08/31 23:59 ID:KJ6UgO5s
>>180
flex-oldにしてやり直しました。
4時間後...
3ギガ食い尽くして no left space on device....
sidに取り込まれるのを待つことにしますた。


183 :login:Penguin:03/09/01 00:03 ID:IcF72fXD
>>181

# modprobe apm
をしてから
# halt
したら切れる?
それなら起動時に modprobe apm が実行されるように /etc/modules.conf に書くだけ。

184 :login:Penguin:03/09/01 00:22 ID:tNNMGBN6
>>181
halt -pしたらどうなる?

>>183
おいおい、そのファイルの先頭あたりを読めよ。
>Please do not edit this file directly. If you want to change or add
>anything please take a look at the files in /etc/modutils and read
>the manpage for update-modules.
>This file is automatically generated by update-modules"

185 :login:Penguin:03/09/01 00:42 ID:gJXxDQtb
/etc/modules に書けばいいんでしょ。起動時にロードしたい module.

# /etc/modules: kernel modules to load at boot time.
#
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line. Comments begin with
# a "#", and everything on the line after them are ignored.


186 :login:Penguin:03/09/01 01:31 ID:zYcmO5JM
複数のカーネル使い分けてると、
/etc/modules の内容もカーネルによって分けたい時があります。


187 :login:Penguin:03/09/01 01:46 ID:tNNMGBN6
それなら/etc/init.d/modutilsあたりをイジればいいのでは。

つか1つのシステムでカーネルを使い分けたくなる例を知りたいな。

188 :login:Penguin:03/09/01 01:47 ID:r932ysqC
>>187
> つか1つのシステムでカーネルを使い分けたくなる例を知りたいな。
あるバージョンのカーネルがどうも調子悪くて、
複数バージョンのカーネルをとっかえひっかえして試してるとき。

189 :login:Penguin:03/09/01 01:50 ID:tNNMGBN6
それは
>使い分けてる
というのかね?

190 :login:Penguin:03/09/01 01:54 ID:r932ysqC
言わないの?

191 :login:Penguin:03/09/01 05:50 ID:N9St10RD
apt-listbugs が締め出されて不便になった

192 :login:Penguin:03/09/01 09:28 ID:gn6s1Jzy
>>183
acpiの関係なのか誤動作することがあるので、
自分は halt する直前にmodprobe apmするようなスクリプトを書いて
login: halt
で呼び出すようにしてる(interlinkの場合ね)。


193 :174:03/09/01 15:39 ID:AkTW0v5v
>>182 みたいな感じでパケジまでは
作れなかったけど、目的のファイルは
出来てたので(ximcp.so.2)、stripして
famにうpしました。testing用っつうか
xfree86 4.2.1-6版です。

自分の環境ではmacromediaのトップページでも
落ちなくなってちゃんと動いてるっぽい。


194 :login:Penguin:03/09/01 16:04 ID:HAl/8QQt
ワロタ
http://osnews.com/comment.php?news_id=4381

>>193
最近のMozillaだとflash6絡みで落ちるんだっけ。
mozilla-firebird 0.6だと落ちないんだけどな。

てかgconfdを起こすのが標準になったのか?

195 :login:Penguin:03/09/01 18:31 ID:5F0DTz4d
>>99
apt-listbugs(0.0.23)で直ってるみたい。
まだ試してないけど。

196 :login:Penguin:03/09/01 18:53 ID:1T+zlSmY
sidでmodconfが横幅はみ出して表示されたり
モジュール選択しても、前の画面に戻ったりしてしまうんですが
これはwhiptailの問題なのでしょうか、
それともlibnewt0.51の問題なのでしょうか、
はたまた設定でなんとかなるもんでしょうか。


197 :login:Penguin:03/09/01 19:50 ID:f5QDsU9I
aptでgzipをアップデートしようと思って
$ sudo apt-get install gzip
すると。以下のようなエラーが出ました。

gzip 1.3.2-3 を(.../gzip_1.3.2-3woody1_i386.deb で)置換するための準備をしています...
install-info: dir ファイルが指定されていません -- 詳しくは --help 付で実行して下さい。
dpkg: 警告 - 古い pre-removal スクリプト がエラーステータス 1 を返しました。
dpkg - かわりに新規パッケージからスクリプトを実行してみます...
install-info: dir ファイルが指定されていません -- 詳しくは --help 付で実行して下さい。
dpkg: /var/cache/apt/archives/gzip_1.3.2-3woody1_i386.deb の読み込みエラーです(--unpack):
サブプロセス 新 pre-removal スクリプト はエラー終了ステータス 1 を返しました。。
install-info: そのようなファイルやディレクトリはありません General Commands
dpkg: クリーンアップ中にエラーが発生しました:
サブプロセス post-installation script はエラー終了ステータス 1 を返しました。
以下のパッケージの処理中にエラーが発生しました:
/var/cache/apt/archives/gzip_1.3.2-3woody1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

このあとに他のパッケージをインストールしようと思っても
gzipの設定が残っているらしく、このエラーがでてとまってしまいます。

gzipの設定をキャンセルする方法、
またはこのエラーの修正方法(install-infoがおかしいんでしょうか?)
はありますか?


198 :login:Penguin:03/09/01 20:07 ID:1T+zlSmY
>>197
apt-get checkは試した?

199 :197:03/09/01 20:47 ID:f5QDsU9I
apt-get checkを行うと
Reading Package Lists.. Done
Building Dependency Tree.. Done
となり、
その後に
apt-get install gzip
をしても197と同じエラーが出てとまってしまいました。


200 :login:Penguin:03/09/01 20:57 ID:1T+zlSmY
--fix-brokenとかは?

201 :197:03/09/01 21:08 ID:f5QDsU9I
>200
すいません。だめでした。同様です。

202 :login:Penguin:03/09/01 21:35 ID:PYM7qsou
apt-get remove --purge gzip

203 :197:03/09/01 21:56 ID:eQutuvIO
>202
apt-get remove --purge gzip
を試してみました。

Reading Package Lists... Done
Building Dependency Tree... Done
The following packages will be REMOVED:
gzip*
WARNING: The following essential packages will be removed
This should NOT be done unless you know exactly what you are doing!
gzip
0 packages upgraded, 0 newly installed, 1 to remove and 27 not upgraded.
1 packages not fully installed or removed.
Need to get 0B of archives. After unpacking 197kB will be freed.
You are about to do something potentially harmful
To continue type in the phrase 'Yes, do as I say!'
?] Yes, do as I say!
dpkg - 警告、--force が有効なため、問題を無視します:
これは必須(essential)パッケージです。- 削除すべきではありません。
dpkg: gzip の読み込みエラーです(--purge):
パッケージが非常に矛盾した状態に陥りました。
削除を行うまえにこのパッケージを再インストールするべきです。。
以下のパッケージの処理中にエラーが発生しました:
gzip
E: Sub-process /usr/bin/dpkg returned an error code (1)

非常に矛盾した状態に陥ったそうです。
消すこともできません。
何度もすいません。


204 :login:Penguin:03/09/01 22:14 ID:XWqYBDea
遅レスな上にどうでもいいことだが、
>>190
およそまともな日本語教育を受けたものであれば、
外人であろうといわない。

205 :login:Penguin:03/09/01 22:40 ID:WXhKjq/O
sidからdebを(aptを使わずhttpかftpで)ぱちってきてdpkgで入れる
とかad hocなことを言ってみる。

206 :login:Penguin:03/09/01 22:47 ID:bcBpQUj7
>>205
同意

/var/cache/apt/archives に古いパケジないかな?


207 :login:Penguin:03/09/01 23:13 ID:WXhKjq/O
つーかaptがDLしたパケジ自体が破損してる可能性もあるから、一度apt-get cleanしようよ(もうしてるかな)
で、それでapt-get install gzipしても入らないならsargeなりsidなりのdebをftpから直接ぱちってきてdpkgで入れる。

#とかsidしか使ってない奴が無責任なことを言う。

208 :Sh-Route:03/09/01 23:40 ID:0MP3MM7c
レス、本当にありがとうございました。

アノ書き込みしたあと普通に halt したら、
電源が自動で落ちました。

鬱田死膿…


209 :login:Penguin:03/09/02 01:09 ID:5izvItPI
sid 使うなといわれるかも知れないが、
inetutils やっぱ困るな。

210 :login:Penguin:03/09/02 03:19 ID:8T7WCmx+
>>209
そんなげすなものを使うなというメンテナからの愛の鞭です。

211 :login:Penguin:03/09/02 12:40 ID:GbMfHldb
kylix3_openインストールしようとしたら

警告 : 場所が見つかりません libX11.so

と表示されてしまった。でもこれを無視してインストールしてしまった。
やっぱ問題有りですかね?

212 :login:Penguin:03/09/02 14:40 ID:mIPn6kei
>>211
libX11.so自体は、xlibs-devをインスコすれば入ると思うけど。

たしか、CDにあったテキストファイルに色々書いてあったぞ。
その中には、Debian向けの注意書きもあったので、ちゃんと嫁。

で、うちではWoody上で無問題で動いてるよ。 > Kylix3
(ただし、dbExpress絡みのバグの部分は除く)
遅いけどな。


213 :login:Penguin:03/09/02 15:23 ID:GbMfHldb
>>212
>xlibs-dev
入ってなかったんでaptで入れました。
どうも有難うございました。

214 :197:03/09/02 19:45 ID:WKT1cQqa
>205,206,207
言われたようにやってみましたが、やっぱりだめでした。

エラーメッセージをみるとinstall-infoがおかしいみたいなので、
半ばやけくそに、install-infoを実行しているところを全部コメントアウト
してdpkg-deb -b でdebを作り直してdpkgしたら入ってしまいました。

これでいいのかどうかわかりませんが、なんか動いてるみたいです。

いろいろ、ありがとうございました。


215 :215:03/09/02 21:36 ID:LhVVncQF
はじめまして、教えて君で、すみません
kon で naga10 を使いたいのですが、うまくいきません。
動いている方、おいでになられましたら /etc/kon.cfg の naga10 の設定行のみ教えて頂けませんでしょうか。

216 :login:Penguin:03/09/02 21:49 ID:XojqSnfq
>>215
くだらねえ質問はここに書きこめ! Part56
http://pc.2ch.net/test/read.cgi/linux/1061972689/

217 :215:03/09/02 22:17 ID:LhVVncQF
>>216
誘導ありがとうございます。
kon.cfg による naga10 化は googling してもヒットしなかったんです。
>>1 の中にも存在しないし。
debian ユーザーにはくだらない質問だったんですね。
お騒がせして、すみませんでした。

218 :login:Penguin:03/09/02 22:22 ID:XojqSnfq
>>217
>Debian に特有ではない Linux の一般の質問についてはできるだけくだ質でどうぞ。
読めよ。

219 :login:Penguin:03/09/03 00:00 ID:RpKc1xuI
ていうか、debian のsendmail とかapache2とかさ、debian ポリシーに基づいた独自のカスタマイズがかなり多いんですけど。。
標準的に設定したいです。


220 :login:Penguin:03/09/03 00:23 ID:aphAeqVB
ほとんど独自のカスタマイズをしてないメジャーなディストロなんてあったっけ?

221 :login:Penguin:03/09/03 00:45 ID:vnqjQ3aY
全てのアプリをデフォルトのインストールのままにして
整合性とれるのかな。

222 :login:Penguin:03/09/03 01:06 ID:ci6bfC2L
>>220
219は「独自のカスタマイズがかなり多い」と言っているので、
独自カスタマイズをなくせと言ってるわけではないでしょう。

で、俺もdebianはちょっと多すぎるなぁと思っている。
インストール先のpathや、ある程度のサンプル設定ファイルまではわかるけど、
かなり凝った設定がインストール後にすぐ有効になっている例が多いかなぁ。
なんか気持ち悪い。
基本的にお気楽極楽人向けだから、それでもいいんだろうけど・・。

223 :login:Penguin:03/09/03 01:23 ID:WE/PJgcV
逆にdebian policyに合わないpackageは嫌なんだが…面倒ですよ。

> 基本的にお気楽極楽人向けだから、それでもいいんだろうけど・・。

debian policyで一貫されていると楽なのは確かだけど、
policyが一貫してないデストリはお気楽というか安易だと思う。


224 :login:Penguin:03/09/03 01:44 ID:1Aska+o+
煽りじゃなくてお聴きしたいんですが、

Debianのポリシーのせいで不便を感じる
(例: gnuplotのreadline)ユーザは
どのディストリを使えば良いでしょうか?
依存関係を自動で解決してくれるものが良いのですが...

225 :login:Penguin:03/09/03 01:47 ID:aphAeqVB
>>222
>標準的に設定したいです。
って言ってるんだから、大筋で
>独自カスタマイズをなくせ
って事に繋がってるんじゃないのか?

そもそも何でポリシーガチガチのディストロを選んだのか謎だな。
ユルユルのディストロが山のようにある中で。

>>224
スレ違い
http://pc.2ch.net/test/read.cgi/linux/1047973777/

226 :224:03/09/03 01:57 ID:1Aska+o+
>>225
すみません、逝ってきます。

227 :222:03/09/03 02:16 ID:ci6bfC2L
>>225
あ、ごめん。
俺はpolicyに文句つけてるんじゃなくて、
policy外(だと思う)で、大きなお世話な設定が多いような気がしているのです>debian
今、debian使ってないので具体的には思い出せないのですが(弱い)
そう感じている人少ないのかなー

228 :login:Penguin:03/09/03 02:35 ID:f+Yr9Uj8
>>227
どうせほとんどの香具師は自分で設定し直すだろうから、
特別に問題があるような設定じゃなければどうでもいいような。
それにそのぐらいの設定の方が、まったくの初心者にはうれしいと思うが。

んなこたぁねえのかね。

229 :login:Penguin:03/09/03 03:13 ID:N6s/TOCK
Debian自体はポリシーガチガチな割に、個々のパケジは微妙にメンテナごとの癖あったりするからなぁ。
標準的な環境を想定したドキュメントが利用しにくいってのはちょっと欠点かも。
野良でmakeしたら入ってないはずの機能が入ってたりして入ってない前提で書かれててはまったり。
あと脈絡無く設定方法をがらっと変えたりされると参る。Apache2には正直参った。

まあ明らかにメンテナ発狂してるパケジもあるから最終的には/usr/localを使う思い切りがあれば何とかなるかと。

230 :login:Penguin:03/09/03 05:00 ID:WE/PJgcV
README.Debianとdpkg -Lくらいは常にみるけど、
README.Debianにほとんど記述がないpackageがあるのは確かだな。

231 :Linux自体初心者ですが:03/09/03 10:33 ID:347rw0u7
>>229
>標準的な環境を想定したドキュメントが利用しにくいってのはちょっと欠点かも。
激しく同意。
どこに設定ファイルあるんだ?って思うときがしばしば。

232 :login:Penguin:03/09/03 10:36 ID:i7ZqXQ1A
>>231
たいてい /usr/share/doc/パッケージ名/README.Debian に書いてあるよ。

233 :login:Penguin:03/09/03 10:38 ID:ml7oWWY9
>>231
README.Debian みてもワケワカだったら、遠慮なくBTSしたってください。


234 :231:03/09/03 11:01 ID:OQjpzEh2
なんとなく書いたものにレスがついてる…
>>232, >>233
すいません、ありがとうございます。
README.Debianを見て頑張ります。

235 :login:Penguin:03/09/03 12:51 ID:OBGyot/S
>>224
ややオフトピではあるのですが、gnuplot の readline は
ライセンス衝突でバイナリ配布が禁止されてるのだから、
配ってるほうがおかしい、というかマズイ。これは自分で
作るしかないっすよ。


236 :196:03/09/03 13:51 ID:85Rhuk+m
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=206616
報告はされてるみたいですた。

237 :login:Penguin:03/09/03 21:00 ID:vSIVFrjM
Sargeをインストールしています。
floppyドライブは物理的にありあません。CDROMからネットインストを試みています。
3. Detect CDROM devices and mount the CD in /cdrom (default)
Prompt: yes/no, default=no>CR
--略--
9. mcdx を選択
[defalust = /dev/mcdx]>/dev/mcdx
--略--
Prompt: 1-6, default=Detect CDROM devices aand mount the CD in /cdrom>
Loading kernel modules
A driver floppy is a ext2 floppy with one file modules.tgz. The content of
modules.tgz is unpackaged in the installation system root directory.
Prompt: yes/no, defalult=no>
結局floppy無いとインストール出来ないという事でしょうか?
識者の方々アドバイスくださいm()m

238 :login:Penguin:03/09/03 21:05 ID:aVP/WGnX
>>237
woodyからsargeにあげる方法は、眼中になしでしか?

239 :login:Penguin:03/09/03 21:17 ID:fm2rIW3a
>>238
アドバイスありがとう御座います。
Sergeのインストーラではまだ一般的にインストール出来るようになっていないという意味なのかな・・。
まずWoodyをインストしてアップデートするのが大多数であると理解すべきでしょうか。
Sargeのインストーラを見るとwoodyのnet-inst触る気がしなくなったのです^^;

240 :login:Penguin:03/09/03 21:45 ID:XLgN3Zx+
a

241 :239:03/09/03 22:31 ID:5cBbTklQ
勝手で申し訳ありませんがfloppy取り付けて再度チャレンジすると
問題なくクリアされました。
ただ今netinstallが無事に進んでいますのでこれでよしとします。
皆さんアドバイスありがとうございましたm()m

242 :login:Penguin:03/09/03 22:39 ID:UMfkMOv3
勝手すぎ

243 :login:Penguin:03/09/03 22:52 ID:nBqF4H4Z
sidでnvidiaのドライバ動かなくなったんだけど・・・

244 :219:03/09/03 23:49 ID:TeFJhaze
>>225
独自カスタマイズをなくせとまではいわないけど、独特の設定が多すぎると思ってます。
今、複数のOS のサーバを数10台管理しています。大抵のOSにおいてはapache2 とか
設定ファイル、起動スクリプト等の使い回しが簡単にできるのですが、Debianでは簡単に
できず、カスタマイズするのが面倒だと感じました。

>そもそも何でポリシーガチガチのディストロを選んだのか謎だな。
>ユルユルのディストロが山のようにある中で。
1年でerrata が利用できなくなるようではredhat はもう使用できないかなと・・・
DebianはOSまるまるアップグレードできて、サーバには向いているように感じました。


245 :login:Penguin:03/09/03 23:59 ID:N6s/TOCK
>>244
個々のメンテナがおかしいのであって、Debian全体としてはetcコピって使い回しやすい設計だと思うけど。
Debianのapache2は設定法が不便だってのは俺も思うけどさ。

246 :login:Penguin:03/09/04 00:25 ID:Iw98HThC
>>244
>1年でerrata が利用できなくなるようではredhat はもう使用できないかなと・・・
本家Errata提供期間終了後、3年間Errata提供をサポートするサービスもあるようだが。
http://slashdot.jp/article.pl?sid=03/04/11/0523221

247 :login:Penguin:03/09/04 00:30 ID:vvH90o7B
MIRACEL が声高く優位と主張してるぞ(藁

http://www.miraclelinux.com/pressroom/details/2003020401.html

248 :login:Penguin:03/09/04 00:43 ID:qAbAducg
>>31
どう。不便ですか?
html が生で表示されて v 押さないといけないだけなら、
ruby の Tempfile で .html 拡張子付けられるようにして patch ください。
または、Tempfile の initialize をオーバライドするでもいいですが
これは TODO です。

249 :219:03/09/04 00:48 ID:UoKsRKu2
>>245
ようやく、Debian用に各種ソフトウェア用設定ファイル移行完了しました。
これで、今後Debian 来ても大丈夫。。
>>246-247
ていうか、お金がありません・・・察してください。

250 :login:Penguin:03/09/04 00:51 ID:qAbAducg
>>99
というか本来 Pin-Priority: -1 は man 的には動くべきなんだけど、
aptのソースみると特定のパッケージに対しては -1 は動かないみたい。
というか、-1 以外にも動作がいろいろ変すぎるので、直してください。

251 :login:Penguin:03/09/04 01:19 ID:qAbAducg
>>77
ここ最近鬼のようにSPAMが来るようになって、doogie が spamassassin いろいろ
いじったから, masterが重くなったすぎ。ので、apt-listbugsのせいじゃない
のです。そもそも平均して 10 秒に 1 アクセスしかないのに、そんなに重くなる
はずがない。cgiのパースしてた時は重かったけど、今は static file を
download してるだけだし。

まぁ、それは別として master 上で動かすのは、あまり良くないので
いまは misato.debian.or.jp にミラーサイトをこさえてあります。
なんか、少し遅い気がするけど、柏のせいかな。それと、海外から
の要求にどれだけ高速にこたえられているのか気になるところ。
しばらくしたら統計とろうかしら。バグもたまってきたし、TODO 多し。

252 :login:Penguin:03/09/04 01:22 ID:G3nuPbB5
Lindowsのせいで、debian大迷惑

253 :login:Penguin:03/09/04 05:14 ID:F2zC1k5T
>>252
えれー祭になってるな。 > Lindows
正直おぢさんはもうついていけません。


254 :login:Penguin:03/09/04 10:08 ID:wbGlmjXU
Lindowsってそんなにはやってるのか?
秋葉で売ってるの見たけど、全然売れてなかったぞ。


255 :login:Penguin:03/09/04 10:11 ID:iqtxKcyn
>>252-254
ヨソでやれや

256 :login:Penguin:03/09/04 10:34 ID:OjZ8QjI5
話題になるのは流行ってるというよりも……

257 :login:Penguin:03/09/04 11:21 ID:5AEY1I+M
woody使ってます
kernel を再構築するために make menuconfig しようとすると以下のようなエラーがでます

/usr/bin/ld: cannot find -lncurses
collect2: ld returned 1 exit status

>> Unable to find the Ncurses libraries.
>>
>> You must have Ncurses installed in order
>> to use 'make menuconfig'

make[1]: *** [ncurses] Error 1
make[1]: Leaving directory `/usr/src/linux-2.4.22/scripts/lxdialog'
make: *** [menuconfig] Error 2

インストールされてる ncurse 関連のものは以下の通りなんですが何が足りないのでしょうか?
# dpkg -l |grep ncurse
ii libncurses4 4.2-10 Shared libraries for terminal handling
ii libncurses5 5.3.20030719-1 Shared libraries for terminal handling
ii ncurses-base 5.3.20030719-1 Descriptions of common terminal types
ii ncurses-bin 5.3.20030719-1 Terminal-related programs and man pages
ii ncurses-term 5.2.20020112a- Additional terminal type definitions


258 :login:Penguin:03/09/04 11:23 ID:OjZ8QjI5
>>257
-dev

259 :login:Penguin:03/09/04 11:29 ID:5AEY1I+M
>>258
ありがとうございます

260 :login:Penguin:03/09/04 13:14 ID:aH+nWA2e
架空 NOC の中の人もたいへんだな。

261 :login:Penguin:03/09/04 22:41 ID:BxdMdIr2
p2のお気に入り共有にここが結構上位で食い込んでた
俺がその一人だけど他の人は何で見に来てるんだろう
やっぱnavi2chとかなのかな?

262 :login:Penguin:03/09/04 23:01 ID:yGHf9gDe
navich とかは?

263 :login:Penguin:03/09/05 00:09 ID:Kfa8nOoI
アンチエイリアスな mozilla を sarge で使いたいけど。。

Backports from sid for woody なやつはブックマークおかしいし、sid のは
libc6 まで上げなきゃいけないし、source から checkinstall しようとした
らバックアップかなんかでディスク不足エラーになるし、、どうしたらいいの
? firebird も何だか mozilla と違いすぎて馴染めないなぁ。


264 :login:Penguin:03/09/05 00:35 ID:kNE3ROAa
0.9.9以降ならAAかかるはずだが…。
sarge使ってないからなんとも言えんが。

コンパイルできないならmozilla.orgのバイナリ使えばいいじゃん。
展開してmozillaスクリプトから/usr/local/binあたりにリンク張るだけで使えるし。

265 :login:Penguin:03/09/05 09:31 ID:N0rBR+3H
exim の件 testing の人はどうすれば良いのかな?
unstable の 3.36-8 入れるのか、それとも待ってれば testing に来るのか…。
こないだ testing にしばかりで、こういう時の対応が分からないです。
アドバイスお願いしますー。

266 :login:Penguin:03/09/05 13:09 ID:qT7SwOm5
Woody で kernel-source と pcmcia-source を使って
kernel-image と modules-image を make-kpkg して得られた
kernel-image と pcmcia-modules を dpkg -i しました。

ところが pcmcia スロットにカードを挿しても
ide_cs: Card Services release does not match!
pcnet_cs: Card Services release does not match!
と言われて動きません。pcnet_cs のほうはカーネル内蔵の
ドライバを使えば良いけど ide_cs はカーネルに入ってないので
pcmcia-modules の動かし方を教えてください。

pcmcia-source は 3.1.33-6woody1 と 3.2.2-1.1
kernel-source は 2.4.21-5 と 2.4.20-11
を試しました。



267 :login:Penguin:03/09/05 13:17 ID:Ew0bFfaE
>>266
これか?
http://lists.debian.or.jp/debian-users/200208/msg00396.html

268 :login:Penguin:03/09/05 14:16 ID:qT7SwOm5
Thanks!
Googleで引っかからなかったので気付きませんでした。

カーネルの drivers/pcmcia/ じゃなくて
drivers/ide/legacy/ のほうにあったのですね。


269 :login:Penguin:03/09/05 15:51 ID:AQmKvvSY
apt-listbugs が使えないと不便なので unstable のものをインストールしたけど、
www-browser が w3m だとソースが表示されてしまうね。-T text/html などと
しないと

270 :login:Penguin:03/09/05 16:12 ID:GN7Ok8Z0
>>269
それ直ってるよ。


271 :login:Penguin:03/09/05 19:42 ID:uULMCK10
apt-getでdebconfが勝手に動くのって何とかならないんですか?

Xの設定をいちいち訊いてきて上書きする、などなど。ほんとに余計なお世話なんだけど。


272 :login:Penguin:03/09/05 20:00 ID:Ew0bFfaE
dpkg-reconfigureした時にdebconfで管理するか聞かれなかったか?

sidの最新版だと上書きされなくなったけど。

273 :login:Penguin:03/09/05 20:58 ID:GN7Ok8Z0
>>271
See /etc/apt/apt.conf.d/70debconf


274 :login:Penguin:03/09/05 22:28 ID:acIZnijW
LindowsOS4.0日本語版バンザーイ!
エッジもなかなかやるねぇ〜。
これで、パソコン界の天下が取れるぜ?

んなわけないな!
Debianよしみでレスしました。

275 :login:Penguin:03/09/05 22:31 ID:7j3snkI2
>>274 誘導

【edge】Lindows 4.0 Part1【日本語版】
http://pc.2ch.net/test/read.cgi/linux/1062297379/l50


276 :login:Penguin:03/09/05 22:40 ID:AQmKvvSY
>>270
おお、本当だ。間の悪いレスをしてしまった(w

277 :login:Penguin:03/09/05 22:42 ID:d7DRhbx0
apt-listbugってEUC-JPで通る?
/etc/apt以下にはそれっぽい設定項目は無いみたいだし
LANG=Cにしとけば通るんだけど何か悔しい気がするんだよな
英語じゃ困るって事も無いんだけど…

278 :login:Penguin:03/09/05 22:45 ID:pjrPbCyH
すいません、ちょっと質問させてください。
apt-get upgrade したらX-windowが
立ち上がらなくなってしまいました。
どうやらxserverのバージョンが変わったみたいです。

#dpkg-reconfigure xserver-xfree86
で再度設定したらrootでは起動するのですが
一般ユーザーでは起動しません。
起動に失敗すると
Couldn't load XKB keymap, falling back to pre-XKB keymap
のようなメッセージがでるのですがどうもよくわかりません。

どうすれば一般ユーザーでXを起動できるでしょうか。

279 :login:Penguin:03/09/05 23:59 ID:9CKPDZ0X
>>278
http://debian.fam.cx/?FAQ#content_1_21

それと一体woody,sarge,sidのどれつかってるのよ。

280 :login:Penguin:03/09/06 00:12 ID:2vEWltBv
dpkg-reconfigure xserver-xfree86

なんて、まともなもの吐いたこと無いな・・・

xf86cfgで雛形作って、直接編集になるんだよな、結局。


281 :278:03/09/06 00:26 ID:Ytfmqaps
失礼しました。
状況は以下のようになっています。

$ cat /var/log/XFree86.0.log | grep -nv '(WW) warning, (EE) error,' > $HOME/0.log ; \
grep '(WW)' $HOME/0.log ; grep '(EE)' $HOME/0.log ; rm -f $HOME/0.log

34:(WW) The directory "/usr/lib/X11/fonts/cyrillic" does not exist.
41:(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
442:(WW) NV(0): config file hsync range 28-49kHz not within DDC hsync range 30-86kHz
443:(WW) NV(0): config file vrefresh range 43-72Hz not within DDC vrefresh range 50-130Hz

debian:~# dpkg -l | grep xfree
ii xfree86-common 4.2.1-3.woody3 X Window System (XFree86) infrastructure
ii xserver-xfree8 4.2.1-3.woody3 the XFree86 X server

debian:~# lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation Riva TnT2 Ultra [NV5] (rev 11)

よろしくお願いします。

282 :login:Penguin:03/09/06 00:28 ID:L11fk1ef
自分で選択するのに「まともなもの吐いたこと無い」って…。

283 :278:03/09/06 00:29 ID:Ytfmqaps
書き忘れました。
今使っているのはwoodyです。
度々すみません。

284 :login:Penguin:03/09/06 00:39 ID:Ue4BIMyk
先日Xのインストールしたけど、前回インストールしたのがslackware95だったため
どうしていいか分からず手書きした……

285 :265:03/09/06 00:52 ID:0VLyvD51
>>265
testing で exim 使ってた人はみんな exim4 か他の MTA に
乗りかえちゃったのかな。
とりあえず unstable から exim 3.36-8 を借りて入れました。

以前、誰かが Sarge の Default MTA を何にするか?議論
http://lists.debian.org/debian-devel/2003/debian-devel-200307/msg00780.html
を紹介してて、こないだスレッドを一通り読んでみたけれど
結論は出ていないみたいだね。
exim4 か postfix かで議論があって、他には local delivery だけに
しようなんて話もあったみたい。

286 :login:Penguin:03/09/06 01:19 ID:UzM5l/le
exim3 はそのうち消える運命なのかな。
乗りかえ面倒だ。

287 :login:Penguin:03/09/06 01:41 ID:JDkGnpol
一つ御教授下さい。

今ATAPI接続のCD-R/Wに書き込みをしようとしています。

# cdrecord -scanbus
では上手く認識されているのですが、

# cdrecord -dummy -eject -v dev=0,0,0 speed=4 hoge.iso
Cdrecord 2.01a16 (i686-pc-linux-gnu) Copyright (C) 1995-2003 Jg Schilling
TOC Type: 1 = CD-ROM
(省略)
cdrecord.mmap: Sorry, no CD/DVD-Recorder or unsupported CD/DVD-Recorder found on this target.
#
となってしまい、うまく書き込みをしていません。そこで
lsmodではide-scsiとsgは見えていますが、
これ以外にsr_modが必要かと思い(あまりこの辺が理解できていません)、

#modprobe sr_mod
としても
modprobe: Can't locate module sr_mod
と言われてしまいます。
この場合、カーネルの設定をどの様にしたら良いんでしょうか。

kernel-sourceのディレクトリ以下には
sr_mod.cというようなものが無かったのですが...



288 :login:Penguin:03/09/06 01:43 ID:JDkGnpol
debian固有の話ではないのかもしれません...
よくわからなかったもので、すみません。
スレ違いでしたら申し訳ありません。

sargeを使っています。
kernelは2.4.20です。

289 :265:03/09/06 02:31 ID:0VLyvD51
>>286
exim3 の開発は既に upstream で終了してるようです。
議論の中にもありましたが、これは必ずしも exim4 に乗り替えなきゃいけないとか
パッケージが exim3 -> 4 への upgrade をサポートしなきゃいけないとかと言う
話では無いようです。
あくまで Sarge をインストールした時に入る default mta を何にする?という
議論らしいです。
(伝聞調なのは元が英語の議論なので…。)
たぶん exim3 はそのままメインテナンスされていくんじゃないかと思いますが。


290 :login:Penguin:03/09/06 03:23 ID:xSMau5x1
KDE no Konqueror kara kakiko !
null po

291 :login:Penguin:03/09/06 08:17 ID:JjAhe2o5
  ( ・∀・)   | | ガッ
 と    )    | |
   Y /ノ    人
    / )    <  >__Λ∩
  _/し' //. V`Д´)/
 (_フ彡        /  ←>>290


292 :login:Penguin:03/09/06 11:24 ID:W0aZzofG
>>287
scanbusの結果とか、ドライブの型名を書かないのはなんで?
sr_modはいらんと思ったが。
作りたければCONFIG_BLK_DEV_SR=y。



293 :login:Penguin:03/09/06 11:48 ID:0K7fUzpn
ムトゥ神って仏でもあるんだな。
「ふぉーとらん」話見てて溢れる涙が止まらなかったよ。


294 :login:Penguin:03/09/06 11:58 ID:1SQweQSC
>>293
優しいんだよね。「餌をあげちゃだめ(わら」とか口は悪いけど



295 :278:03/09/06 12:09 ID:Ytfmqaps
警告を参考にXF86Config-4を書き換えてみましたが、
やっぱりrootじゃないとXが立ち上がりません。
一般ユーザーだと一度Xの画面になって、網目模様の背景の画面で
落ちてしまいます。この時、マウスを動かすときちんとポインターも動いてくれます。

とりあえず警告は少なくなりました。
Couldn't load XKB keymap, falling back to pre-XKB keymap
ってメッセージはjp106キーボードを指定すると出るみたいです。
jp106のキーボードを指定しなくてもXの起動には関係ないみたいですね。

現在の状況は以下のようになってます。
$ cat /var/log/XFree86.0.log | grep -nv '(WW) warning, (EE) error,' > $HOME/0.log ; \
grep '(WW)' $HOME/0.log ; grep '(EE)' $HOME/0.log ; rm -f $HOME/0.log

41:(WW) Open APM failed (/dev/apm_bios) (No such file or directory)

debian:~# dpkg -l | grep xfree
ii xfree86-common 4.2.1-3.woody3 X Window System (XFree86) infrastructure
ii xserver-xfree8 4.2.1-3.woody3 the XFree86 X server

debian:~# lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation Riva TnT2 Ultra [NV5] (rev 11)

woody使ってます。
先人のみなさま、アドバイスお願いします。

296 :login:Penguin:03/09/06 12:40 ID:/xqn9KcN
>>295
.xinitrcか.xserverrcか.xsessionの書き方がおかしいんじゃないの。

297 :login:Penguin:03/09/06 12:52 ID:Vn3bi+VV
>>295
xlibs パッケージも気になる


298 :login:Penguin:03/09/06 13:04 ID:JDkGnpol
>>292
> >>287
> scanbusの結果とか、ドライブの型名を書かないのはなんで?
失礼しました。レスが長すぎるかな、と思って勝手に省略して
しまいました。scanbusの結果は

Cdrecord 2.01a16 (i686-pc-linux-gnu) Copyright (C) 1995-2003 Jg Schilling
Linux sg driver version: 3.1.25
Using libscg version 'schily-0.7'
scsibus0:
0,0,0 0) 'HL-DT-ST' 'DVD-ROM GDR8081N' '0012' Removable CD-ROM
0,1,0 1) *
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *

です。またドライブはthinkpad用のウルトラベイ2000です。

> 作りたければCONFIG_BLK_DEV_SR=y。
CONFIG_BLK_DEV_SR=m
CONFIG_BLK_DEV_SR_VENDOR=y
となっておりました。
しかし、この状態で
modprobe sr_modして
modprobe: Can't locate module sr_mod
と言われてしまいます。

何か勘違いをしているのでしょうか?

299 :login:Penguin:03/09/06 13:25 ID:/Ug3+uu6
> 298
DVD-"ROM" デスカ?

300 :login:Penguin:03/09/06 13:42 ID:JDkGnpol
ほんとうに....スミマセンでした。

_| ̄|○

http://www-3.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-4NQRG4
を使っているのですが、
実は読み込み専用モデルみたいでした。
てっきりDVDが読めるならCD-R/RWの書き込みくらい
当然できると思てました。

アホやった.ベッピーのこと笑えん...
ご迷惑をおかけしました。
さようなら。ごきげんよう。



301 :login:Penguin:03/09/06 13:44 ID:z+Fq5CM1
>>300強ク逝キ(ry


302 :login:Penguin:03/09/06 14:40 ID:xSMau5x1
とても笑いました

303 :login:Penguin:03/09/06 15:36 ID:rywqj/np
aptでgdmをインストールしたのですが、
gdmをstartするとキーボードが全く効かなくなってしまいます。
xdmでも同じです

これは私だけでしょうか?

304 :login:Penguin:03/09/06 15:40 ID:FEzDWVNT
>>303
Xの設定はまちがってないよね?

305 :login:Penguin:03/09/06 15:47 ID:rywqj/np
>>304
Xは普通に使えています。(普段はコンソールでログインしてstartxして使ってます。)
キーボードはPS/2です。
gdm 2.2.5.5-2
xdm 4.1.0-16

306 :login:Penguin:03/09/06 16:10 ID:PK/p+8VR
*dmでログインすると~/.xなんたらが読み込まれないせいじゃない?

307 :login:Penguin:03/09/06 16:30 ID:beNUvnt7
>>277
なにそれ?動いてるけど....

308 :277:03/09/06 16:57 ID:+wUXb8Ic
うわ、失礼
apt-listchangesですた…

309 :277:03/09/06 17:00 ID:+wUXb8Ic
ちなみにエラーはこんな感じ

Traceback (most recent call last):
File "/usr/bin/apt-listchanges", line 35, in ?
import apt_listchanges
File "/usr/lib/site-python/apt_listchanges.py", line 26, in ?
_ = gettext.translation('apt-listchanges').gettext
File "/usr/lib/python2.3/gettext.py", line 416, in translation
t = _translations.setdefault(key, class_(open(mofile, 'rb')))
File "/usr/lib/python2.3/gettext.py", line 176, in __init__
self._parse(fp)
File "/usr/lib/python2.3/gettext.py", line 304, in _parse
tmsg = unicode(tmsg, self._charset)
LookupError: unknown encoding: EUC-JP


310 :login:Penguin:03/09/06 17:05 ID:OgIzbeBg
>>309
apt-get install python-japanese-codecs

311 :login:Penguin:03/09/06 17:06 ID:z+Fq5CM1
>>309 使っているpythonのバージョンに合わせて
python*-japanese-codecsかpython*-cjk-codecsを入れるとよろし。
ja_JP.UTF-8だとこれでも化けるけどね。


312 :login:Penguin:03/09/06 18:07 ID:OgIzbeBg
>>311
Error Messageからja_JP.eucJPでPython2.3を使用していることが
わかるよね。
だから、python-japanese-codecsでいいんだよ。


313 :311:03/09/06 18:27 ID:z+Fq5CM1
>>312 む、なるほど。thx!


314 :278:03/09/06 20:52 ID:Ytfmqaps
>>296-297
なるほど確かにそうですね。
debian固有じゃないみたいなので専門スレできいてみます。
ありがとうございました。

315 :login:Penguin:03/09/06 20:54 ID:sp0HuNY+
xmame0.72のdebは存在しないんでしょうか。

316 :login:Penguin:03/09/06 20:58 ID:2vEWltBv
油断してると、pythonが2.1、2.2、2.3が併存したままになるのね・・・


317 :login:Penguin:03/09/06 21:21 ID:z+Fq5CM1
>>316 うち1.5まで入ってる < アホ


318 :login:Penguin:03/09/06 23:19 ID:06SY4kDX
>316
知らんかった。サンクス。

319 :login:Penguin:03/09/06 23:45 ID:nrCJoQ0a
sidの話
kernel-imageとkernel-headersを2.4.21-5に上げたんだけど
linux/version.hのUTS_RELEASEが"2.4.21-4"になっちょる
これってkernel-headersの問題?

320 :login:Penguin:03/09/07 00:38 ID:8VP984W7
/usr/src/kernel-headers-2.4.21-5/include/linux/version.hは
ちゃんと"2.4.21-5"になってるが。
/usr/include/linux/version.hは"2.4.21-4"になってるけど
こっちはlibc6-devで提供されるheader。
glibcをbuildしたシステムのカーネルバージョンだべ。

というヲチを予想。

321 :login:Penguin:03/09/07 01:09 ID:e4wXvYz+
nvi-m17n 消えたの? ring.asahi-net の sid だけど。

322 :login:Penguin:03/09/07 07:59 ID:FwhDsqrg
だってもはやそんなの使ってるやついねーじゃん


323 :login:Penguin:03/09/07 10:42 ID:A5iPeZ+s
>322
確かにwoodyからバージョン変わってないからなー。
そうすっと、日本語使えるviって何入れればいいの?jvim-canna?

324 :login:Penguin:03/09/07 11:00 ID:UqGeHvv/
>>323
vimでいいじゃん。でかいのが嫌いなの?

325 :login:Penguin:03/09/07 11:06 ID:A5iPeZ+s
>324
んにゃ。何も考えず日本語に対応してそうなnvi-m17n入れてただけ。
viにはこだわりないんで、vim入れてみまつ。

326 :Linux初心者 && Debian初心者:03/09/07 15:58 ID:IROcOLtB
woody入れてsargeにしてmozilla-firebirdやOOo, cannadicなども入れて
日常的に使えるレベルになりました。

それで一言。。。
>>1http://debian.fam.cx/http://debian.dtdns.net/2ch-debian/
が非常に役立ちました。ありがとうございました。

それだけなんでsage

327 :login:Penguin:03/09/07 17:40 ID:EYYHzRRG
jvim-canna が好きなのでこれ入れてる。
UTF-8 な文書が編集できないと思っていたので
そのためだけに Vim 6 とか Emacs 入れてたけど、
単に自動判別に失敗していたということに気がつき、
VIm 6 をアンインストール。JVim マンセー

328 :login:Penguin:03/09/07 18:14 ID:MaFKC3BZ
>>327
【Linux板】初心者にもやさしい【vi】
http://pc.2ch.net/test/read.cgi/linux/1014426934/

329 :名無しさん@Emacs:03/09/07 19:07 ID:F9/mc9RP
ノーパソにwoodyインスコしたいんですが
言語選択画面で、どうやら画面が広がってしまい、
以降項目の下部が隠れてしまいます

言語選択画面に2byte文字が表示された&LCDの相性問題だとは
思うので、non-USのインストールイメージで、最初からenglishの
インストールできる方法ありますか?



330 :login:Penguin:03/09/07 19:18 ID:XUbOBlxB
boot: bf24 video=vga16:off


331 :名無しさん@Emacs:03/09/07 19:32 ID:F9/mc9RP
>330
どうもありがとうございます
改めてUSのインストイメージをダウンロードするのも
気がひけてたんで、助かりました




332 :321:03/09/07 20:54 ID:e4wXvYz+
>>322
nvi-m17n 使ってたよ。
vim は起動するのに十秒くらいかかるし。(初起動でキャッシュなしの時)
emacs の補助として使ってたから素の vi の機能で
十分だったんだけどな。

333 :login:Penguin:03/09/07 23:19 ID:V7IABANq
vim独自の機能が要らないなら
set compatible
filetype off
なんてすれば早くなるかもね。

334 :login:Penguin:03/09/08 01:12 ID:aTowO9xU
DebianインストールでKDE入れたいのですがうまく行きません。
アドバイス下さい
dselectで x-window-system 入れたのですが灰色の画面にXポインタが表示される
だけでそこから進みません、/log/Xfree86.0.log にはerrorらしきメッセージは
在りませんでした。
dselectにてkdeパッケージを選択したのですが他に
何かしなければならないのでしょうか?

335 :login:Penguin:03/09/08 01:22 ID:uu2EgNHh
>>334
user-ja-confで.xssessionの設定をするとか。

336 :login:Penguin:03/09/08 01:25 ID:27gmWyXn
>>334
Debian と言ってもいろいろあるのだが。

337 :login:Penguin:03/09/08 01:33 ID:5S4LnBYd
>>334
ついでにkdmとかgdmでもいれたら?

apt-get install kdm

shutdown -r now


338 :login:Penguin:03/09/08 01:57 ID:AvnX0FyC
>>334
startkdeしてもそうなるの?

339 :login:Penguin:03/09/08 02:35 ID:WSg7piP4
>>334
俺はKDE入れるときはここを参考にしてる。
ttp://davidpashley.com/debian-kde/faq.html

日本語環境欲しければkde-i18n-jaを忘れずに。

340 :login:Penguin:03/09/08 05:55 ID:KV2hEIfi
>>335
woodyからはset-language-envだよ

341 :login:Penguin:03/09/08 06:16 ID:7H/0zvGI
apt-get install language-env


342 :login:Penguin:03/09/08 09:51 ID:PzRkqYmJ
専門スレでdpkgとかちょこっとでも出ると叩かれるのはなんでだろう?
debianはdebianスレで聞けよって言われる。
他のディス鳥だって設定方法に互換性がないのに
なんでdebianだけこんなに嫌われてるのよ?


343 :login:Penguin:03/09/08 09:53 ID:ISsDuMjR
>>342
厨は無視しろ。

344 :login:Penguin:03/09/08 10:22 ID:BmjFgTFW
>>342 某/.-jで口だけはdebianマンセーとかほざいてる
蛆虫共が沢山いるからだろう。

スレ違いにつきsage


345 :login:Penguin:03/09/08 11:36 ID:B79UY1fp
>>342
rpmとかでてきても叩かれてると思うが?


346 :login:Penguin:03/09/08 11:42 ID:L/LOBh47
>>342
叩かれたのはどのレス?

347 :login:Penguin:03/09/08 15:38 ID:PzRkqYmJ
>>346
unix板のxfree86設定スレとlinux板のalsa専門でもちょっと。

348 :login:Penguin:03/09/08 15:51 ID:L/LOBh47
>>347
ALSA スレは見てないからよく知らんが
XFree86 スレの方は
「dpkgとかちょこっとでも出た」からではないだろう。
ちゃんと理由が書いてあっただろ?
あれは Red Hat の話を出しても反応は同じだよ。

349 :login:Penguin:03/09/08 16:23 ID:4Z9pqlPV
>>347
alsaスレのは、まさかこれか?
http://pc.2ch.net/test/read.cgi/linux/1012998650/741-742

350 :347:03/09/08 16:35 ID:PzRkqYmJ
>>348
まったく仰る通りです。反省します(´・ω・`)

351 :login:Penguin:03/09/08 17:04 ID:tnbDjlWg
ディストリビューション別のスレやMLは、まず問題がディストリビューション
固有か否かまでは切り分ける役目を負うべきだと思うよ。


352 :login:Penguin:03/09/08 22:54 ID:6s4YQxcs
漏れもこのスレ住人には何度も助けてもらってるが、
気が向いて答えてくれてるだろう親切なハカー様に
役目を負うべきって偉そうな口はきけない。



353 :login:Penguin:03/09/08 23:52 ID:WI2iU+oc
sidのxserver-xfree86のインストールで、設定(postinst)の段階で固まるのですが…原因御存じの方いますか?


354 :login:Penguin:03/09/09 00:09 ID:VvBzQoFA
いろんなものをコンパイルするに当たって、
gcc/g++/cppは2.95xと3.0.4のどちらでコンパイルしたほうがいいのでしょうか?

できれば、バイナリのサイズとスピードが両立したのがいいです。

・・・妙に自分の環境だと3.0.4でコンパイルしたバイナリはサイズが大きいのですが。

355 :login:Penguin:03/09/09 00:33 ID:CcVy60jo
>>354
くだらない質問はここに書き込め! Part57
http://pc.2ch.net/test/read.cgi/linux/1062975738/

356 : :03/09/09 00:35 ID:t8Q/0B9W
>>354
3.0.4 ってなんだよ。。やたら中途半端だな。


357 :login:Penguin:03/09/09 00:46 ID:7VNE1+Ur
>>353 postrmだったらBTSにあるけどなぁ
ttp://bugs.debian.org/cgi-bin/bugreport.cgi?bug=207809


358 :357:03/09/09 00:48 ID:7VNE1+Ur
うわ、resolvedだった。357は忘れて


359 :login:Penguin:03/09/09 01:58 ID:FBsOwJem
>>352
壁作んなくてもいいじゃん。
俺は助けて欲しい時は助けてもらうし、助けられる時はがんがん助ける。
意見すべきだと思ったら遠慮なく言う。
言い出しっぺの法則はやれる限り守る(w

そういうコミュニティを目指してるんだと、受け取ってるからね。

360 :login:Penguin:03/09/09 02:15 ID:CcVy60jo
 | ∧
 |Д゚) ・・・。
壁|⊂)
 |∧|

361 :login:Penguin:03/09/09 18:48 ID:8qT3aQfw
しかし4.3.0こね〜な〜。
brandenタンは逝かせちゃうし。

362 :login:Penguin:03/09/09 19:39 ID:7xa1B1xv
sargeではxfree86_4.2.1でのリリースになります(嘘・・・恐怖

デフォのインストールカーネルは2.4系になるんだっけ?

363 :login:Penguin:03/09/09 20:42 ID:7VNE1+Ur
brandenタンはdebian-legal@orgでRMSとの論争に忙しいのです。


364 :login:Penguin:03/09/09 22:19 ID:7xa1B1xv
めーりんぐりすと@でびあん

いこう!逝こうぜ、みんな!

アヒャヒャー

365 :login:Penguin:03/09/10 00:24 ID:vOBfCzwG
brandenタンはなんでLinExって表記すんだ?
誰か解説キボン

366 :login:Penguin:03/09/10 00:42 ID:lH7zH7x6
>>365
http://www.ofb.biz/modules.php?name=News&file=article&sid=260

367 :365:03/09/10 00:54 ID:vOBfCzwG
>>366
さっき見れなかったのに…どうもです

368 :login:Penguin:03/09/11 03:05 ID:P8tqAPHu
woody --> sarge で、何かゴミでも残りますか?

369 :login:Penguin:03/09/11 09:30 ID:UyW5QVuT
>>368
やってみれ。
残ったら BTS すれ。

370 :login:Penguin:03/09/11 11:51 ID:nV5M2lbo
>>369
やってるよ、、、。

そんなのは、無いってことだね。

ありがと。

371 :login:Penguin:03/09/11 12:02 ID:pLqJEbbI
(´-`).。oO(vim6.2はパッケージ化されないのかな…)

372 :login:Penguin:03/09/11 12:19 ID:nSvAQ+65
>>370
deborphan使え


373 :login:Penguin:03/09/11 13:25 ID:jIPGKxO7
>>368
つーか、「ゴミ」って何を指してる?

374 :login:Penguin:03/09/11 13:52 ID:6lP5uvec
>>373
たぶん、purgeしても残ってしまうファイルの事じゃないかなぁ。
使われなくなったlib*とか、gcc-3.0とかの古いバージョンの事で
はないような。知らんけど。

375 :MEMO:03/09/11 14:00 ID:N8q7ObBZ
(/usr/share/apps/ksplash/pics/)
ttp://www.kde-look.org/

376 :login:Penguin:03/09/11 17:25 ID:N8q7ObBZ
>>370
どもども、
http://debian.g-com.ne.jp/index.html
「初級からの脱出」で、勉強しました。

やっと、sarge になりやんした。

Mozilla 1.0.0 ?? ふうっ。

377 : :03/09/11 17:36 ID:hep4MBAP
Debian で LaTeX をつかって日本語の文書を作っています。
最終的な生成物としてハイパーリンク付き PDF ファイルを作ることはできるのでしょうか?
dvi -> ps も何種類かあるようだし…
そもそも \usepackage{hyperref} でいいんでしょうか。

今は dvi2ps と ps2pdf を使っています。

あと anthy が入っているのを発見。初めて使ってみた。

378 :login:Penguin:03/09/11 19:52 ID:LUkMSWVf
>>370 apt-get --purge remove $(deborphan)
ただし/usr/localに突っ込んだものが動かなくなるかも
しれないという両刃の剣。素人には(ry

ゴミと言えば/etc以下のディレクトリが--purge remove
で綺麗に消えないというdpkgのbugがあるみたいだね。
まぁ実害ないので放置するつもりだけど

>>377とりあえずdvipdfmx+hyperrefで作れたYO!
ただcolorlinks=trueだと上手くいかない気味

379 :login:Penguin:03/09/11 22:29 ID:nV5M2lbo
sarge に KDEが、入らないのは分かりましたが、

# apt-get install kde
Sorry, but the following packages have unmet dependencies:
kde: Depends: kdebase-audiolibs but it is not going to be installed or
kdebase3-audiolibs but it is not installable
E: Sorry, broken packages

結局は、どうしたらいいのか、、わかりませんです。

どうしよ?!

380 :login:Penguin:03/09/11 23:21 ID:P8tqAPHu
んんー、ボケかましたかな > 自分

381 : :03/09/12 00:38 ID:MTZslqFo
>>379
ちゃんと書いてある内容読めや。あほ

382 :login:Penguin:03/09/12 00:48 ID:S5Ed80Yk
>>381
どうやればインストール出来るって書いてあるの?

by あほ

383 : :03/09/12 00:52 ID:MTZslqFo
dpkg --remove kdebase-audiolibs kde kdebase-dev

384 :阿呆草:03/09/12 00:57 ID:2Znyz0PU
382さんへ、
僕の思うには、381さんは「読んで理解できない阿呆はlinuxを使うな」
と言っているのだと。僕ももうlinux使うの止めようと思っています。
自分で自分の事を阿呆じゃないのかと思っている所へ、「阿呆」と
言われると、やっぱりそうだったのかと思うと同時に、なんか複雑な
気持になります。僕の本能は「とりあえず ここから逃げろ」と言ってます。
それでは お先に さようなら。


385 :login:Penguin:03/09/12 01:01 ID:1ZAqkpiL
まぁおちけつ

>>379 書いてある意味は分かってると思うけど一応解説
kdeはkdebase-audiolibsまたはkdebase3-audiolibに依存
しているけど、前者はインストールされる予定がない。
後者は現在インストールできない、と言っている。

で対処方としてはkdebase-audiolibsが何故インストール
されないのかを見る(apt-get install kdebase-audiolibs
してみて何が問題かを見る)。not to be installedなパケジ
に対してこれをくり返していくと、運が良ければ依存関係が
解決されてインストールできる。駄目なら自分でソース
取ってきてリビルドする必要がある。OK?

386 :login:Penguin:03/09/12 01:05 ID:qdMcCiCj
>>383
install されてない物は、消せないと思いますが、、、。

by あほ

387 :login:Penguin:03/09/12 01:08 ID:ac+wcAlJ
sarge の namazu で lang ja でインデックス作ると
Segmentation faultします。lang C だと問題ないですし、sidだとlang 関係なくOKでした。
namazuスレに書こうと思ったんですけどnamazu2パッケージはsarge と sid 同じバージョンなんで
こっちに書かせていただきました。よろぴこ

以上はPostgreSQLのドキュメントですが他のドキュメントでもファイルが10個を越えるあたりから
Segmentation faultします。
ちなみに最後のファイルがおかしいのかと思い単独でmknmzすると成功します。
mona@mona:~$ mknmz -L ja --debug -O namazu/ public_html/documents/PostgreSQL/
省略
// 16app-initdb.html/16
// target file: /home/mona/public_html/documents/PostgreSQL/app-initlocation.html
// Detected type: text/html
// pre_codeconv
@@ Using html.pl
@@ Processing html file ...
Segmentation fault

ii namazu2 2.0.12-1
ii namazu2-common 2.0.12-1
ii namazu2-index-tools 2.0.12-1
ii perl 5.8.0-18
ii libnkf-perl 2.01-5
ii libtext-kakasi-perl 1.05-4

388 :login:Penguin:03/09/12 01:09 ID:Wq+tggkR
>>379
sidにいらっしゃ〜い。

389 :login:Penguin:03/09/12 01:14 ID:R1iw1gse
>>385
どもども、
依存関係を修復(?)出来るのかどうかとか、
インストールに順番があるのか等と思ってました。
ソースからやりなさいと言うのは、どこかで読みました。
が、やはりそうですか。
ありがとうございます。

と、お騒がせしました。

390 :login:Penguin:03/09/12 01:18 ID:R1iw1gse
>>379
とてもとても、これくらいの事で、オロオロしてる様では
sidへは行けません。
apt-lineだけいただきに行きます。

ではでは。


391 :login:Penguin:03/09/12 01:22 ID:YLOkmDY5
testingよりunstableのほうが安定しているような気がするが?


392 :login:Penguin:03/09/12 01:25 ID:R1iw1gse
>>391
うはー、そうなんですか?!!

早速、トライしまふ。

ありがとうございます。


393 :login:Penguin:03/09/12 01:29 ID:+hJcgPLy
>>392
sidは使い方次第だよ。がんばって。

394 :login:Penguin:03/09/12 01:30 ID:TOgebMY6
testingって何のためにあるの?

395 :login:Penguin:03/09/12 01:36 ID:IzN8FLty
testのため。

396 :login:Penguin:03/09/12 01:53 ID:1ZAqkpiL
現行のtestingがあまり上手くいってないのは羞恥の事実
そりゃあajも"Bits from the RM"なんてメールを書くさ

397 :login:Penguin:03/09/12 02:08 ID:IzN8FLty
ってかtestingって、stableの放置とunstableのいい加減さを兼ね備え……

398 :login:Penguin:03/09/12 02:22 ID:uSLxpAt/
メンテナは大抵 sid 使ってるでしょ?
いつ testing に入れるかどうかはメンテナの判断しだいな訳?

399 :login:Penguin:03/09/12 02:31 ID:YLOkmDY5
>>398
RC bugがなければurgency=lowの場合で10日ほどでtestingに入る。ただし、
他のパッケージに依存している場合、そのパッケージもtestingに入ってないと
お預けを食らう。だからglibcでRC bugがあると、testingの更新がほぼ止まる。

testingに何で入ってないのかは

http://bjorn.haxx.se/debian/

で調べればわかる。


400 :login:Penguin:03/09/12 02:48 ID:7twrflY3
俺んとこの sarge では KDE 3.1.3 動いてるが、
どうやって入れたのかほとんど憶えていない…

woody用のlibvorbis0を無理やり入れたとか、
依存関係の地雷原を避けるために入れるパッケージをdselectで選んだとか、
あまり他人には薦められない方法だったような気がする…

sarge って、特に廃止パッケージの周りが苦しいよね。
先日は celestia が libgtk2 と conflict って言われて一瞬何事かと思った
(libgtk2.0-0png3 廃止に伴うアレ)。

401 :login:Penguin:03/09/12 05:00 ID:9PBILM9l
リリース版でもないバージョンに文句言ってもしょうがない。

402 :login:Penguin:03/09/12 15:35 ID:7eEf7d+k
おれはsargeで
apt-get install -t unstable kdebase
として入れたが、何か問題あるかな?

403 :login:Penguin:03/09/12 16:15 ID:PeRqdMIc
アレで申し訳ないのだが
potatoってあぼーんした?aptできないようだが・・

404 :403:03/09/12 17:13 ID:PeRqdMIc
snapshot.debian.netによると9/8からPackagesがなくなってるのね
まぁ素直に上げろと言うことでスマソ

405 :login:Penguin:03/09/12 19:04 ID:YLOkmDY5
>>403
ttp://archive.debian.org/


406 :名無しさん@Linuxザウルス:03/09/12 19:44 ID:KCtkMvvh
最近アップデートしてないけど普通にwoody用のkde本家のパッケージが
入ったんだけど、今はだめなの?>sarge
何気にkdebindingとか足りなかったりしない?>sidのkde


407 :login:Penguin:03/09/12 20:21 ID:MwMvxKKj
Err http://ring.astem.or.jp proposed-updates/main ssh 1:3.4p1-1.woody.1 404 Not Found [IP: 133.18.72.10 80]
Failed to fetch http://ring.astem.or.jp/pub/linux/debian/debian/pool/main/o/openssh/ssh_3.4p1-1.woody.1_i386.deb 404 Not Found [IP: 133.18.72.10 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
ってどういう意味ですか?


408 :login:Penguin:03/09/12 20:36 ID:1ZAqkpiL
>>407 Packages.gzには記載されてる場所にパケジがない、と言っている
i. apt-get updateしてからupgradeするまで時間が空いてしまいパケジの
リストが古くなっている
ii.まだミラーしきれてないだけ

iiであれば時間をおけば解決すると思われ


409 :login:Penguin:03/09/12 20:45 ID:N2DNoIpH
>>407
ssh以外にもupgrade対象がある場合は、とりあえず
apt-get update && apt-get upgrade -um
とすれば入る(かもしんない)。
(あ、-m = --fix-missing ね)

410 :login:Penguin:03/09/12 21:25 ID:IzN8FLty
>>408
ringだとどうしてもiiが多くなり、sidなんかだとミラーできてすぐパケジが出てまたはまったりする……

411 :login:Penguin:03/09/12 22:33 ID:WD67PElY
大体ミラーリングが終わる時間が分かってればそうでもないけどな。
漏れの使ってるとこだと15-6時ぐらいには終わってる。

412 :sage:03/09/13 00:29 ID:6Y015vv2
今、bonzaiというインストーラを使って
中古のMSIのLPXベアボーンにdebianをインストール
しようとしてます。

パーティション切ろうとしたら、/dev/ataraid/d0
とでているので、同じHDD二つ用意してそれぞれ、
/dev/hda, /dev/hdbにつけました。

なんとかインストールが終わったが、よく考えてみると
このベアボーン(MS-5203)はRAIDコントローラなんて
持ってたか? 案の定、起動しようとしても
L 99 99 99 99 とLILOで止まるし。

気持ち悪い。普通に/dev/hdaにインストールしようかな

413 :login:Penguin:03/09/13 00:30 ID:6Y015vv2
ごめんなさい。名前欄にsageを入れてしまいました。もう寝ます。

414 :login:Penguin:03/09/13 00:40 ID:jsoZZjFo
Debian woody ってshutdown -h now で電源落ちないね。
どっかで設定したら落ちるようになる?

415 :login:Penguin:03/09/13 00:42 ID:iDzzm3Hi
>>414
APM まわり?

416 :login:Penguin:03/09/13 00:45 ID:H9127Kam
>>414
kernel再構築しましょう。

417 :login:Penguin:03/09/13 00:52 ID:ARuLmNcJ
PC買い換えてWoody入れようとしたらNICの認識ができず、ネットワークインストールできません。
NICはオンボードのintel pro/100 VEってやつです。
bf24でやっても同じです。
どうすれば認識できるのでしょうか?

そいえばsargeって、まだ・・・・・?

418 :login:Penguin:03/09/13 01:00 ID:tQv4Yl3R
sargeはホントに12月1日にリリースされるのかな

419 :login:Penguin:03/09/13 01:07 ID:5+r1Ixn9
>>417
認識できんってのにもいろいろある。
自動認識しない?選択してるのに動かない?対応ドライバが選択肢にない?




420 :login:Penguin:03/09/13 01:11 ID:QLZmhJWl
>>418
リリース日より次のコードネームの方が気になる。

421 :login:Penguin:03/09/13 01:15 ID:ARuLmNcJ
インストール時にモジュール組み込もうとして失敗してみました。
対応ドライバも、それっぽいやつ全部試したのに。。。。。。
一度インストールして他のマシンでintelから対応ドライバとってくるしかないのか?

sargeでもっと使いやすくなるかな、debian。

422 :login:Penguin:03/09/13 01:18 ID:AgyNISIN
モジュールは合ってる?
Intelがオンボードなのはドライバ周り怪しいよ。これはDebianというよりLinuxの問題……

423 :login:Penguin:03/09/13 01:26 ID:ARuLmNcJ
そうなんですか。
前rtl1839使ってて、それは自動認識できたんだけどなぁ。
まぁ、その時もインストール時にはモジュールインストールできなかったけど。
いやぁ、ワケワカラン。

赤帽は認識するって、どっかでみたんだけどなぁ。
正直、浮気する予感。

424 :login:Penguin:03/09/13 02:14 ID:yex3MdJq
ATOKXを使うのに、パッケージ使って/tmpに置いたファイルを使って入れて、
~/.xsessionの後ろに. /usr/lib/atokx/im/locale/ja/atokserver/atokx_client
を書いて、/.xsessionのXIM, XIM2をコメントアウト、新たに XIM=htt を加え、
/.Xresourcesの#define XIM kinput2 をコメントアウト、新たに #define XIM httを加えても、
ATOKXが立ち上がりません。何か抜けているのでしょうか?

ps auxすると
/usr/lib/im/htt -port 9010 -syslog -message_locale C
/usr/lib/locale/ja/atokserver/atokmngdaemon
htt_server -port 9010 -syslog -message_locale C が4つ
ほど走ってました。

インストの時に Starting ATOKX server: atokmngdaemon htt.
と、出ているのでインストは間違ってないと思うのですが。

gdmでログインしているので、明日辺り、/etc/gdm/Sessions/Gnomeにatokx_client
を追加してみよう、と思っております。ちなみにWoodyでKDE3.1.3、GNOME2.2です。
突っ込みどころがあればよろしくお願いします。

425 :login:Penguin:03/09/13 02:31 ID:onHU+bZB
>>423
intel pro/100 V の件

http://www.debian.or.jp/search/
ここで、intel pro/100 VE って入れて見たら、、、
http://lists.debian.or.jp/debian-users/200211/msg00140.html
こんなのがあって、
出来そうですが、、、。


426 :login:Penguin:03/09/13 02:43 ID:WuChaQ2W
>>424

http://debian.fam.cx/?FAQ に、

atokx の設定

と言う項目があります。

チェックしてみてはいかが?

427 :login:Penguin:03/09/13 02:53 ID:EInyT97u
>>424
gdm って.xsession 読まないんじゃなかった?

428 :424:03/09/13 03:16 ID:yex3MdJq
>>426
ありがとうございます。そこは拝見しております。424に書いてあるのは
そのページにも書いてあります。

>>427
そう思ってinittabを書き換えてランレベル2に戻してみたのですが……。
書きませんでしたね。すみません。

それで、次は/etc/gdm/Sessions/Gnomeしてみようかと。Vineだとwdmの
設定に手を入れましたし。明日、もう一度確認します。ありがとうございました。

429 :427:03/09/13 03:17 ID:EInyT97u
>>428
> それで、次は/etc/gdm/Sessions/Gnome

そこに書くくらいなら、~/.gnomerc に書きなはれ。
うちはそれで動いてる。

sid + gdm + gnome2.2

430 :login:Penguin:03/09/13 03:18 ID:jsoZZjFo
>>420
次もその次もきまってたんじゃ・・

431 :login:Penguin:03/09/13 04:44 ID:i0KoxivF
あれ、きまってんの?
どこに書いてあるか教えてくれると嬉しいな。

432 :424:03/09/13 11:09 ID:fCEgBUgy
>>427
/~.gnomercを作ったところ、立ち上がりました。
自分の環境にきちんと読み替える力がなければ宝の山も
ただのゴミであることを再認識しました。精進いたします。
ありがとうございました。

424に書きませんでしたが、以前同じように困っている人の書き込みは
見つけたのですが、その時は解決策が書いていなかったのでご報告します。
426さんもありがとうございました。

433 :427:03/09/13 11:28 ID:EInyT97u
>>424
お役に立てて何よりです。
といいつつ、俺も最初は分かんなくて、最近まで GNOME control manager ->
拡張設定 -> セッション 内の「自動起動するプログラム」の中に登録して
むりやり起動してた、という恥ずかしいオチ。

ところでLinux 板ってあんまり見ないんですが(日頃は新マク板)、この板って
礼儀正しいヒトが多いですね。このスレだけ?

それともマク板が(略

434 :login:Penguin:03/09/13 11:41 ID:WuChaQ2W

http://www.orca.med.or.jp/receipt/tec/woody/woody_install_jma.html
44. 「.gnomerc」と「.xmodmap」の編集

435 :login:Penguin:03/09/13 14:02 ID:qTZzSQyB
>>412 raidは誤認識だと思われ
>>430 次はともかくその次も決まってたっけ?
sidだったら永遠にunstableのハズ


436 :login:Penguin:03/09/13 15:02 ID:jsoZZjFo
とりあえず次はandyだな・・

437 :423:03/09/13 15:14 ID:x4uuw4Yl
>>425
遅くなりました。
どうもです。

それでよさげですが、NICを認識しないからapt-getができないのです。
前使ってたrtlさしたらPCが起動しなくなるしお手上げ。
よかったら、どなたか助けてください。

438 :424:03/09/13 15:18 ID:fCEgBUgy
http://lists.debian.or.jp/debian-users/200111/msg00122.html
見つけてしまいました……、愕然。基本中の基本では無いか…。
見覚えが無いところを見ると検索漏れか…。
ここで聞く前に帰りの電車内で気付いたことを先にやるべきでした。

>>427
そういうのもありましたか。ありがとうございます。
>>434
これもいいページですよね。ありがとうございます。

恥さらしはこの程度に致します。度々お邪魔しました。

439 :login:Penguin:03/09/13 15:44 ID:qTZzSQyB
>>437 modprobe eepro100 の結果はどうだった?


440 :412:03/09/13 17:09 ID:QWZIJrIZ
>435
レスどうもです。やっぱり、そうでしたか。
で、今はソフトRAIDに挑戦してます。
なかなか大変です。
とりあえず、/dev/hdaにノーマルインスコして
/dev/hdb, /dev/hddに二つの同じHDDをつないで
後から増設するカタチにしようと思ってます。

441 :423:03/09/13 23:25 ID:1JYBWCBP
>>439
インストール時に認識しない時点であきらめて、その後続けてなかったですよ。
modprobeは試してないです。

さっきwoodyのCDイメージをbonzai linuxに変えたらDHCPの設定がインストール時にできました。
たぶん成功っぽいです。

かき回してスマソ。


442 :login:Penguin:03/09/14 00:48 ID:WNXZOSzd
gnome2.4のdebまだー?

443 :login:Penguin:03/09/14 01:46 ID:SSFV7+BE
慌てる乞食は貰いが少ない

444 :一休さん:03/09/14 02:15 ID:dwHWiaM5
慌てない慌てない
一休み一休み

445 :login:Penguin:03/09/14 05:05 ID:6uNIuVuI
wishlistだすとちょっとは早くなるかもね


446 :名無しさん:03/09/14 05:35 ID:vCfuDSmU
ブックノートのDEGATTOというのを買ったんですが
nicが認識しません

SiSM650+962マザーのオンボードです

nicが使えた方、教えてくれませんか


447 :login:Penguin:03/09/14 08:20 ID:3w+0kzQM
>>446
肝心のnicが何なのかを書かないのは嫌がらせですか?

448 :login:Penguin:03/09/14 08:22 ID:OpO3qSJ9
>>446
あと/proc/pciも晒せ

449 :login:Penguin:03/09/14 11:57 ID:UPEr4XsI
mkinitrd-cdやると、
/tmp/やらbusyboxが云々言ってきて
失敗するけど、Google見る限り、
対処法もでてないし、

みなさんどうしてますか?


450 :449:03/09/14 12:05 ID:UPEr4XsI
なんか間違えてたっぽい
スルーしてください。

451 :login:Penguin:03/09/14 22:50 ID:wXeH71VQ
DeMuDiっていうマルチメディアに特化したディストり使ってる人居ませんか?
感想教えてください。

452 :login:Penguin:03/09/14 23:48 ID:6uNIuVuI
>>451 これか
ttp://www.demudi.org/main/main.php3
使ってる香具師はいるのかな?


453 :login:Penguin:03/09/15 00:10 ID:qkAI6nYl
禿しくいなそう。

454 :login:Penguin:03/09/15 00:51 ID:+MYyTiNY
woodyでmozilla使ってるんですが、
URL欄に日本語をkinput2 -wnnで入れてgoogle検索を選ぶと、
googleにその日本語を正しく渡すことができません。
#日本語は全て%3Fという文字だとしてクエリ文字列に渡されてるみたい
どなたか対処法をご存知ではないでしょうか。

455 :login:Penguin:03/09/15 01:51 ID:efh/zBEQ
>>454
ヲレのは mozilla.org でバイナリ配布の mozilla-1.4 で
kinput2 -canna だけど文字化けしてないよ。



456 :名無しさん:03/09/15 02:39 ID:wUiEa7Mp
>>degatto
/proc/pci には、
Ethernet controller: PCI device 14e4:4401 (Broadcom Corporation) (rev 1).

とありました。

型番までは説明書にも無かったのですが、100baseTXとあります。
一方でbroadcom社製 giga bit ethernetcardが使えるカーネルを
公開してくれてる人がいるので、それを使ってみようかと思います


457 :login:Penguin:03/09/15 04:04 ID:14z+rpRs
>>456 参考になるかどうかは分からんが
ttp://www.google.com/search?hl=ja&inlang=ja&ie=UTF-8&oe=utf8&c2coff=1&q=Broadcom+Corporation+14e4%3A4401+linux+ether&btnG=Google+%E6%A4%9C%E7%B4%A2&lr=


458 :login:Penguin:03/09/15 10:07 ID:Q96ovV5x
>>454
俺もそうだ。今やったらわかった。
mozilla-1.0.2-2 + skkinput-2.03-10


459 :login:Penguin:03/09/15 11:20 ID:IAHtdoLz
woody使ってます。

今までは.Xresourcesに
KTerm*VT100*SaveLines: 1000
XTerm*VT100*SaveLines: 1000
Rxvt*saveLines: 1000
と書いてkatermでも1000行前まで見ることができたのですが
2画面分ぐらいしか上スクロールできなくなってしまいました。
ktermとkrxvtでは1000行前までスクロールできてます。

katermは画面にゴミが残らないしafterstepと相性がいいので
使い続けたいのですが、うまい解決法ありませんか?
DSA-380-1でXをupgradeした以外には、何も設定をいじっていません。



460 :補足:03/09/15 11:23 ID:IAHtdoLz
aterm-mlのバージョンは0.4.2-3です。


461 :login:Penguin:03/09/15 13:27 ID:9fHwq+tm
testing を使ってます。
XFree86 に脆弱が見つかりましたが、testing は放置でしょうか。
testing とはそもそも利用が想定されていないのですか。
よろしくお願いします。


462 :login:Penguin:03/09/15 13:33 ID:0GGjBpQF
>>461
testing はその名のとおりリリース版のテストのためのもの。
セキュリティアップデートと言えども
unstable で安定するまでは testing に降りてこない。
しばらく待つか unstable から取ってきて入れれ。

463 :login:Penguin:03/09/15 13:52 ID:9fHwq+tm
>>462
Thanks.


464 :login:Penguin:03/09/15 14:44 ID:zsWLno2v
root 下で、必要最小限のファイル達は、なんでしょう?
ちょい消しまくりたいので、教えていただけますか?

465 :login:Penguin:03/09/15 14:52 ID:ZMSeIBi3
インストール直後のXを起動してない状態で
存在するファイルは、なんでしょうかって聞いたほうが
よかったかな、、、。
すみません、よろしく。

466 :login:Penguin:03/09/15 15:03 ID:JHj1EuDS
>>465
あなたが直接または間接に使わないものは全部消しても動くけど、そんなの、あなたが
何を使うかによるから、他人に聞いて答えがでるわけない。
小さいところに、必要なのだけをいれていくほうがよくないかな? (baseでも既に大きいけどね)

467 :login:Penguin:03/09/15 15:17 ID:XE40mIiK
>>465
標準でインストールさせるものからでも、環境によりまだ削り落すことは可能。
ipchains, pppoe, ...etc.

468 :login:Penguin:03/09/15 15:17 ID:ZMSeIBi3
>>466
ども、、。
おっしゃっていただいてる意味はわかります。
mvしたりcpしたりで、root下で余計な事やってましたので、
訳分からんようになってます。
defaultなファイルを欲しかったのですが、、、。


469 :login:Penguin:03/09/15 15:43 ID:XE40mIiK
>>468
root下でファイル単位でパッケージをいじったら、パッケージ単位で管理している
debianでは(作業を覚えていない限り)復旧は無理でしょう。
必要なもののバックアップ取って、素直に再インストールしたら?

(´-`).。oO(rootで何かを大々的にやることなんて普通無いよな)

470 :login:Penguin:03/09/15 15:45 ID:9fHwq+tm
>>1 では安定版の apt-line に proposed-updates を含めた設定例を示されていますが、
<http://www.debian.org/security/faq#proposed-updates> を見ると、
proposed-updates のパッケージは削除される可能性があり、
セキュリティチームによってサポートされないものもあるようです。
含めないほうがいいんじゃないだろうか。と思っただけ。


471 :login:Penguin:03/09/15 15:48 ID:uiTI1h78
>>468
もしかして465=464?
だとすると /root 以下のファイルの話?

472 :login:Penguin:03/09/15 15:57 ID:76COFs5Z
ディレクトリをスワップとルートのみすれば解決(ボソ

473 :login:Penguin:03/09/15 16:12 ID:XE40mIiK
>>470
そういえば、以前は「proposed-updates とは」みたいな項目があったが、今は無くなったのかな?

474 :login:Penguin:03/09/15 16:26 ID:mIwXQs1T
Tipsの方にあるじゃん。

475 :login:Penguin:03/09/15 17:35 ID:uIcK0EFe
>>470
そうだったのか。
security.debian.orgのミラーが欲しいな。


476 :login:Penguin:03/09/15 17:48 ID:76COFs5Z
>>475
よーし、
じゃあBふれベーシックをweb巡回にしかつかってないオレが・・・

ってこの程度の回線だと速攻アウトだな・・・


スレッドのテンプレ リンクきれてないか?
gnomeとかfirebirdとか・・・

477 :login:Penguin:03/09/15 18:25 ID:tGz1bkYe
>>476
backport系がゴッソリ消えてるな。
why?

ディスクスペース食い過ぎじゃ(゚Д゚)ゴルァ!!!とでも言われたのかのう。

478 :login:Penguin:03/09/15 19:08 ID:ag8zvOMT
>>476
そういう通達は既に出てる。
ttp://lists.debian.org/debian-devel-announce/2003/debian-devel-announce-200308/msg00009.html

Debianパッケージだけで使う(であろう)diskの容量は下を参照のこと
ttp://lists.debian.org/debian-devel/2003/debian-devel-200308/msg03929.html


479 :login:Penguin:03/09/15 19:49 ID:76COFs5Z
速度測ってみた
アップ回線の速度は30Mb/sくらい
下りは40Mb/s

480 :◆eruX6eXBcA :03/09/15 20:37 ID:fb6meOrQ
サーバを復旧してバックアップしてたetc上書きしたら動作がおかしくなった。
全部上書きするのはやめようと思った。

481 :login:Penguin:03/09/15 21:30 ID:76COFs5Z
サーバ用途にpentium-Mがつかえるマザーほすぃ。
静音、低消費電力、高性能は萌え萌えなんじゃがー

寝室においてもぐっすり寝られるさーばー


藻前さんたち、どんなマシンを使ってるんでござるか?

482 :login:Penguin:03/09/15 21:32 ID:eyRgzPCf
>>476

うぃっきぃっーなんだから、気付いた香具師が直せよゴルァ

483 :login:Penguin:03/09/15 21:33 ID:uiTI1h78
>>481
スレ違い

484 :login:Penguin:03/09/15 21:39 ID:/4oJ9Vav
>>482
直しましたが、なにか?

485 :login:Penguin:03/09/15 21:49 ID:eyRgzPCf
>>484

よくやった

486 :login:Penguin:03/09/15 21:51 ID:eyRgzPCf
と言うわけで、一週間海外旅行するのでうぃっきぃっーの保守よろしゅぅ

487 :login:Penguin:03/09/15 21:54 ID:TJQV6zwl
海外かー、羨ましいねぇ


488 :login:Penguin:03/09/15 21:59 ID:/4oJ9Vav
ヨーロッパあたりに逝って例のデモ活動とか?

489 :login:Penguin:03/09/16 02:20 ID:mWyK9DN7
>>442
debian-gtk-gnomeの下記の投稿が参考になるかと。
公式パッケージではありませんが。

ttp://lists.debian.org/debian-gtk-gnome/2003/debian-gtk-gnome-200309/msg00228.html

490 :MEMO:03/09/16 03:32 ID:AxFcXxTq
Gnome のデスクトップアイコン
「ゴミ箱」の名前を変更したいんですが、
お願いします。

491 :login:Penguin:03/09/16 04:11 ID:bcdIKQtf
なんて名前に?


492 :login:Penguin:03/09/16 05:57 ID:+URrYOzf
>>491
うーんっと、
Trash が、いいかな。

493 :login:Penguin:03/09/16 06:44 ID:jAZ3L5mr
woodyを使っています。ブート時に新しいハードウェアの検出をする時はどこを書き換えればよかったでしょうか?

494 :login:Penguin:03/09/16 07:58 ID:JUk3bG5B
>>493
ハードウェアの種類によるんでは?

495 :login:Penguin:03/09/16 08:24 ID:AxFcXxTq
>>464
>>465
インストール直後のroot直下には、
~/.profile
~/.bashrc

496 :login:Penguin:03/09/16 08:25 ID:AxFcXxTq
--ここから
# ~/.profile: executed by Bourne-compatible login shells.

if [ -f ~/.bashrc ]; then
. ~/.bashrc
fi

PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11
export PATH

mesg n
--ここまで

497 :login:Penguin:03/09/16 08:26 ID:AxFcXxTq
--ここから
# ~/.bashrc: executed by bash(1) for non-login shells.

export PS1='\h:\w\$ '
umask 022

# You may uncomment the following lines if you want `ls' to be colorized:
# export LS_OPTIONS='--color=auto'
# eval `dircolors`
# alias ls='ls $LS_OPTIONS'
# alias ll='ls $LS_OPTIONS -l'
# alias l='ls $LS_OPTIONS -lA'
#
# Some more alias to avoid making mistakes:
# alias rm='rm -i'
# alias cp='cp -i'
# alias mv='mv -i'
--ここまで

498 :login:Penguin:03/09/16 10:42 ID:a56GdkKT
JFのJigdoのドキュメントはよく更新されてるな。

499 :login:Penguin:03/09/16 10:49 ID:YdaOpsN3
げぇ

sargeはDVD-R2枚


500 :login:Penguin:03/09/16 18:01 ID:uBU1eTtl
sid ですが、ふと気付いたら _ や ] が入力できなくなってました。
xev するとキーコードはひろっているみたいですし、
別パーティションの Windows では正常に入力できているので
キーボードの故障ではなさそうです。

なぜ入力できなくなったかわからないですが、
どこを直せばよいのでしょう?


501 :login:Penguin:03/09/16 18:13 ID:VlvMc+bW
>>500
もしかして USB キーボード?

502 :login:Penguin:03/09/16 18:14 ID:5h+CJWfr
>>500 kernelのversionは?2.6でconsole-toolsでモゲーというのは
関係ないか?


503 :500:03/09/16 18:18 ID:uBU1eTtl
>> 501 いや、ノートパソコンなので、USB ではないです。

>> 502 Kernel は 2.4.22 なのです。

ちなみに X 上では入力できないですが、コンソール上(X 動かしてない状態)
であれば 入力できましたので X 関係の何かがおかしくなって
しまったのかもしれません。。。

504 :(・∀・)ニヤニヤ:03/09/16 18:23 ID:gkD/uQEJ
|д゚)
|д゚).。oO(10.220.135.85)
|)彡 サッ

505 :login:Penguin:03/09/16 18:25 ID:js2Eww7d
>>503
/etc/X11/xkb/ 以下が壊れたときテンキーが使えなくなった経験あり。


506 :login:Penguin:03/09/16 18:36 ID:5h+CJWfr
>>503 XF86Config-4どっかに退避して--purge removeしてインストール
しなおしというのが一番早いかのぉ。因に--reinstall installだけだと
/etc以下は置き換わらないので要注意。


507 :500:03/09/16 18:53 ID:uBU1eTtl
>>506

--purge して 再度インストールしたら治りました。
いやー助かりました。ありがとう。

508 :???:03/09/16 21:59 ID:wmMW6I44
Woodyで,PSC2150をスキャナーとしてお使いの方いらっしゃいますでしょうか?

509 :***:03/09/16 22:10 ID:wmMW6I44
apt-get install j2sdk1.4を入力したら、libc6が、古いといわれました。どのようにしたらよろしいでしょうか。教えてください。


510 :login:Penguin:03/09/16 22:29 ID:iClfL70i
apt-get install j2sdk1.4
といってもどんなapt lineを使っているか分からない.
Debianのどんなバージョン(potato, woody, sarge, sid, etc.)を
使っているかも分からない.

# apt-get install j2sdk1.4
libc6が、古い

と表示されるとは思えない.どのようにしたらいいでしょうか.

511 :login:Penguin:03/09/16 23:10 ID:5h+CJWfr
>>509 以下woodyでBlackdownのjavaを使おうとしていると仮定。
多分unstableなapt-lineを書いていると思うが、j2sdk1.4は当然
glibc2.3でコンパイルされているので素のwoodyには入らない。
残念ながらBlackdownのパケジはwoody向けは1.3までしかない。
mpkg-j2sdkでSunのを入れる等が必要。

詳しくはdebian-usersを検索してくれ。そのまんまなサブジェクト
のスレッドがあるから。

スキャナの方は知らん。


512 :login:Penguin:03/09/17 06:48 ID:/0ITD95w
>>387 遅レススマソ。手元の環境でも同様の問題が出ることを
確認しました。-L jaで問題が出るとのことなので、nkf,kakasi,
chasenのどれかが問題だろうと当たりをつけて色々弄りましたが
上手くいかず、結局sidのlibnkf-perl-utf8をぶちこむという良く
わからん手法にて解決しました。とりあえず、御報告まで。

とここまで書き捨ててあとはknok氏が降臨してくれることを期待
#libtext-chasen-perlもrebuildしてくれるとありがたいなぁ...


513 :***:03/09/17 08:13 ID:CIsqOntu
おはようございます。ありがとうございます。今日は、仕事なので、あしたの夜以降、詳しく調べてみます。

514 :login:Penguin:03/09/17 11:58 ID:xUFbaERj
ssh_3.4p1-1.1_i386.debとssh_3.4p1-1.woody.1_i386.debで騒いぢゃったよ...
確かに書いてあるな。 (--;

でも、そういう問題じゃないような... (w


515 :login:Penguin:03/09/17 18:35 ID:sXDoV2RB
XEmacs utf-8

Package: mule-ucs

ttp://lists.suse.com/archive/m17n/2002-May/0016.html

(if (locate-library "un-define") (require 'un-define))

516 :login:Penguin:03/09/17 19:07 ID:/0ITD95w
>>515 誤爆? あ、Mike Fabianだ


517 :login:Penguin:03/09/17 21:33 ID:jC6px5NX
/var/cache/debconf/config.dat と templates.dat って
debconfが使うことは想像つきますが
実際にこれらを削除すると、具体的に何が怒るのでしょうか?

518 :login:Penguin:03/09/17 21:35 ID:Thn1xXvS
とりあえず通報しときました。

519 :login:Penguin:03/09/18 00:42 ID:y2Z2y4fR
>>517
何?消しかたがわかんないの?しょーがないなぁ。

# rm -f /var/cache/debconf/config.dat

はい。これで確認できるでしょ。


520 :login:Penguin:03/09/18 01:01 ID:/yMM1YIL
>>519
おひおひ。せめて
# (cd /var/cache/debconf && (for i in config templates; do mv -i $i.dat $i.dat.bak; done))
くらいにしといてやれよ。

521 :login:Penguin:03/09/18 08:32 ID:W+Nmha87
>>517
debconfが怒ります。

522 :login:Penguin:03/09/18 13:29 ID:IV7S1Xeh
>>517
でぶがおこります。

熱が発散されます。結果部屋の温度も激しく上昇し雲が
できます。んでもって雨がふります。



523 :login:Penguin:03/09/18 17:09 ID:1WMWeFJr
debian-installerを試したくて、jigdoでsarge-i386-1.isoをとってきたん
だけど・・ススマン。

みんなこれでインストールできてるの?


524 :login:Penguin:03/09/18 17:39 ID:nQCUbRH+
インストーラが実用になるのは
リリースの1ヶ月前くらいじゃなかったっけ?

525 :login:Penguin:03/09/18 17:48 ID:1WMWeFJr
そだったんですか・・。

不具合が残っているというよりサッパリといった手応えなんだけど、
間にあうんだろうか?それとも、たまたまか。

526 :login:Penguin:03/09/18 19:40 ID:6X7OR4cL
woodyのalsaconfバージョン古過ぎんだよ。使えね

527 :login:Penguin:03/09/18 20:56 ID:fRKmo6Ag
>>526
あれはダメスギだよなー。
sargeでは改善されるはずだが。

528 :login:Penguin:03/09/18 22:08 ID:eM5SxLn3
infoseek 検索キーワードランキング
今週の急上昇は「半ズボン」
http://japan.internet.com/wmnews/20030918/5.html

529 :login:Penguin:03/09/18 22:11 ID:lEsC1Wy1
>>528

ワロタ。infoseekの記者を眠らせてやってくれ。

530 :login:Penguin:03/09/18 22:14 ID:lEsC1Wy1
http://hanzubon.org/private/history.html

半ズボンって会社ころころ変えすぎ。rolling stoneか?

531 :login:Penguin:03/09/18 22:26 ID:eUZDLHdM
>>530 今、最長在職期間更新中なんだから、そっとして置いてあげれ


532 :login:Penguin:03/09/18 22:53 ID:CzaLJoiQ
>>530
すげえな。問題児ぽいな。


533 :login:Penguin:03/09/18 23:45 ID:lEsC1Wy1
>>531

ただの更新し忘れじゃなくって?

534 :login:Penguin:03/09/19 01:06 ID:rl9T+sx7
なかなか入れない企業を遷移しているのでは?

535 :login:Penguin:03/09/19 03:37 ID:z54Wn2LK
AbiWord で

『言語 日本語 [ja-JP] 用の辞書を読み込むことができませんでした』

って、これは、どうするんでしょう、、、。

536 :login:Penguin:03/09/19 08:58 ID:sgiCoN/1
scigraphica インストールできない。。
コンパイルした、、、落ちる、、
かれこれ一月

どうなってるの?

537 :login:Penguin:03/09/19 12:08 ID:VQaHmeut
Debianを再インストールしたときに,
以前使っていた/home以下を初期化せずに,
そのままマウントしてインストールしました.
その後で以前も使っていたGnome2.2をインストールすると
デスクトップのメニューがすべて文字化けしてしまいました.
(正方形の枠の中に30A2とか書いてある文字)

これの原因がわかる方,ぜひご教示ください.

538 :login:Penguin:03/09/19 12:26 ID:X+4h9/rt
>>537
原因:
1)以前はインストールしていたフォントを入れていない。
> 入れる。.xsession-errors あたりにヒントがあるかも。

2)古い設定ファイルが残って悪さをしている。
> ~/.gnome* ~/.gconf ~/.gconfd あたりを退避して設定しなおしたら?
  for dir in ~/.gnome* ~/.gconf ~/.gconfd; do mv $dir $dir.bak; done


539 :login:Penguin:03/09/19 12:36 ID:VQaHmeut
>>538
情報ありがとうございます.

540 :login:Penguin:03/09/19 12:55 ID:s2qtIvju
Sarge libc6 2.3.2 age

541 :login:Penguin:03/09/19 17:57 ID:pqEZ8Zqe
gnome 2.4予想に反して早かったな。

542 :login:Penguin:03/09/19 18:20 ID:v6bij4iJ
最近みてない
XFree86 はどうなった?

543 :login:Penguin:03/09/19 19:40 ID:ePRJftJ1
sidのvimがようやく6.2になったけど、
gvimの描画が変。文字が表示されない・・・。
プルダウンメニューを一度表示させて消すと、表示されてたところだけ文字が見えるようになる(w


544 :login:Penguin:03/09/19 20:28 ID:4FL0KvMF
>>536 gtk-1.2でbuildしてるのにpythonの方はgtk-2.0の方を
見に行ってるような気がする。これが原因じゃないかな。
あ、環境はsidね。


545 :login:Penguin:03/09/19 22:23 ID:vSYh4Awt
最近のsidのdvipdfmx腐ってないすか?
$ dvipdfmx anal.dvi

anal.dvi -> anal.pdf
[1kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 1+597/600 --dpi 1197 rml
mktexpk: don't know how to create bitmap font for rml.
kpathsea: Appending font creation commands to missfont.log.
** Fatal error: Could not locate a virtual or a physical font file for 'rml'.

$ cat /etc/texmf/texmf.d/50dvipdfmx.cnf
;; READ /usr/share/doc/dvipdfmx/README.Debian for details:
CMAPINPUTS =.;/usr/share/fonts/cmap/adobe-japan1//;/usr/share/fonts/cmap/adobe-japan2//;/usr/share/fonts/cmap/gs-cjk-resource//

にしてあるんですけど。
BTSには何にも出てないみたい……

546 :???:03/09/19 22:27 ID:DrYDK9oJ
# apt-get install j2sdk1.4
libc6が、古い。といわれる問題は、
# apt-get install j2sdk1.3で、逃げました。
とりあえず、Clock.javaが、動作しているので大丈夫なのでしょうか。
ありがとうございました。

547 :login:Penguin:03/09/19 22:52 ID:P1WcAiy3
>>545
うちでは問題なく使えてます。


548 :login:Penguin:03/09/20 03:01 ID:3GzjKYtU
Acrobat Reader 5.08

# mkdir downloads downloads/linux-508
# cd downloads/linux-508/
# wget ftp://ftp.adobe.com/pub/adobe/acrobatreader/unix/5.x/linux-508.tar.gz
# tar xvzf linux-508.tar.gz
# ./INSTALL
Please type "accept" to accept the terms and conditions license agreement; Type "decline" to exit.
Enter installation directory for Acrobat 5.0.8 [/usr/local/Acrobat5]
Directory "/usr/local/Acrobat5" does not exist.
Do you want to create it now? [y]
Installing platform independent files ... Done
Installing platform dependent files ... Done
# cd
# mkdir downloads/jpfont
# cd downloads/jpfont
# wget ftp://ftp.adobe.com/pub/adobe/acrobatreader/unix/5.x/jpnfont.tar.gz
# tar xvzf jpnfont.tar.gz
# cd JPNKIT/
# ./INSTLANG
Continue installation? [y]
Please type "accept" to accept the terms and conditions of this license agreement; Type "decline" to exit.
Enter the location where you installed the Acrobat Reader [/usr/local/Acrobat5]
Installation completed.

549 :login:Penguin:03/09/20 05:21 ID:SempHKB1
>>545 それが/var/lib/texmf/web2c/texmf.cnfの方に反映されてないと
意味ないYO!とりあえずupdate-texmfでもしてみるとか


550 :login:Penguin:03/09/20 14:28 ID:Arv9PAe7
半ズボンは道頓堀で突き落とした香具師のこと。

551 :545:03/09/20 14:34 ID:sI8O0IxE
update-texmfしてもupdate-fmtutilしても駄目だったのですが、
TeX関係全部purgeしてapt-get installしなおしたらなおりました。
厨でスマソ > 皆様 & ringサーバー

552 :login:Penguin:03/09/20 17:29 ID:FXbNt8O/
athlon64 どうよ?
使ってる奴いる?

553 :login:Penguin:03/09/20 17:35 ID:SempHKB1
>>552 微妙にスレ違いっぽいような気もするが...
pergolesi.d.oはOpteronのdualらしいね


554 :login:Penguin:03/09/20 17:39 ID:jIt2mKNw
>>552
64bitで使えるメドはたってないんじゃないの?
あのコードがあったんじゃなかったっけ?

555 :login:Penguin:03/09/20 18:37 ID:iYrWli06
>>554
> あのコードがあったんじゃなかったっけ?

それなに?

556 :login:Penguin:03/09/21 13:08 ID:Ypn9pEf5
カーネルの再構築なのですが、

kernel-source-2.4.22 には、

XFS filesystem support オプションが、見当たらないのですが。

557 :login:Penguin:03/09/21 13:36 ID:W+BZI1/S
>>556
apt-get install kernel-patch-xfs

558 :login:Penguin:03/09/21 14:09 ID:hO16Krgw
>>557
ども、ありがとう。

559 :login:Penguin:03/09/21 14:17 ID:hO16Krgw
>>556
kernel-patch-xfs - XFS Filesystem support for Linux 2.4.21

2.4.21 だ。

kernel-source-2.4.21 にダウンしないとだめかな。

560 :login:Penguin:03/09/21 17:49 ID:YFswn8Yz
localesを2.3.2-7(testing)に上げたらatokxが
使えなくなりますた。調べてみると
/usr/lib/im/locale/ja/atokserver/atokx_client
の中で呼んでるhttxってのがうまく上がらない模様
(起動に時間もかかる)。そんでもってこのhttxてのが
エラーも何もはかないんで、どう対処したらよいの
かさっぱりです。あてずっぽでもアドバイスよろしく


561 :560:03/09/21 17:53 ID:YFswn8Yz
あそれと、/usr/lib/locale/ja 以下 atokserver も
ごっそり消されるのでこれからupgradeしようという
人はご注意。

562 :login:Penguin:03/09/21 18:23 ID:bGZqPPVO
対処法はBTSする事だ



563 :login:Penguin:03/09/21 18:38 ID:HMIxH6ue
>>531
でも、人の入れ替わりの激しいNVだから(ry


564 :login:Penguin:03/09/21 18:39 ID:W+BZI1/S
しかも、debconfでatokx/restartにsetしてるとpostinstでエラー返すから
困るんだよねぇ。

いったんpurgeしてinstallをやり直す羽目になったし。英語でうまく説明
できないから誰かBTSしてくれ。


565 :login:Penguin:03/09/21 19:34 ID:wIFH/wAW
http://www.debian.or.jp/Packages.html

このページでDebian-JPのパッケージを見ようとしたらリンク切れだったんですけど、
ここってもうサポートされていないんですか?

566 :login:Penguin:03/09/21 19:56 ID:Xagxc9My
>>565
http://packages.debian.or.jp/unstable-jp/
こっちは見れるね。

つーか、-JP のパッケージ必要か?

567 :login:Penguin:03/09/21 20:57 ID:wIFH/wAW
>>566
オフィシャルのパッケージで代替物があったのかも知れませんが、
htmllintを入れました。


568 :login:Penguin:03/09/21 21:01 ID:HUsIh0zt
例えばGnome2をAptで入れると数十のパッケージがインストールされますよね?
そしてGnome2をアンインストールしたくなったら、すべてのパッケージを一発で
アンインストールすることは出来ますか?

569 :login:Penguin:03/09/21 21:50 ID:QfAFEm9C
>>568
ようは依存されてるものを一緒にアンインスコするってことか?
多分できない。

570 :login:Penguin:03/09/21 23:56 ID:HUsIh0zt
たびたびすいません。

Stableにパッケージが追加/更新される条件とはなんなのでしょうか?
例えばStableのX-Window-Systemは4.1ですよね?
xfree.orgでは4.4が出ようとしているということは4.2や4.3の開発は終了しているんですよね?
素人考えなんですが、4.2がリリースされたらStableは4.2になっていい気がするんですが、
まだ安定してないから入らないのでしょうか?
Gnomeも2.4が出たのに未だに1ですし。疑問です。

571 :login:Penguin:03/09/22 00:26 ID:qPCwhbD/
>>570
stableはリリースした後に新しいパッケージは追加されない。
セキュリティホールなどがあった場合のみ修正される。

つか少しは過去ログとか嫁。

572 :login:Penguin:03/09/22 02:54 ID:6Q2Vj2vm
テンプレTipsのproposed-updatesの項目、
誰か削除(コメントアウト)したみたいだけど、
あれあった方が良くない?

意見求む。

573 :login:Penguin:03/09/22 03:46 ID:qPCwhbD/
>>572
>>470

574 :login:Penguin:03/09/22 03:47 ID:qPCwhbD/
ゴメソ、勘違いした。

575 :login:Penguin:03/09/22 04:05 ID:kSWw+jgN

http://www.nongnu.org/synaptic/

いいですねえ

576 :login:Penguin:03/09/22 04:20 ID:oh39C2FI
結局、proposed-updatesは入れないほうがいいってこと?

577 :560:03/09/22 07:45 ID:7OoF1vDv
>>561
X-ML-Name: debian-users
X-Mail-Count: 38059
によると/usr/lib/locale下なんか勝手に
使ってんぢゃねえよヴォケ>atokx、って
ことらしい

>>560
でも動かなくなったといってる香具師は
MLにはいないみたい


578 :login:Penguin:03/09/22 09:16 ID:uC6bGr5U
>>576
Debian 3.0r1 とか r2 とかを一足早くデバッグしたい人は入れた方がいいのでは。


579 :login:Penguin:03/09/22 11:49 ID:y5jUcUd0
>>576
security.debian.org の変更が proposed-updates に入るとそちらに取りに行き、
負荷分散になるので、proposed-updates は入れといてくれるとありがたいのでは?

580 :login:Penguin:03/09/22 12:44 ID:N+5cGpPL
>>579
でもproposed-updatesは単なるsecurity.debian.orgのミラーではなく、
余計なものも混じってるわけだが。see >>470


581 :login:Penguin:03/09/22 12:53 ID:vlswOvry
apt-get upgradeで失敗するんですが・・・
ミラーリングがまだされていないだけ?

43 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 28.1MB/81.5MB of archives. After unpacking 1295kB will be used.
Do you want to continue? [Y/n]
Err http://ring.pwd.ne.jp proposed-updates/main gnupg 1.0.6-4
404 Not Found [IP: 210.158.0.14 80]
Err http://ring.pwd.ne.jp proposed-updates/main initrd-tools 0.1.32woody.5
404 Not Found [IP: 210.158.0.14 80]
Err http://ring.pwd.ne.jp proposed-updates/main kernel-source-2.4.20 2.4.20-3woody.13
404 Not Found [IP: 210.158.0.14 80]
Failed to fetch http://ring.pwd.ne.jp/pub/linux/debian/debian/pool/main/g/gnupg/gnupg_1.0.6-4_i386.deb 404 Not Found [IP: 210.158.0.14 80]
Failed to fetch http://ring.pwd.ne.jp/pub/linux/debian/debian/pool/main/i/initrd-tools/initrd-tools_0.1.32woody.5_all.deb 404 Not Found [IP: 210.158.0.14 80]
Failed to fetch http://ring.pwd.ne.jp/pub/linux/debian/debian/pool/main/k/kernel-source-2.4.20/kernel-source-2.4.20_2.4.20-3woody.13_all.deb 404 Not Found [IP: 210.158.0.14 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?


582 :login:Penguin:03/09/22 13:04 ID:wFyIsYEL
よくあること。

583 :login:Penguin:03/09/22 13:13 ID:7OoF1vDv
libc6関係をホールドしているのに、libc6に依存の
あるパッケージがupdateされる度にホールドが
外れてしまいます(aptitude使用)。毎回ホールド
し直すのがめんどうなのですが方法ありませんか?


584 :login:Penguin:03/09/22 13:35 ID:SxZlwV17
/etc/apt/preferencesに書いとけば?
ttp://debian.fam.cx/?AptGet#content_1_22

585 :login:Penguin:03/09/22 13:51 ID:7OoF1vDv
>>584
どもですた


586 :login:Penguin:03/09/22 14:22 ID:uC6bGr5U
>>580
よく勉強したら、後は自分の好きなようにということじゃない。


587 :login:Penguin:03/09/22 15:55 ID:N+5cGpPL
>>586
まあそれはそうなんだけど、純粋なsecurity.debian.orgのミラーとしての機能も欲しかったりする。


588 :login:Penguin:03/09/22 16:08 ID:k+bXbUDb
proposed-updatesをsecurity.debian.orgのミラーとして使うのはいかかがものかと。

deb http://dennou-h.ees.hokudai.ac.jp/library/Linux/debian-security stable/updates main contrib non-free
deb http://dennou-t.ms.u-tokyo.ac.jp/library/Linux/debian-security stable/updates main contrib non-free
deb http://dennou-q.geo.kyushu-u.ac.jp/library/Linux/debian-security stable/updates main contrib non-free
deb ftp://debian.mis.hiroshima-u.ac.jp/debian-security stable/updates main contrib non-free

589 : :03/09/22 16:39 ID:Y+OQd2wh
漏れの Debian ちゃんでは、 aptitude を実行すると
「Loading cache」って表示されたままとまってしまうんですが、
何が悪いのでしょうか?

590 :login:Penguin:03/09/22 16:43 ID:uC6bGr5U
>>566
> つーか、-JP のパッケージ必要か?

なんとなく、試しに調べてみたら 3つだった。

acroread-asianfont
easypr-lprng
grep-ja

もっとあるかと思ってたんだけど、少ないね。


591 : :03/09/22 16:47 ID:Y+OQd2wh
>>589
とりあえず /var/lib/aptitude/ にある pkgstates を pkgstates.old とかにしたら動いた。
こんなことしてよかったんだろうか。

592 :login:Penguin:03/09/22 16:53 ID:k+bXbUDb
>>590
gs-jaとかも結構使っている人いそうだけどな。

593 :login:Penguin:03/09/22 17:58 ID:bWlsq5YG
testingのgv1:3.5.8-30.1がダメだった。
>Warning: Representation size 2 must match superclass's to override internalWidth
>セグメンテーション違反です

他の人どうですか?

594 :login:Penguin:03/09/22 23:15 ID:g8AT/0vN
>>593
あー、ほんとだー

595 :login:Penguin:03/09/23 03:16 ID:5x9a9sLR
東風フォントがkochi-substituteに入れ替わる模様。


596 :login:Penguin:03/09/23 03:59 ID:ANpiYl8l
webalizer 2.01.10-19 使ってます
最近タイトルや本文が
`Usage Statistics for Hostname - August 2003'
から
`遵ス遵k遵ス遵ホ遵ァ醇・× Hostname - September 2003'
のように文字化けするようになりました.

同様の症状になっている人いませんか?
又は原因・対処方法など知ってる人いませんか?

597 :596:03/09/23 04:00 ID:ANpiYl8l
ちなみにsidつかってます.
Debian固有の問題か不明ですが.

598 :login:Penguin:03/09/23 06:27 ID:+TOWDr57
>>595
gsで日本語が出なくなったね……

599 :login:Penguin:03/09/23 07:46 ID:REcjei+4
当然snapshot.debian.netからも東風消すんかな...


600 :login:Penguin:03/09/23 15:00 ID:sQCRn7FZ
やっと入れ替えるのか。
ずいぶんと時間かかったな。

601 :login:Penguin:03/09/23 15:11 ID:8V7hGWOI
fontconfig >>>>>>>>>>>>> defoma

602 :login:Penguin:03/09/23 15:17 ID:REcjei+4
>>601 fontconfigがgsまわりも面倒見てくれたらいいんだけどねぇ...


603 :login:Penguin:03/09/23 15:28 ID:Pe9ioCDd
正直、リングサーバーのミラーが中途半端すぎるので本家のサーバを見るようにしているやつ→

604 :login:Penguin:03/09/23 15:33 ID:/GR0NDxn
lftp ftp.jp.debian.org:/debian/pool/main/t/ttf-kochi> mget *
`ttf-kochi-gothic_1.0.20030809-1_all.deb' (現在 399008 バイト) (8%) 62.9KB/s eta:65s [データ受信中]

605 :login:Penguin:03/09/23 15:38 ID:/GR0NDxn
...本物はnon-freeのほうにありました。

606 :login:Penguin:03/09/23 15:44 ID:JZtuG0ui
ringのミラーを使いましょう、と言いながら
(本家が重いので)とりあえずringに来てる範囲で更新かけて、
残りを本家から取ってくる、というのが暗黙のr(ry

607 :login:Penguin:03/09/23 15:48 ID:5x9a9sLR
地雷踏む覚悟があるならincoming.debian.orgから直接持ってくr(ry

608 :login:Penguin:03/09/23 16:10 ID:pWaoW5iP
>>602 gs の Fontconfig/Xft2 化お願いします。


609 :login:Penguin:03/09/23 16:22 ID:HV/LEGAl
ringは5つ指定してます・・・

610 :login:Penguin:03/09/23 16:30 ID:Pe9ioCDd
crontab -e とか visudo とかで使われるエディタを
変更するにはどこをいじればよいのでしょうか?
nano ではなく、vim を使いたいのですが…

611 :login:Penguin:03/09/23 16:34 ID:PLD7+XN+
>>610

nanoをremoveすればいい

612 :login:Penguin:03/09/23 16:36 ID:Pe9ioCDd
>>611
ほんとだ。。すんません。お手数おかけしました。

613 :login:Penguin:03/09/23 16:37 ID:XESOqt9P
>>610
# update-alternatives --config editor
か?

614 :login:Penguin:03/09/23 16:43 ID:RJsNdXoE
環境変数EDITORをvimにすれ。
bashなら~/.bashrcに

export EDITOR=vim

とか追記。

615 :login:Penguin:03/09/23 20:01 ID:PLD7+XN+
スラドでLIDSのトピックができたけど、debianでLIDS導入している香具師いませんか?

616 :ですます調:03/09/24 00:11 ID:5tM3oM/w
$ sudo apt-get install ffmpeg
Password:
パッケージリストを読みこんでいます... 完了
セグメンテーション違反ですます... 50%

617 :ですます調:03/09/24 00:22 ID:5tM3oM/w
おい直らんぞ。apt壊れた?

618 :何これ。どうしよう:03/09/24 00:27 ID:5tM3oM/w
LANG=C; sudo apt-get upgrade
Reading Package Lists... Done
Segmentation faulty Tree... 50%


619 :618:03/09/24 00:33 ID:5tM3oM/w
deb http://security.debian.org/ stable/updates ...
外したら直った。スレ汚しごめんなさい。
sidにしたのに、消すの忘れてた。ふふ

620 :login:Penguin:03/09/24 01:21 ID:EridqRfB
kernel-source-2.6.0-test4
でmake menuconfigできないのは
何のいやがらせなんでしょうか?


621 :login:Penguin:03/09/24 01:40 ID:sr9sm196
仕様です。

622 :login:Penguin:03/09/24 09:49 ID:78AZFttr
debian 厨房です
apt-get install で持ってくる国内サーバーで更新頻度の良いところはどこでつか?
時々、旧帝大系もダメな場合があるので教えて。

623 :login:Penguin:03/09/24 09:52 ID:lpI2Tih1
>>622
stableを使ってるのかunstableを使っているのかでだいぶ違うと思うが。


624 :login:Penguin:03/09/24 10:03 ID:O6tGxEYw
mirrorを名乗ってるなら、更新頻度はどこでも同じだと思うけど。
ラグについても、一日以上開くことはない、はず。


625 :login:Penguin:03/09/24 10:54 ID:eZa/E6H8
1日間隔でmirrorしてる(はずの)ringは駄目駄目だからなぁ。

626 :login:Penguin:03/09/24 11:25 ID:KW1fvWRe
>>620
qt入れておかないと通らなかったような気がしますな。


627 :login:Penguin:03/09/24 11:28 ID:O6tGxEYw
2.6試してないから分からんけど、
qt必要なのはxconfigじゃないのか?


628 :login:Penguin:03/09/24 12:31 ID:eK+PeDKy
長くて申し訳ないが、結果を教えて。

{cat /var/lib/apt/lists/*debian-jp*|grep '^Package: ' | awk '{print $2}' | sort -u;
dpkg --get-selections | awk '$2=="install" {print $1}'} | sort | uniq -d


629 :login:Penguin:03/09/24 13:21 ID:RnHiVhqw
>>628
そのままじゃうまく動かなかった
結果は grep-ja だけだった、、

630 :login:Penguin:03/09/24 14:02 ID:FS7lT3gF
Sidでつ。

久々にUpgradeしたら...

| 以下のパッケージは保留されます
| apache apache-common apt apt-utils bash bind9 bind9-host binutils bsdmainutils bsdutils canna console-tools coreutils
| cpio cpp-3.2 cpp-3.3 cron debianutils dialog dnsutils dpkg dselect dwww e2fslibs e2fsprogs elvis eruby fbset fdutils
| file fontconfig g++-3.2 g++-3.3 gawk gcc-3.2 gcc-3.3 gcc-3.3-base gkrellm gkrellm-common gnupg grep groff-base ifupdown
| libapache-mod-ruby libasn1-6-heimdal libblkid1 libc6 libc6-dev libcanna1g libcomerr2 libconsole libdb4.0 libdbm-ruby
| libdps1 liberuby libfontconfig1 libfreetype6 libgcc1 libgdbm3 libglib2.0-0 libgtk2.0-0 libgtk2.0-common libisccc0
| libisccfg0 libkrb-1-kerberos4kth libkrb5-17-heimdal liblwres1 libmagic1 libncurses5 libnewt0.51 libpango1.0-0
| libpango1.0-common libpisock++0 libpisock8 libpq3 libroken16-kerberos4kth libruby libstdc++5 libstdc++5-3.3-dev
| libstdc++5-dev libstrscan-ruby libuuid1 libxaw7 lilo locales login make makepasswd man-db man2html mew-bin
| module-init-tools modutils mount ncurses-bin nmap ntpdate passwd perl perl-base php4 postfix postfix-ldap postfix-pcre
| postgresql postgresql-client procps proftpd proftpd-common python python2.2 raidtools2 rdtool realpath reportbug ruby
| slang1 slang1a-utf8 ssh sudo sylpheed tar tasksel util-linux w3m wget whiptail whois xbase-clients xlibmesa3-gl
| xlibmesa3-glu xlibs zlib1g

って感じになりますた。(TT)

たぶん変なパケヂに依存してて詰ってるんだと思いますが、どうやって調べれば良いでしょうか...


631 :622:03/09/24 14:03 ID:78AZFttr
>>623-625
了解っス、ありがとん。

632 :login:Penguin:03/09/24 14:30 ID:eK+PeDKy
>>630 /etc/apt の下に何か設定してそう。


633 :login:Penguin:03/09/24 14:47 ID:FS7lT3gF
>>632
さんくすこ。

何も設定してないんだなぁ、これが。

/etc/apt/apt.conf.d/70debconf

| // Pre-configure all packages with debconf before they are installed.
| // If you don't like it, comment it out.
| DPkg::Pre-Install-Pkgs {"/usr/sbin/dpkg-preconfigure --apt || true";};

だけぽ。

apt-lineは

| deb http://ftp.jp.debian.org/debian-ddtp ja/sid main
| deb http://ftp.jp.debian.org/debian unstable main contrib non-free
| deb http://ftp.jp.debian.org/debian-non-US unstable/non-US main contrib non-free
| deb http://ftp.jp.debian.org/debian-jp unstable-jp main contrib non-free
| deb http://www.debuan.org/ ./
| deb http://navi2ch.sourceforge.net/debian ./

こんな感じ。


634 :login:Penguin:03/09/24 15:05 ID:eK+PeDKy
>>633
じゃあ、 upgrade でなく dist-upgrade でしょ。
でも何かが削除されるけどね。


635 :login:Penguin:03/09/24 15:07 ID:fswHZw6v
>>630
# apt-get install libc6-dev
してみたら?

636 :login:Penguin:03/09/24 15:07 ID:FS7lT3gF
>>634
さんくすこ、やってみます。


637 :login:Penguin:03/09/24 15:11 ID:FS7lT3gF
やってみました。

>>635
| # apt-get install libc6-dev
| してみたら?

こっちが正解でした。

うーん、holdしたような覚えは無いんだけどなぁ...

とりあえず解決しました、ありがとうございました。


638 :login:Penguin:03/09/24 15:46 ID:Y35GDn1R
>>630
そういう時は dselect とか aptitude 使って
依存関係を調べるのがおすすめ。

639 :626:03/09/24 16:30 ID:KW1fvWRe
>>627
漏れもそう思って入れないで実行したらエラーになった。
深く追求していないので、理由は謎だが。


640 :login:Penguin:03/09/24 18:03 ID:Ux881Z1Z
Woodyでboot-FDを作りたいのですが、うまい方法ありますか?

以前(potatoの頃?)はこんな感じでできた記憶があるのですが、

# superformat /dev/fd0
# dd if=/vmlinuz of=/dev/fd0
# rdev /dev/fd0 /dev/fd3

Woody(kernel-2.4.18)で同様にやってみたら、

Loading........
Uncompressing Linux...

invalid compressed format (err=1)

-- System halted

と言われて起動できません。redhatのmkbootdiskみたいなコマンドでもあるの
でしょうか? 


641 :login:Penguin:03/09/24 18:12 ID:eK+PeDKy
>>640 mkboot でどう?


642 :login:Penguin:03/09/24 18:27 ID:fzxw6ylC
>>639
# apt-get install libncurses5-dev

643 :login:Penguin:03/09/24 18:39 ID:Ux881Z1Z
>>641
mkboot は man 見たんですけど、オプション指定の
仕方がよくわからいので恐くて実行してないんです。

# mkboot -r /dev/fd0 /boot/vmlinuz-2.4.18

とかでいいんでしょうか? 


644 :login:Penguin:03/09/24 18:59 ID:g7T2jb/y
>>643
くだ室でどうぞ


645 :login:Penguin:03/09/24 19:03 ID:+DoXX6h4
>>644
Debian 固有のコマンドだからここでいいだろ。

646 :login:Penguin:03/09/24 19:10 ID:lkuaekS9
>>625
場所によってはいいよ。
data-hotel.net

so-net.ne.jp
はよい。1日送れだが確実に毎日更新してる

647 :login:Penguin:03/09/24 19:10 ID:fLpoZts4
お、skksearchなおってたのか・・・


648 :login:Penguin:03/09/24 20:22 ID:xXzT/Eql
>>643 -rは実際のルートパーティションを渡さすのでは?
あとgrubがインストールされてるとboot-FD作られないので注意ね。


649 :login:Penguin:03/09/24 21:37 ID:Ux881Z1Z
>>648
ありがとうございます。

# mkboot -r /dev/hda3 /boot/vmlinuz-2.4.18

とかでFDに書きに行きました。
liloでboot-FDができたけれど、残念ながら
"Error 0x10" みたいなメッセージを一瞬出して
ブートはしませんでした。HDDからのブートには
grubを使っているからかなあ。
もうちょっとねばってみます。

てゆーかgrubをFDに入れりゃいいんだろうけど。


650 :login:Penguin:03/09/24 23:12 ID:qD54wWsC
cp kochi-gothic.ttf /usr/share/fonts/truetype/kochi/kochi-gothic-subst.ttf
cp kochi-mincho.ttf /usr/share/fonts/truetype/kochi/kochi-mincho-subst.ttf

綺麗とは言えない漢字がいくつもあったので、試してみますた。

651 :login:Penguin:03/09/24 23:20 ID:sZpZ4eHX
久しぶりに公式見ると、
いきなり赤文字で
Protest against software patents
とある。
どういう意味?

652 :login:Penguin:03/09/24 23:22 ID:xU/paq8K
>>81

653 :login:Penguin:03/09/24 23:23 ID:sZpZ4eHX
>652
サンクスです。

654 :login:Penguin:03/09/25 00:20 ID:/dTQ+Ebx
>>559
遅レスだが、
ftp://oss.sgi.com/projects/xfs/download/patches/
から2.4.22用のパッチをとってくるのがよいと思う。
一カ所失敗するから、手パッチが必要になった記憶があるけど。


655 :login:Penguin:03/09/25 00:47 ID:cGRhGOcY
>>654
ありがとうございました。
xfs-2.4.22-all-i386.bz2 829 KB 2003年09月02日 21:18:00

2.4.21を使ってます、早速試してみます。

656 :login:Penguin:03/09/25 01:15 ID:1MAuUMz9
acパッチにはXFS入ってるんじゃなかったっけ。
2.4.22-ac4あたり。
入ってなかったらごめん

657 :login:Penguin:03/09/25 02:08 ID:4hv0Sl+C
>>656
ttp://www.kernel.org/pub/linux/kernel/people/alan/linux-2.4/2.4.22/
patch-2.4.22-ac4.bz2

XFS filesystem 入ってますね。

658 :login:Penguin:03/09/25 02:16 ID:csjmDxTO
ふぎゃーmigemoが入らんー
無いとなにもする気にならんぴー

またりー


659 :login:Penguin:03/09/25 02:27 ID:hQfepquW
eb 関係もおかしいな。

660 :login:Penguin:03/09/25 03:05 ID:UBqQ6W2v
>>657
わーい!

661 :login:Penguin:03/09/25 03:14 ID:csjmDxTO
debianっ娘は元気いっぱいという感じだな


662 :login:Penguin:03/09/25 06:11 ID:HN6QnoXD
debianで使えるP2pクライアントはある?

663 :login:Penguin:03/09/25 09:49 ID:JrbN+X0U
>>662
結構あるよ。


664 :login:Penguin:03/09/25 11:04 ID:1pB2MRJV
>>659
ちなみに、どうおかしいの?

$ apt-cache show libeb7
(...)
Conflicts: libeb, libeb4, libeb5, libeb6

これじゃ、なんのためにパッケージ名の末尾に数字をつけているのかわからんな。
Debian って、こういうもんなの?


665 :login:Penguin:03/09/25 11:53 ID:sol0/kVC
こういうもん。Debian に過剰な期待は禁物。
信者の言う「素晴しいパケジ管理ポリシー」を真に受けてはいけない。

666 :login:Penguin:03/09/25 11:59 ID:o9C+uveV
>>664
やってくれてるだけでありがたいってもんだよ。大半のパッケージはそんなこと
お構いなし。ライブラリのごみがいっぱい残る。

まあ、stable以外を使ってる限りはしかたがないね。日々更新されるunstableや
testingにそういうものを求めるのが間違い。

667 :login:Penguin:03/09/25 12:58 ID:7uI/qkEv
>>666 いや、これは単にバグだろう。

BTSへGo!気が付いた香具師が直さないといつまで立っても直らない...


668 :login:Penguin:03/09/25 13:03 ID:sol0/kVC
2ch で質問するような奴がメアドまで晒して BTS で報告するわけない。

669 :login:Penguin:03/09/25 14:06 ID:IMwDQXkx
>>668
普通はそう思うだろ?
でも 659 は一味違うんだよ。

670 :login:Penguin:03/09/25 14:12 ID:6S9v22po
そうですか

671 :login:Penguin:03/09/25 14:14 ID:6Tj42Wx0
そうだよ!!
みんな>>659を信じてあげてッ!!

672 :login:Penguin:03/09/25 14:30 ID:1pB2MRJV
調べてみると結構あるね。
grep-available -FSection libs | grep-dctrl -sPackage,Conflicts -FConflicts lib


673 :login:Penguin:03/09/25 14:39 ID:yfNpkEOm
テンプレの「特定パッケージを自動アップグレードの対象から外したい
(ttp://debian.fam.cx/?AptGet#content_1_22)」なんだけどさ。

Package: (パッケージ名)
Pin: version (バージョン)

これだけだと機能しなくなってねえ?
Pin-Priority: 1001 が必要な感じなんだが、みんなんとこどうよ?



674 :login:Penguin:03/09/25 15:15 ID:ff9D1C04
うお〜〜〜
パーティション壊れた・・・なんで・・・??
ブートもできない・・・
デフォルトのママのext3なのに・・・


675 :login:Penguin:03/09/25 15:32 ID:IMwDQXkx
>>674
質問? グチ?

676 :login:Penguin:03/09/25 16:43 ID:fX44SmWU
>>673
洩れも。
つい最近、テンプレどうりしたらうまくいかんかったのでそうした。
ちなみにsid。

677 :login:Penguin:03/09/25 17:04 ID:o9C+uveV
>>673,676
多分これのせい

apt (0.5.10) unstable; urgency=low

* Correct the section in apt_preferences(5) on interpreting priorities
to show that zero is not a valid priority, and print a warning if such
a pin is encountered in the preferences file (Closes: #204971)


678 :login:Penguin:03/09/25 17:24 ID:yfNpkEOm
>>677
なるほど。よくわからんけど1以上のPin-Priorityを入れないとダメになったっ
てことかな。
たぶん大丈夫だと思うけど、sarge/woodyでPin-Priority: 1001付けても問題
ないかな。
一応注意書きは付けて書き換えとくから、sarge/woodyで問題ないようなら注
意書き消しといてー。

679 :login:Penguin:03/09/25 20:28 ID:PkEN4sT8
テンプレ編集する時、一部編集すると編集対象でない前の段落(?)との間の改行
が消えてしまいます。これは仕様ですか?

680 :login:Penguin:03/09/25 21:08 ID:q3eHgL+v
>>678
Woody Sarge 共に確認して平気そうだったので消しときます。

681 :login:Penguin:03/09/25 21:14 ID:q3eHgL+v
>>679
確かに「一部編集」な機能を使うと、すぐ上のセンテンスと合体しちゃうね。

682 :login:Penguin:03/09/25 21:35 ID:7uI/qkEv
guruに日本語patchedなdilloが入った


683 :login:Penguin:03/09/25 21:55 ID:LAH93U+r
>>679

>>681

プラグインが古いせいです。バージョンアップきぼんぬ>管理者タン

684 :login:Penguin:03/09/25 22:20 ID:JrbN+X0U
>>682
使ってみた。
w3mより速い気がした。


685 :login:Penguin:03/09/25 22:29 ID:OMY4RlfZ
>>679,681,683
upしてみました。
直ってるでしょうか?


686 :login:Penguin:03/09/25 22:33 ID:q3eHgL+v
>>685
直ってるようです。
素早い対応乙です。

687 :login:Penguin:03/09/25 22:35 ID:LAH93U+r
>>685

早い・・・
乙彼です。

688 :login:Penguin:03/09/25 23:20 ID:9om5AM/s
asahi-netの調子が悪いんで、apt-lineにso-netを指定したら

# apt-get update
取得:1 ftp://ring.so-net.ne.jp sid/main Packages [2689kB]
エラー ftp://ring.so-net.ne.jp sid/main Packages
Unable to fetch file, server said 'Possible PASV port theft, cannot open data connection. '
(以下、同様のエラーが続く)

というようなエラーが出たんだが、おまいらの中でこのエラーの解決法を
ご存じの方はおりませんでしょうか?


689 :login:Penguin:03/09/26 00:14 ID:+pMGQul+
>>apt.confのftpの設定にPassive "false";を設定してみるとか。
/usr/share/doc/apt/examples/configure-index.gzが参考になると思う。


690 :login:Penguin:03/09/26 00:17 ID:r863VRF+
asahi-netの調子が悪い

って、もう少し情報希望。
エラーなんかは出てないみたいなんだけど、そんなんじゃないの?使ってるのに。

691 :login:Penguin:03/09/26 00:24 ID:99SBdWnm
>>682
guruのdillo、日本語関連のpatchだけじゃなくてAAパッチまで入ってるじゃん。
感動した。

692 :login:Penguin:03/09/26 01:54 ID:+m8RznRx
>>689
Acquire
{
ftp
 {
  Passive "false";
 };
};

693 :login:Penguin:03/09/26 01:58 ID:l/eIY1Ct
わざわざ login 制限がある ftp なんかつかわずに、
http 使えばいいんじゃないの?

694 :login:Penguin:03/09/26 14:11 ID:fBuIEeL0
>>693
ftpで持ってきたい事情があるのかもしれない。

695 :$HOME/.emacs.d/:03/09/26 16:50 ID:2a4xpz/i
今まで emacs20 を使っていて、最近 emacs21 にしたら
$HOME/.emacs.d/ ができました。

これって、$HOME/.emacs はもうふるいから使うべきではなく、
これからは $HOME/.emacs.d/ にいろんなファイルを入れておきなさい、
というお告げなのでしょうか?

696 :login:Penguin:03/09/26 17:46 ID:vpr1YuBE
アルェー、またルートパーティション(ext3)壊れたよ・・・
今度はインストールしてsidにupgradeしてカーネルを2.4.22にして再起動しただけなのに・・・
ちなみに、別のlinuxからfsckはできるしマウント(ext3)はできるのに・・・


697 :login:Penguin:03/09/26 17:52 ID:BrPfXo1m
>>696
それは本当に壊れてるのか?


698 :login:Penguin:03/09/26 18:15 ID:2a4xpz/i
壊れてないと思うけどな、それは。

699 :login:Penguin:03/09/26 18:25 ID:vpr1YuBE
ちょっと、言い間違えた。
他のlinuxからchrootすることはできてるので、壊れてるわけじゃないっすね。
実際にbootすると「Read only〜」で止まってしまう・・・
fstabでext2にしても同じ。bootの過程で、マウントのし直しに失敗してる、ということなのかな?
バグだとしたら、自分だけというのも変だしな。
まあ、勉強と思って、bootスクリプト追っかけてみる。


700 :login:Penguin:03/09/26 18:31 ID:1RT9eHuw
ただブートしようとしてるカーネルにマウントしようとしてる
ディスクのサポートが組み込まれていないだけじゃねーの

701 :login:Penguin:03/09/26 18:39 ID:vpr1YuBE
普通のIDEだし、カーネルをインストール時のもの(bf2.4)にしても同じやね・・・

まさか、VIAチップののろいか?でも他のLinux(2.4.21)はちゃんと動いてるんだよな・・・


702 :login:Penguin:03/09/26 18:50 ID:2a4xpz/i
念のためカーネルに root= オプションつけてみたら?

703 :wamu:03/09/26 19:18 ID:5eEcbOfe
クソ、sid XFree86-4.3でxawtv起動したらこれだよ。

v4l2: WARNING: framebuffer base address mismatch
v4l2: me=0xe5800000 v4l=(nil)

画面は緑色のジャミジャミ。

録音ツールはのきなみアウトだし。
EsounDはlocalhost:5001がアクセスできない。

vcrパッケージは録画始めたらラリって終了しないし。
無茶苦茶状態。なんでウチのはこんなにイカモノなんだよう。

これもVIAチップののろいかJOJO?

704 :xdvipdfmx の問題?:03/09/26 19:51 ID:2a4xpz/i
sarge を使っています。 xdvipdfmx をインストールすると
/usr/share/doc/dvipdfmx/README.Debian にしたがって
/etc/texmf/texmf.d/50dvipdfmx.cnf
を修正しなさいといわれますが、そこにはこんな記述があります。

CMAPINPUTS = .;/usr/share/fonts/cmap/adobe-gb1//
;/usr/share/fonts/cmap/gs-cjk-resource//

これのままだと GB はいいんだろうけど、日本語のファイルはうまく変換できないから、
adobe-gb1 のところは adobe-japan1 にしておいたほうがいいですね。

705 :login:Penguin:03/09/26 20:22 ID:+pMGQul+
>>704 そう。あとadobe-japan2くらいかなぁ > 書き足すの


706 :login:Penguin:03/09/26 21:54 ID:X8ipiC7s
Woody で guru の dillo で日本語が表示されません。
libc6 が 2.2.5-11.5 なので apt-get source dillo して入れたのですが
英字はきれいな AA なのに日本語は透明で全く見えないのです。
# ttp://oldeee.see.ed.ac.uk/~rjt/dillo/nihongo.html
# からもらってきたものだと、AA できないけど日本語は出てます。

xft がらみかと思うのですが、どうしたらいいのかわかりません。
どなたかヒントくださいませ。

~$ dpkg -l | grep xft
ii libgdkxft0 1.5-4 transparently adds anti-aliased font support to gtk+-1.2

~$ sudo apt-get -s install libxft2
...略...
Sorry, but the following packages have unmet dependencies:
libxft2: Depends: libc6 (>= 2.3.1-1) but 2.2.5-11.5 is to be installed
Depends: libfontconfig1 (>= 2.2.0) but it is not going to be installed
Depends: libfreetype6 (>= 2.1.4-1) but 2.0.9-1 is to be installed
Depends: xlibs (> 4.2.0) but 4.1.0-16woody1 is to be installed
E: Sorry, broken packages




707 :login:Penguin:03/09/27 00:36 ID:b329JZ3M
sidでnvidia-glx-devがアンインストールできないんだけど、どうしたらいいの?

エラーはこんな感じ

(Reading database ... 90715 files and directories currently installed.)
Removing nvidia-glx-dev ...
dpkg-divert: mismatch on divert-to
when removing `diversion of /usr/lib/libGL.so to /usr/share/nvidia-glx/diversions/libGL.so by nvidia-glx-dev'
found `diversion of /usr/lib/libGL.so to /usr/lib/nvidia/libGL.so.xlibmesa by nvidia-glx-dev'
dpkg: error processing nvidia-glx-dev (--purge):
subprocess post-removal script returned error exit status 2
Errors were encountered while processing:
nvidia-glx-dev

708 : :03/09/27 00:36 ID:52NZXg1j
すんません。sarge でsendmail 使ってる方、今度の穴の対策は
どのようにしているのでしょーか?
やっぱ、パッチ当てて、dpkg-build したほうがよい?
それともsidから降りてくるの待ってるのかな・・・

709 :login:Penguin:03/09/27 00:46 ID:+9kV8UAq
>>708
これを機にPostfixへカモーン
今ならsendmail互換コマンド付き!


710 :login:Penguin:03/09/27 00:48 ID:Xfnd0hPD
debianの基本的なコマンドとか覚えたんで、次はApache勉強しようと思ってます。
Apacheをinstallするのはパッケージとソースのどっちが良いのですかね?
本を一冊買ったのですが、初めてはソースからが設定しやすいとか。。。。。
でも、apt-getすればinstall楽チンぽいし。。。
始めて野郎にオススメってどっちでしょうか?

711 :login:Penguin:03/09/27 00:52 ID:kBU4VxmP
>>706
多分Xを4.2以上にしないとむりぽ。
4.1じゃxft2もfontconfigも使えなかったと思ふ。
どっちにしろlibc6も2.3も要求してるからdilloもrebuildだな。
guruにwoody向けのものはない。

>>708
glibcに依存してるものは降りてくるのが遅くなる可能性があるから
できるなら自前で修正した方がいいんじゃないの。

>>710
まずインスコの勉強をしたいならソース。
まず使い方の勉強をしたいならパッケージ。

712 : :03/09/27 00:57 ID:52NZXg1j
>>709
sendmail じゃなきゃダメなのよ。
複数台メールサーバがあって細かなリレー設定してるし、
postfixを使ったこともないので、それやろうとすると設定ファイル
作るのに死にそう。


713 :login:Penguin:03/09/27 00:58 ID:MQetQyUP
>>706 Xft絡みだね。gnome2のbackportを置いてあるサイト等にlibxft2の
backportも置いてあると思うから、それを入れてリビルドするのが速いかな。
ただXのupgradeも必要だったりしてなかなか難儀ではある。

#つーかlibxft1(XftConfig)の設定なんてもう忘れたよ...

>>707 なんかおかしくなってるね。/usr/share以下にsoをdivertしてある時点で
ありえないような...とりあえず、
/var/lib/dpkg/info/nvidia-glx-dev.postrm:
でdpkg-divert --removeしているなかからエラーが出ている箇所をコメントアウト
してみるとどうか?


714 :login:Penguin:03/09/27 01:00 ID:MQetQyUP
>>711 むは、かぶった


715 : :03/09/27 01:06 ID:52NZXg1j
>>711
結局、sargeじゃapt-get 使う意味が半減しますね・・・

716 :login:Penguin:03/09/27 01:12 ID:MQetQyUP
>>715まぁsecurity fixはいかんともしがたいなぁ...
いっそsidに上げた方が楽かも知れませんね
(ちゃんとdebian-devel@orgとかで動向を追っていれば)


717 :706:03/09/27 01:19 ID:+zt79fI9
>>711,713
thxです。libc6 を upgrade する勇気がないのでとりあえず
xfree86 4.2.1-3woody3 を apt-get source してます。

ところで最近 X の 4.1 ではセキュリティ関連の修正が出ましたが
4.2 だとどこからパッチをもらってくるのがよいのでしょうか。


718 :login:Penguin:03/09/27 01:34 ID:kBU4VxmP
>>717
sidから貰ってくるとか。

719 :login:Penguin:03/09/27 01:56 ID:7JhA+g7u
/var/log/XFree86.0.log
の中で
(WW) Open APM failed (/dev/apm_bios) (No such device)
って言われてしまってる。
ACPIを有効にしてつかってるんだけど、、、
エラーを無視してて良いですか?

720 :login:Penguin:03/09/27 02:03 ID:kBU4VxmP
warningなんてほっとけ。

721 :login:Penguin:03/09/27 02:06 ID:7JhA+g7u
>>720
(WW) = warning だもんね。

どもどもありがと。

722 :login:Penguin:03/09/27 03:07 ID:GUzp7Xx2
gs周りがおかしくなったか,dvipdf, ps2pdfが動かなくなったな

723 :login:Penguin:03/09/27 09:44 ID:OcKjb6yi
>>722
# dpkg -i ttf-kochi-mincho_0.2.20020727-2_all.deb
# dpkg -i ttf-kochi-gothic_0.2.20020727-2_all.deb
して昔の東風フォントに戻してやるとなおるんですけどね。
とりあえずholdしておくか……DFSGごめんなさい。

英語で(しかもメアド晒して)BTSに送れないDQNです。
だれかgotomタンに伝えてくださいませ……

724 :688:03/09/27 15:08 ID:zW0CH2XV
>689, 692
おぉ、そんな設定があるんですか。参考になります。

>693, 694
単にファイルを持ってくるなら ftp の方がいいかな〜、程度の理由です。
ネットワークの負荷とかを考えると、どっちがいいんだろ?

>690
Packages.gz ファイルを見に行ったきり、反応が返ってこないって
現象だったけど、今日やってみたら直ってました。

とりあえず、ftpをhttpに変更して対処することにしました。
教えてくれた方々、ありがとうございますた。


725 :login:Penguin:03/09/27 15:23 ID:ffPMEYFA
>Packages.gz ファイルを見に行ったきり、反応が返ってこないって
それって鯖が混んでるだけじゃないのか。

726 :login:Penguin:03/09/27 16:40 ID:+m/pWMhz
sidで試しにkernel-image-2.6.0-test4-1-386を、aptで入れたんだけど
usbマウスXで動かない。

何か変更しないといけないの?

727 :login:Penguin:03/09/27 16:44 ID:NEt8HNs1
apt-get install foo bar hogehoge
といった感じで複数のアプリをインストールできるのは知ってますが、
同時にインストール可能な数には限度がありますか?例えば文字数とか。
てか、あんまり多くのアプリを一度に並べると「そんなん無いぜ」というメッセージが表われます。
個別だとインストールできるのでちょっと不思議。

728 :701:03/09/27 17:07 ID:WrZ5rdIR
だめだ・・・
通常、read-onlyでbootして init 2 でマルチユーザモードになるときにマウントし直されるわけだが、
なぜ、roのまま突っ走ってしまうんだろうか・・・
boot時のオプションから ro 消してもダメなんだな・・・

つうことでお手上げなので、再度インスコしてみる・・・
スレ汚し、スマソ。



729 :login:Penguin:03/09/27 17:28 ID:MQetQyUP
>>727 shell側の限界じゃないかな。それとも、そんなに多く
なくても出る?具体例を挙げて貰えれば何が分かるかも知れないが...


730 :login:Penguin:03/09/27 17:54 ID:KYdyFty9
日本語キーボードなのですが、インストール時に英語キーボードを選んでしまいました。
設定を日本語キーボードに直したいのですが、
どうすればいいのでしょうか?
よろしくお願いします。


731 :727:03/09/27 17:59 ID:NEt8HNs1
>>729
ご回答ありがとうございます。
医者じゃないんですが、debian インストールを ttp://www.orca.med.or.jp/receipt/tec/woody/woody_install_jma.html に倣って行なってみますた。
その中の「42. 基本日本語環境のインストール」部分に書かれている以下の既述をやろうと思って今回の件に気付きました。
apt-get install language-env user-ja canna freewnn-jserver skkserv canna-utils grep-ja kterm manpages-ja jless doc-debian-ja doc-linux-ja-text ja-trans tcsh-kanji kinput2-common kinput2-canna maint-guide-ja debian-jp-keyring
個別に入れられるので実害はないんですが、debian コミュニティの ML で尋ねる勇気もない小心者なので。(汗

732 :login:Penguin:03/09/27 18:05 ID:BXOWshJd
# dpkg-reconfigure hogehoge

詳しくわ ttp://debian.fam.cx/

733 :login:Penguin:03/09/27 18:05 ID:XCTednBz
カーネル2.4.20で / をext2→ext3にしようと思っているのですが
もしかしてDebianのmkinitrdは Redhatのそれと中身が違いますか
/etc/mkinitrd/mkinitrd.confを見ると、mkcramfsなるものを呼び出しているようですが、

漏れの/boot/config-2.4.20は
# CONFIG_CRAMFS is not


何かこのまま特攻するとやばそうな予感がしますが、やっぱり
カーネル再構築が必要ですかね…(´・ω・`)


734 :login:Penguin:03/09/27 18:48 ID:WrZ5rdIR
ext2→ext3にするのにカーネルの再構築の必要あったっけ?

そもそもinitirdが読み込まれるときは、ext3であってもext2でマウントされている、はず。


735 :login:Penguin:03/09/27 18:53 ID:mzOAm1TR
>>731
cannaにwnnにskkのサーバと、そんなに入れてどうするんだ?
全部使う事情があるなら別だが、フツーどれかひとつで十分。
user-jaはlanguage-envのダミーパッケージだから要らないぞ。

つか「そんなん無いぜ」あたりのメッセージを意訳しないでそのままコピペして。

736 :730:03/09/27 18:56 ID:KYdyFty9
# dpkg-reconfigure cosole-data
とかやったのですが、
パッケージ 'console-data' はまだインストールされておらず情報が利用不可能です。
と出てきます。
console-data は apt-cache では出てこないようなのですが、
どうすればよいのでしょうか?
よろしくお願いします。


737 :login:Penguin:03/09/27 19:05 ID:mzOAm1TR
>>736
apt-lineを正しく書いてapt-get updateしろ。

738 :730:03/09/27 19:11 ID:KYdyFty9
apt-get update したら、ちゃと出てきました。すみません。
ありがとうございました。

739 :login:Penguin:03/09/27 19:24 ID:MQetQyUP
>>731 試してみたけど問題なかったYO!エラーメッセージも
晒してくれるとありがたい。

>>733 kernel-imageはofficialのやつ?なら問題ないと思われ。
つかtune2fsするだけならinitrdに触らんでしょ

>>735 まぁ最初は何が必要か分からなかったりするからね...
色々試してみるのもいいんでない?


740 :login:Penguin:03/09/27 19:59 ID:+m/pWMhz
>>726

自己レスです。
せっかくだからP4用にカーネルを再コンパイル、しかし駄目
組み込まれてるモジュールを見る、ななんと無い、手動で入れる
OK

結果
HotplugのMurasakiは駄目でした、hotplugはOK
なんと無駄な時間を使ったことか・・・


741 :727:03/09/27 20:37 ID:NEt8HNs1
>>739
> エラーメッセージも晒してくれるとありがたい。
kterm, xterm で試してみますた。
例えば、既にインストール済みの場合だと以下のようになりますよね。
apt-get install canna
Reading Package List... Done
Building Dependency Tree ... Done
Sorry, canna is already the newest version.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

ところが、>>731 のようにやると以下のメッセージしか表われません。
Reading Package List... Done
Building Dependency Tree ... Done
Sorry, language-env is already the newest version.
Sorry, canna is already the newest version.
Sorry, freewnn-jserver is already the newest version.
E: Couldn't find package grep-ja

たしかに件のサイトの記述のままだと grep-ja は apt-get install grep-ja やっても存在しないし、
grep 単独で i18n 化が終わっているのでエラー表示が表われるのは理解できるのですが、
他のファイルはどこ行っちゃったのかな?と。

で、いま気付いたんですが、grep-ja を grep に直して再度試みると
Sorry, language-env is already the newest version.
(略)
Sorry, maint-guide-ja is already the newest version.
E: Couldn't find package debian-jp-keyring
となりました。
debian-jp-keyring は現在見当たらんのですが、ここで >>731 の先頭のファイル名の language-env を language--env と存在しないファイルにしてみたところその段階でストップしました。
ってことで、apt-get install の場合、存在しないファイル名があるとその時点でエラー吐いてお終いって感じみたいです。
apt-get -v の結果は、apt 0.5.4 ですた。以上、長文失礼しますた。

742 :login:Penguin:03/09/27 20:40 ID:uCcGdMZi
>>727=741
それって、「個別にインストール出来る」っていう最初の前堤が既に間違ってないか


743 :login:Penguin:03/09/27 20:50 ID:GdwVs4Ns
pool/より、Packages.gz, Release.gzが先にupdateされちゃうってこと結構あるよな…

744 :733:03/09/27 21:40 ID:XCTednBz
>>734
>そもそもinitirdが読み込まれるときは、ext3であってもext2でマウントされている、はず。
逆に、ext3を読むにはinitrdを経由する必要があるという事ですよね?
Redhat7.xでは、普通にmkinitrdで出来ていたのですが、
Debianではshell scriptになっていて、そこからmkcramfsを呼び出して…
という形になっている事に気付いたので、これは一体何だろう、と。

>>739
すみません、kernel-sourceパッケージから作り直した奴です。
ぐぐってみたらあるページでCONFIG_CRAMFS=yという記述が見つかったので、
もしかしてここがnになってるとinitrdで展開したファイルシステムを読めない?とか
不安が出てきたもので…
何かの拍子に勝手にNにしてしまったのだろうか。うーん、しまった…

そうではなくて、initrdが常にext2でマウントしてくれるなら上の心配は杞憂ですね。
ありがとうございました、もう少し調べてみます…


745 :login:Penguin:03/09/27 23:38 ID:p8wpYYeC
なんかあさっての方向に.....
ext3でマウントしたい&&ext3はモジュールだ
という時にinitrdをつかうのでしょ。
「ext2でマウントしてくれる」initrdなど欲しくない。

746 :login:Penguin:03/09/28 00:31 ID:qc4bDxpn
postgresがなんでeximに依存してるんだよ・・・


747 :login:Penguin:03/09/28 00:42 ID:0LuwhgNM
依存してないぞ?
mailxはMTAに依存しているが。

748 :login:Penguin:03/09/28 00:48 ID:qc4bDxpn
eximをremoveすると、postgresも消されるんだけど・・・


749 :login:Penguin:03/09/28 00:51 ID:0K8Z2Bsz
>>748
だからMTAに依存してるからでね?
postfixなりqmailなり入れればeximだけ消せるべ。

750 :login:Penguin:03/09/28 00:56 ID:qc4bDxpn
ああ、なるほろ。


751 :login:Penguin:03/09/28 22:25 ID:DZJjnNFH
woodyで東芝PCカードHDD1Gを使いたいんですが、挿すと
ピッっという音がした後、すぐにブッという音がします。
なにが問題なのでしょう?

752 :login:Penguin:03/09/28 22:37 ID:d/HoM3aU
>>744
root fsをXFSとか、reiserfsにして、かつ、
それらをモジュールとした場合にはinitrdが必要。
なぜなら、root fsを読むのにXFS.o(仮)が必要、
だが、XFS.oを読むのにroot fsを読まねばならない、
といった状況になるので。

ところが、ext3はext2に対して後方互換性?
を持っているという特殊事情があるので、
ext2fsを読めるカーネルならば、
とりあえず、ext2.o(仮・kernel組み込み)を使ってext3.o(仮)を読み込んで、
root fsをext3fsとしてリマウントというトリックをやってくれた気がする。


753 :login:Penguin:03/09/28 23:31 ID:7+MqTyKk
>>751
検索してみるから
もっと情報出してみて。

754 :login:Penguin:03/09/28 23:40 ID:F1jHGe3k
>>751
IBMのMicroDriveでなったことがある。
そんときはカーネルにそれ用のモジュール組み込んでなかった。
その辺調べてみては。

755 :login:Penguin:03/09/29 04:19 ID:eRfzIefN
初心者質問で恐縮ですが、TclやTkはどうすればインストールできますか?

756 :login:Penguin:03/09/29 05:10 ID:pcGjXheh
>>755
とりあえず
apt-cache search tcl/tk
してみるのはどうだ。

757 :login:Penguin:03/09/29 05:38 ID:nruj+VUO
今現在Woodyなんだが、Kernel2.6や2.4を使いたい、そんなときはどうすればいい?

カーネルハッカーはDebian使いが多いと聞いたので、簡単にカーネルを入れ換える仕組みとかあるのかなと勝手に思ってるんだが

758 :login:Penguin:03/09/29 05:59 ID:pcGjXheh
>>757
make-kpkg の使いかたをみる。

759 :login:Penguin:03/09/29 06:00 ID:DFVgp0uu
>>757
普通にkernel.orgのカーネル拾って来てmake-kpkg

760 :login:Penguin:03/09/29 06:07 ID:/PFH+AXB
>>758-759
オマイラやさしいな
オレは Google の URL を貼ろうとしてたってのに・・・

761 :login:Penguin:03/09/29 06:29 ID:A/zmoF7p
>>758-760
オマイラやさしいな
オレは Debian の URL を貼ろうとしてたってのに・・・



762 :login:Penguin:03/09/29 06:52 ID:/HLwilf/
>>751
そのカードが認識出来てないっていう問題

763 :login:Penguin:03/09/29 07:20 ID:8f+cySOW
一週間ほど前に apt-get update したら
2.6.0-test4があったので、入れた。(Sarge)
これはとても快調にうごいている。


きのうkernel.orgを冷やかしてみたら
2.6.0-test6があったので、make-kpkg中。

configの雛型はdebianの2.6.0-test4に
入っていたのを拝借した。

initrdがよくわからない。
/etc/mkinitrd/mkinitrd.conf
ではcramfsがデフォルトになっているが、
kernel.orgのカーネルはこれを受け付けないようだ。
manを読むとgenromfsを代わりに使えとある。

で、やってみたら"initrdがとてもビッグなので駄目です"、
と表示され、続いて
"ideのhddがunknownなblock-majorなのでrootfsがマウントできない"
と出て、カーネルがパニックして終了する。


764 :login:Penguin:03/09/29 07:22 ID:8f+cySOW
mkinitrd.confでは
all/most/dep/none
からinitrdにどの程度モジュールを入れるか選択できるようだ。

同じディレクトリにあるmodulesというファイルに
rootfsをマウントするのに絶対要るモジュールを列挙するといいらしい。

どのモジュールが要るのかわからないので
2.6.0-test4に入っていたinitrd.imgを
cramfsでループバックマウントして、中身を覗いて参考にしてみた。

そんなわけでただいま、いろいろ試行してます。

dpkg-deb: building package `kernel-headers-2.6.0-test6' in `../kernel-headers-2.6.0-test6_10.00.Custom_i386.deb'.
rm -rf debian/tmp-headers
echo done > stamp-headers
make[2]: Leaving directory `/home/baka/kernel/linux-2.6.0-test6'
make[1]: Leaving directory `/home/baka/kernel/linux-2.6.0-test6'
dpkg-genchanges -b -mUnknown Kernel Package Maintainer <unknown@unconfigured.in.etc.kernel-pkg.conf>
dpkg-genchanges: binary-only upload - not including any source code
dpkg-buildpackage: binary only upload (no source included)
rm -f stamp-building
echo done > stamp-buildpackage

リブートします。さようなら。


765 :login:Penguin:03/09/29 07:59 ID:0pyMhAGS
atp-getに惹かれてRedhatからDebianに切り替えたのですが
topをしてみると開発中のマルチスレッドプログラムと、
そのプログラムで使用している同じくマルチスレッドなMySQLが
スレッドごとに表示されてしまいます。

↓こんなふうに
4740 mysql 11 0 31208 30m 3192 S 2.2 4.2 0:00.09 mysqld
4744 mysql 11 0 31208 30m 3192 S 2.0 4.2 0:00.09 mysqld
4746 mysql 11 0 31208 30m 3192 S 2.0 4.2 0:00.08 mysqld
4748 mysql 11 0 31208 30m 3192 S 2.0 4.2 0:00.08 mysqld
4750 mysql 11 0 31208 30m 3192 S 2.0 4.2 0:00.08 mysqld

これをRedhatの環境のように一つにまとめて表示するようにはできませんか?
man topを見てもわからなかったので質問させてください。
ps axでもスレッドごとに表示されるからプロセス管理部分のバージョン関係かな?

環境は最初はWoodyいれましたがMySQL4を必要とするために
あれこれしてたらsargeになってしまいました。

766 :login:Penguin:03/09/29 08:00 ID:8f+cySOW
なんででしょう???

RAMDISK: romfs filesystem found at block 0
RAMDISK: Loading 3631 blocks [1 disk] into ram disk...done.
Freeing initrd memory: 3631k freed
Kernel panic:VFS:Unable to mount root fs on unknown-block(22,9)

lilo.confの"root"には/dev/hdc9が指定してあって、

unknown-block(22,9)というのはたぶんこれ↓です。
$ ls -l /dev/ide/host0/bus1/target0/lun0/part9
brw-rw---- 1 root disk 22, 9 1970-01-01 09:00
/dev/ide/host0/bus1/target0/lun0/part9

/etc/mkinitrd/mkinitrd.conf は以下のような具合で、
MODULES=dep
DELAY=0
ROOT=probe
UMASK=022
MKIMAGE='genromfs -d %s -f %s > /dev/null'
BUSYBOX=no
PKGSCRIPTS=yes

/etc/mkinitrd/modules には以下のモジュールを列記しました。
vesafb fbcon unix ide-mod pdc202xx_new aec62xx alim15x3
amd74xx cmd64x cs5520 cs5530 cy82c693 generic hpt34x
hpt366 ns87415 opti621 pdc202xx_old piix rz1000 sc1200
serverworks siimage sis5513 slc90e66 triflex trm290 via82cxxx
ide-probe-mod ide-disk ext3 xfs reiserfs g450_pll i2c-matroxfb
matroxfb_DAC1064 matroxfb_Ti3026 matroxfb_accel matroxfb_base
matroxfb_crtc2 matroxfb_g450 matroxfb_maven matroxfb_misc


767 :login:Penguin:03/09/29 09:35 ID:0A07Z2vb
>>766
devfsd入れてupdate-devfsdとかはしてるよね。

768 :login:Penguin:03/09/29 10:59 ID:sPcjPrz6
sidでdebian kernelの2.4.21-5と2.4.22-1インストールすると、/sbin/liloで「devfs=mountの記述がない」
の警告がでるので、これって付けた方がいいのですか?
ちなみに、debianのソース持ってきて覗いてみても、devfsの項目が見あたらないけど、
やっぱり、有効になってると解釈してもいいのでしょうか?

769 :>>757:03/09/29 11:07 ID:XEa34uZc
>>758-761
http://debian.fam.cx/?Tips#content_1_3
を貼るのは優しくないですか?

770 :login:Penguin:03/09/29 16:49 ID:WrXGVtWc
DNS ひく `dig' はどのパッケージ?


771 :login:Penguin:03/09/29 16:52 ID:7DSxPRDg
>>770
auto-apt search bin/dig
ttp://debian.fam.cx/?AptGet#content_1_18

772 :login:Penguin:03/09/29 16:53 ID:LBHtN3yR
>>770
http://debian.fam.cx/?AptGet#content_1_18

773 :751:03/09/29 18:51 ID:ZNBtZxzi
>>753>>754
ATA/IDE/MFM/RLL support --->
IDE, ATA and ATAPI Block devices --->
Enhanced IDE/MFM/RLL disk/cdrom/tape/floppy support
PCMCIA IDE support
をチェックしたら、使えるようになりました。
ありがとうございます。

774 :login:Penguin:03/09/29 20:28 ID:yV+IsG0M
woodyでSquirrelMail使ってる人いますか?
コンフィグで日本語の設定にしても、文字崩れません?
なんか、平仮名とか簡単な漢字は表示できてるけど
長文になるとへんな記号とかでぼろぼろ。

バージョン1.2.6だけど、pinして上の使わないと駄目?

postfix+courier-imapです。

775 :login:Penguin:03/09/29 21:30 ID:/HLwilf/
>>774
平気。
ちゃんと普通に使えてる。
Woody で qmail+vpopmail+courier-imap

776 :774:03/09/29 22:28 ID:yV+IsG0M
>775
そんなあ。
ひょっとして、courier-imapに原因があるのかな
などといってみるテスト。

でも、ローカルホストでsylpheedやら
mozilla mailで読むと、文字化けしないんだよね。

どんな化け具合かというとこんな感じです。

>この度は・髟阡擦\x{FFFD}\x{FFFD}屬鯆座廚靴討靴泙い泙靴\x{FFFD}(B
>誠に申し訳ございませんが・髟阡擦甘\x{FFFD}紊泙\x{FFFD}(B
>今しばらくお待ち頂けないでしょう瘢雹か。

↑ね、おかしいでしょう

777 :login:Penguin:03/09/29 22:43 ID:Ea8V0rOc
>>774
うちも正常に使えてる

courier-mta + courier-imap

778 :login:Penguin:03/09/29 22:57 ID:Hgx/WvoE
>>774
うちは文字化けはしねーけど、SquirrelMail自体の挙動が不審だった。
Woodyでpostfix+courier-imap

ってただ漏れの技術力不足の悪寒。

779 :774:03/09/29 23:51 ID:yV+IsG0M
みんなうまくいってる!

しょうがないので、Squirrelピンハネしました。
testingの1.4.0-1です。

そしたら文字化けなおりました。
しかもメニュー日本語だし格好いい。

でも、SquirrelMail使ってる人結構いるんだね。
なんかうれすい。

780 :login:Penguin:03/09/30 00:47 ID:TakyFSSD
>>779
> testingの1.4.0-1です。
なぜ日本語版を使わない?

781 :login:Penguin:03/09/30 02:31 ID:r3QUwuup
突如ターミナルが正常起動しなくなり、(ツール非表示、入力非受付、
右角クリックしてもなぜか閉じない。起動に数分かかる。)
MOZILAもツールバーが表示されなくなってしまいました。
GONOME関連かと思ったのですがKDEで起動してもよくにた症状なんです。
どのようにして修復すべきでしょうか?どなたか教えてください。


782 :login:Penguin:03/09/30 06:31 ID:OLOQu2DL
unstable

java 関連は何をインストすれば幸せになれるのでしょうか?

783 :login:Penguin:03/09/30 07:24 ID:ULgVxkOa
>Subject: blackdown
>Date: Thu, 1 Mar 2001 20:45:45 +0000 (GMT)
>
>Umm.. dudes.
>deb http:// ftp.linux.org.uk/pub/linux/java/debian potato non-free
>(or http:// www.blackdown.org/java-linux/mirrors.html
> to find your nearest mirror)
http://lists.debian.org/debian-java/2001/debian-java-200103/msg00027.html


>Subject: blackdown java 1.4.1 (gcc3.2) debs available
>Date: Tue, 06 May 2003 15:26:39 +0200
>
>blackdown java 1.4.1 (gcc3.2) debs available
http://lists.debian.org/debian-java/2003/debian-java-200305/msg00007.html

784 :login:Penguin:03/09/30 07:37 ID:OLOQu2DL
>>783
速攻で教えていただきありがとうございまーす。

785 :login:Penguin:03/09/30 12:23 ID:wmUxga07
>>774
deb http://www.yaromai.net/~nsaito squirrelmail/


786 :login:Penguin:03/09/30 12:57 ID:OLOQu2DL
>>783
java ゲームとパズル
http://java.sun.com/getjava/ja/showcase.html
こちらサイトで動作を確認しました。

/etc/apt/sources.list に追記
# Blackdown Java 1.4.1 Standard Development Kit
deb http://jopa.studentenweb.org/debian ./

apt-get update
apt-get install j2sdk1.4

以上でした、ありがとうございます。

unstable `sid'

787 :login:Penguin:03/09/30 13:59 ID:hnFPnTNX
unstable ですが, netscape7.1 で http://www.yahoo.co.jp/ をひらくとエラー
メッセージなしで落ちるのですが同じ現象を体験したヤシはいますか?


788 :sage:03/09/30 14:14 ID:qFYHDTVf
Sis651オンボード、Xが立ち上がりません。
方法あるのでしょうか?

789 :login:Penguin:03/09/30 14:29 ID:WmDmeMDE
>>781
くだらない質問はここに書き込め! Part58
http://pc.2ch.net/test/read.cgi/linux/1064047020/

>>788
>>1

790 :login:Penguin:03/09/30 14:32 ID:OLCPTKXj
>>786
mozillaでjava使えてる?


791 :login:Penguin:03/09/30 14:46 ID:OLOQu2DL
>>mozillaでjava使えてる?

java ゲームとパズルは、動きます。全ては確認してないですが。

google.co.jp/ の
○ウェブ全体から検索 ○日本語のページを検索

広告掲載について - 人材募集 - Googleについて - Google.com in English
の間にあるバーナーが表示できていません。


792 :login:Penguin:03/09/30 15:11 ID:OLOQu2DL
>>791
google.co.jp/ の
バーナーが表示できていません。

って、linux ではじかれてるだけ?

793 :login:Penguin:03/09/30 15:16 ID:OLOQu2DL
>>790 mozillaでjava使えてる?

http://www.kbc.co.jp/livecamera/index.shtml
こんな所のライブカメラも見えてます。

794 :login:Penguin:03/09/30 16:54 ID:hnFPnTNX
unstable ですが, flashplayer-mozilla や flashplayer-nonfree 等入れて
mozilla もしくは netscape で http://www.yahoo.co.jp/ をひらくと落ちる
ことが多々あります. これじゃ困るなぁ.



795 :login:Penguin:03/09/30 17:11 ID:OLCPTKXj
>>794
今頃そんなこといわれても

796 :login:Penguin:03/09/30 17:47 ID:WmDmeMDE
>>794
ログぐらい嫁よ。

797 :login:Penguin:03/09/30 18:06 ID:rs+olLGz
>>792
赤帽かWindows使えば?

798 :login:Penguin:03/09/30 18:45 ID:WmDmeMDE
>>791-792
Mozilla Part3 - 肉体改造中 -
http://pc.2ch.net/test/read.cgi/linux/1051559264/

799 :login:Penguin:03/09/30 20:36 ID:LPyf+jgI
stableですが。upgradeしたら、X関係がいくつもアップグレード
されました。やばいな・・・と思いましたが、再起動したら案の定、
文字化けして、マウスが動かなくなってました。

upgradeの時って、設定ファイル書き換えちゃんですか?
バックアップ残してくれないのかな?
そもそも、設定ファイルって今回のupgradeでは互換性は
維持されてないんでしょうか?

とりあえず記憶を頼りに、XF86Config-4を書き換えてみます・・・が

800 :login:Penguin:03/09/30 21:05 ID:NeieSYpp
>>799
hoge.d/ 以下に書き込んで update-hoge すべきところを
全部 hoge.conf に書いてたんじゃない?

801 :login:Penguin:03/09/30 21:10 ID:P2Q5hVED
レンレンキタ━━━━━━(゚∀゚)━━━━━━ !!


802 :login:Penguin:03/09/30 21:52 ID:3inmMStb
aptソース作るときって、apt-moveってファイル移動した後
Packages.gzとか作るのってどうやったらいいの?
pool内のファイルにapt-ftparchiveかけると、dists別にPackagesファイル作れないし。。。

803 :login:Penguin:03/09/30 22:41 ID:KTuoPWLQ
>>802
apt-move packages じゃなくて?

804 :login:Penguin:03/09/30 23:27 ID:tw+cPQSm
赤帽などでいうe2fsckやfsckなどの自動修復コマンドはないのでしょうか?
それらを入力するとmanを呼んだみたいにヴァージョン表示のみで、
稼動してくれません。

805 :login:Penguin:03/09/30 23:58 ID:65M+snYU
man e2fsck
e2fsck -f


806 :login:Penguin:03/10/01 00:41 ID:l9oBzTxR
>>795
>>796
過去ログは flash で検索かけたんでつが該当投稿が出てきませんでした。過
去ログのどのへんで出てきた話題ですか?


807 :login:Penguin:03/10/01 00:43 ID:+FLqjpFm
ターミナルからvim6.2.98を起動すると、挿入モードのときのカーソル移動で、AとかBとか入力されてしまう。
$TERM=xtermなどで起きる(コンソールでは起きない)現象なので、terminfoのバグだと思うんだけど、
Debianのterminfoソースってどこにあるんですか?
やっぱり、terminfoさわるにはESRさんのterminfoからコンパイルするしかないのですか?

808 :login:Penguin:03/10/01 00:46 ID:YEoxk1PK
>>699
ちょっと遅かったけどまだ見てるかな?

devfs 使ってる?
前にalsaをupdateしたら、devfsdの設定ファイルがつづり間違ってて
起動時に似たような状態になった気がする。


809 :login:Penguin:03/10/01 01:01 ID:P08VpJ8q
>>806
testingのなら落ちないね。
バージョン下げてみたら?


810 :login:Penguin:03/10/01 02:00 ID:+FLqjpFm
>>808,768他
どうやら、sid Officialカーネルはdevfsはonだけど、automount devfsはoffになってるようで。
つまり、カーネルオプションにdevfs=mountの記述が必要ということになる。


811 :login:Penguin:03/10/01 02:35 ID:l9oBzTxR
>>809
flash ? それとも mozilla の方? flash の testing の方は, 以下のエラーが
出てインストールに失敗しするようです.

mozilla だとインストールし直しに大分時間がかかってしまうので未確認でつ.

Setting up flashplugin-nonfree (6.0.79-2) ...
/usr/sbin/update-flashplugin:110: warning: don't put space before argument parentheses
/usr/sbin/update-flashplugin:183: warning: don't put space before argument parentheses
/usr/sbin/update-flashplugin:212: warning: don't put space before argument parentheses
/usr/sbin/update-flashplugin:213: warning: don't put space before argument parentheses
/usr/sbin/update-flashplugin:214: warning: don't put space before argument parentheses
/usr/sbin/update-flashplugin:223: warning: don't put space before argument parentheses
/usr/sbin/update-flashplugin:232: warning: don't put space before argument parentheses
Checking new upstream release...
/usr/sbin/update-flashplugin:274: warning: toplevel constant TimeoutError referenced by Errno::TimeoutError
E: Unknown HTTP error.


812 :login:Penguin:03/10/01 07:49 ID:A8o5weqJ
サウンドの設定コマンドはどういうものでしょうか?sndconfigは認識してくれないんです。

813 :login:Penguin:03/10/01 09:47 ID:OLSTE7kK
>>812
/etc/modutils/soundに「alias sound-slot-0 hoge」とかいろいろ書いてupdate-modules


814 :login:Penguin:03/10/01 10:51 ID:Y4m3lWFQ
apt-moveの使い方詳しく書いてる所ない?

815 :799:03/10/01 12:45 ID:d5MRxaNU
XFConfig-4を自分で書き換える場合、追加内容を書くべきファイルが
どこか別にあるんですか?(gsのフォントの設定みたいに)

たまたまemacsのバックアップファイルが残っていたので、それで復帰
しました。(それでも、何かを書き換えた前のバックアップなんだろう
けど・・・)
フォントパスも追加のマウスの設定もapt-get upgradeで引き継がれな
かったので、ちょっと今後のupgradeが怖くなりました。


816 :login:Penguin:03/10/01 12:49 ID:7x8olw0o
>>815
「### BEGIN DEBCONF SECTION」より前に書いとけばいいのでは。
それか sudo dpkg-reconfigure xserver-xfree86 して
最初の質問 (debconf 管理下に置くか) に No と答えるか。

817 :login:Penguin:03/10/01 12:59 ID:eJJ8sUyh
>>815
816のようにするか、dpkg-reconfigure debconfでcriticalと前に訊いた質問を再びしない、設定にする。
これだと、Xだけでなく他のdebでも下らん質問はしなくなる。

818 :login:Penguin:03/10/01 13:19 ID:oP771qeT
>>814 apt-move

apt-moveを使う、使いたいと思うくらいのスキルであれば
検索くらい出来るだろうし、、、。
なんなら自分で書いてどこかにアップしてくれたら
みんなの為になる。

819 :login:Penguin:03/10/01 13:51 ID:BEJHgFjr
起動する度に「画像 gnome-pkgview/pkgview.png の読み込みに失敗しました。
詳細: ファイルがありません,」という三つも同じアラートがでます。どのファイルをいじれば修復できますか?

820 :login:Penguin:03/10/01 13:55 ID:7x8olw0o
「何を」起動するたびなのかわかる
エスパーの方を募集中です。

821 :login:Penguin:03/10/01 14:02 ID:oP771qeT
>>819
apt-get --purge remove gnome-pkgview
apt-get install gnome-pkgview
出来る?

822 :login:Penguin:03/10/01 14:18 ID:oP771qeT
>>
gnome-pkgview - あなたの GNOME 2 デスクトップのバージョンを表示

おいらには、入ってないなあ。

823 :login:Penguin:03/10/01 14:21 ID:W4XgJwkL
ところで、もう dselect って廃れちゃったの?
これからは aptitude の時代?

824 :login:Penguin:03/10/01 14:31 ID:46JRtArz
どっちも使ってません

825 :login:Penguin:03/10/01 14:36 ID:W4XgJwkL
>>824 え? apt-get だけつかってるの?

826 :login:Penguin:03/10/01 14:41 ID:q0REkh9z
>>814
apt-ftparchive使えば?

827 :login:Penguin:03/10/01 15:39 ID:46JRtArz
>>825
apt-cache/apt-getだけあれば良くね?せいぜいauto-apt

828 :login:Penguin:03/10/01 16:20 ID:ibtjHjMW
>>825
aptitude(dselect)はパッケージを眺める時にしか使ってないな。
auto-apt以外に、インスコされてないファイルを検索できるツールほすぃね。

sidのkde-i18n-* 4:3.1.4-1がインスコできないな。
kdebaseに依存するようになってて、kdebaseに依存しているksysguardがインスコできない?
つか、なんでkde-i18n-*をkdebaseに依存させるんだょぅ。

829 :login:Penguin:03/10/01 16:38 ID:oP771qeT
>>828 インスコされてないファイルを検索できるツールほすぃね
synaptic - APT の Gtk GUI フロントエンド
synaptic-debtags - Gtk GUI-frontend for APT with debtags support

こんなのは嫌いかい?

gaim とかも、、、。つっかえてる。

830 :799:03/10/01 16:39 ID:d5MRxaNU
>>816,817
debが全く質問してこないのは不安なので・・・。>817の方法は(私としては)
やりすぎになりそうです。じゃあ、Xも全く自分の管理で大丈夫か?と考えると、
バージョン上がってXF86Configの書き方が変わったときに、サラで自分で
書けるかどうか、ちと不安・・・。

>「### BEGIN DEBCONF SECTION」より前に書いとけばいいのでは。
という方法が良さそうなのですが、例えば、フォントパスを1行追加するには、
どうしたら良いのですか?フォントセクションをまるまる全部書くのかな?
マウスの追加はインプットセクションを書けば良いって事でしょうか。


831 :login:Penguin:03/10/01 16:39 ID:W4XgJwkL
あのさ、長年使っていると、必要も無いのにインストールされっぱなしになっているパッケージが増えてこない?
まぁディスクの肥やしになるだけだからいいんだけどさ。

832 :login:Penguin:03/10/01 16:45 ID:Ox8rJeko
>>831
deborphan

833 :login:Penguin:03/10/01 16:51 ID:7x8olw0o
>>830
> 例えば、フォントパスを1行追加するには、
> どうしたら良いのですか?
最初か最後に Section "Files" をまるまる書いて、
dpkg-reconfigure の最後の方の
「設定ファイルにデフォルトの Files セクションを作りますか?」に
No と答えればいいんじゃないかな。

> マウスの追加はインプットセクションを書けば良いって事でしょうか。
Identifier が同じだと前に書いてある方が有効っぽい。
なんで、最初にまるまる書いておけばたぶん大丈夫じゃないかな。

試してない & ちゃんと調べてないので
おかしかったらツッコミきぼんぬ。

834 :login:Penguin:03/10/01 16:56 ID:oP771qeT
>>832
deborphan - みなし子化されたライブラリを調査
その意味ではないような、、、。

いくつ使わんパッケージを入れてても
HDDがでかけりゃいいのでは?

835 :login:Penguin:03/10/01 16:57 ID:eJJ8sUyh
apt-shellってapt-rpmのものだったのか〜
見た感じ便利そう。
パッケージ名のtab補完とか、version比較とか。
apt-cache searchでもいいけど、wild cardが使いにくかったり、--names-onlyとかオプションが長すぎ(w


836 :login:Penguin:03/10/01 17:20 ID:oP771qeT
kernel-patch-xfs - XFS Filesystem support for Linux 2.4.21 and 2.4.22
アップされますたー。

837 :login:Penguin:03/10/01 17:20 ID:ibtjHjMW
>>835
"--names-only" = "-n"だろ。

838 :login:Penguin:03/10/01 17:56 ID:Ox8rJeko
>>834
いや、その意味で使うものなのよ
deborphan finds packages that have no packages depending on them.

インストールされてるライブラリでもはや必要のないものを教えてくれる

839 :login:Penguin:03/10/01 17:58 ID:7EJNMh4C
>>838
ライブラリに限らず使いもしない糞パケジが増えるという話では。
俺は時々リストとって手動で掃除してるが。ウプグレード遅くなるし。

840 :login:Penguin:03/10/01 17:59 ID:OtB8zaps
使ってないアプリは教えてくれない、ってことをいいたかったのかも。

841 :login:Penguin:03/10/01 18:00 ID:OtB8zaps
タイミング ハズシタ.スマソ

842 :login:Penguin:03/10/01 18:05 ID:ibtjHjMW
>>839
deborphanはライブラリ以外も表示できるぞ。

843 :login:Penguin:03/10/01 18:08 ID:Ox8rJeko
ああ知ってる、でも
The default operation is to search only within the libs and oldlibs
sections, to hunt down unused libraries.
だからライブラリって書いておいた。

普段は --guess-allとか -aにしてるよ


844 :799:03/10/01 18:23 ID:d5MRxaNU
>>833
ありがとうございます。その方向で調べてやってみます。

ついでにもう一つ。もう一台あって、そっちは、Xの
ドライバーをrpmから借りてきてるので、できれば
X関係をホールドしたいのですが・・・具体的には
「どれ」をホールドしておけば良いでしょうか?


845 :login:Penguin:03/10/01 18:30 ID:7x8olw0o
>>844
借りてきたファイルを含むパッケージ、じゃないの?

846 :799:03/10/01 19:27 ID:d5MRxaNU
>>845
うーん、言われてみれば、その通り。
・・・だけど、X関係って、パッケージがいっぱいあるから、
かなり迷いそうな予感。まずは自分で探してみます。


847 :login:Penguin:03/10/01 20:40 ID:rLV3mFAx
migemo がインストールできないのって折れのところだけ?
sid だからしょうがないと言えばそうだが。

# apt-get install migemo
パッケージリストを読みこんでいます... 完了
依存関係ツリーを作成しています... 完了
インストールすることができないパッケージがありました。おそらく、ありえ
ない状況を要求したか、必要なパッケージがまだ作成されていなかったり
Incoming から移動されていない、不安定版ディストリビューションを使用し
ているものと考えられます。"

単純な操作を行っただけなので、このパッケージは単にインストールできない
可能性が高いです。そのため、このパッケージへのバグレポートを送ってくだ
さい。
以下の情報がこの問題を解決するために役立つかもしれません:

以下のパッケージには満たせない依存関係があります:
migemo: 依存: libromkan-ruby1.8 しかし、インストールすることができません
E: 壊れたパッケージ


848 :login:Penguin:03/10/01 20:52 ID:IPXg65QY
なんでBTSを覗かないんだろうか。

849 :login:Penguin:03/10/01 22:17 ID:FrlRy7hM
>>847
reportbug 入れて querybts migemo とでもすりゃいいのに

850 :login:Penguin:03/10/01 22:21 ID:ykeV9Hvf
popularity-contest の OLD フラグを見るとか

851 :login:Penguin:03/10/02 02:00 ID:ivqpkUol
sidで、しばらく前からdpkgが日本語表示しなくなったんですが、うちだけでしょうか?

straceで見ると/usr/share/locale見に行ってないようなんですが。


852 :login:Penguin:03/10/02 04:00 ID:PE10Ybpz
久々にsargeでupgradeしたら祭り2,3回分くらいupgradeされた。
何事だ?

853 :login:Penguin:03/10/02 04:10 ID:w2SS/XrF
libc6でも上がったんじゃねーの?sarge使ってないから知らんけども。

854 :login:Penguin:03/10/02 04:31 ID:chqAE7Py
>>852
libc6が上がったよ。
ついでにapt-getのメッセージも日本語化された。


855 :login:Penguin:03/10/02 11:27 ID:dcYYo6qH
DebianのTシャツとかを海外の通販じゃなくて
国内で買えるところがあったら教えてください


856 :login:Penguin:03/10/02 11:54 ID:+drlqPEc
>>855
海外から買うのはイヤなの?
10日位で届くよ?


857 :login:Penguin:03/10/02 18:16 ID:WDP0uX0F
debパッケージ内の設定ファイルのリスト表示させるのってどうやるんだっけ?

858 :login:Penguin:03/10/02 19:26 ID:+/B16+Of
>>857
これか?
dlocate -conf

859 :login:Penguin:03/10/02 19:36 ID:ZjM4exOJ
Tシャツどこのサイトにありますか?

860 :やっぱりLinuxかなって思って:03/10/02 19:42 ID:LqJ1YiH6
FreeBSDからDebianに乗り換えようと思ってるんですが
stableは少し古いような気がするし、次のstableまで1年くらいかかるようなので
testを使おうと思っています。
このtestっていうのは、実験中(不安定)という意味でなく、単に次期stableっていう意味なんですよね。
セキュリティ勧告が出れば、アップデートしていれば、普通に使えるんですよね。

あと、Debianではパッケージにもstableとか、testがあるようなのですが
それを混ぜても使えるんでしょうか?
たとえば、システムはtestを使って、Apacheはstableを使って、Rubyはtestを使って、、
依存関係が無茶苦茶にならないでしょうか?
なるなら、皆さんはどういう風にされてるのでしょうか?


861 :login:Penguin:03/10/02 19:54 ID:3Y1RKWi8
質問: テスト版 (testing) と不安定版 (unstable) のセキュリティはどうなっているのでしょうか?

A: 端的に言うと、これらにはセキュリティ上のサポートはありません。
テスト版 (testing) と不安定版 (unstable) は頻繁に変化するものなので、
セキュリティチームは適切なサポートをするのに必要なリソースを持っていません。
安全な (そして安定した) サーバを構築したい場合には、
安定版 (stable) を使い続けるよう強くおすすめします。
但し、セキュリティチーム書記は安定版 (stable) の修正後、
テスト版 (testing) と不安定版 (unstable) でも問題が修正されるよう努めています。

http://www.debian.org/security/faq#testing

862 :login:Penguin:03/10/02 20:15 ID:bmRsxj5U
>>860
大概下位のバージョンパッケージとの
依存性は大丈夫だったりする。

んで依存関係に問題あってインスコできない場合は、
お手軽rebuildで大抵OK。

どうしても依存関係が解消できないときは/usr/localにインスコしてる。

つーかtestingつかうなら、
stableつかって新しいパッケージが欲しいのを
testing,unstableからひっぱってくるか、
いっそこのとunstable使うことをお勧めする。

863 :login:Penguin:03/10/02 20:50 ID:IAztfxn6
unstableは本家がセキュリティ更新すれば、かなり早くupdateされるけど、
testingはどうなんだろうね?


864 :login:Penguin:03/10/02 20:55 ID:fqlBTH9J
規定の時間がくるまで放置。他のパッケージに引っ張られて余計に時間がかかる場合もあり。

昔glibc2.3がtestingに入らなかったせいでapacheが1.3.26のまま放置されてたこともあったし。

865 :860:03/10/02 21:19 ID:jmxVrEW9
testingってunstableの、特定の瞬間のものなんですか?
FreeBSDのstableとcurrentとはちがうんですね。

866 :あぼーん:あぼーん
あぼーん

867 :login:Penguin:03/10/02 21:40 ID:LU78Tp+T
>>865
>>1にあるhttp://debian.fam.cx/も読んでみれ

868 :login:Penguin:03/10/02 22:05 ID:v/GsZGq8
nForce2 ultraでdebian動かしてる人いますか?
とりあえず、woody入れてみたけど、
当然、ネットにつながるわけもなく、
今、jigdoしてまとめてsarge入れようと
してます。それでカーネル2.6にしようかと
思ってます。たぶん、それでうまくいくと思う。

nVidiaのサイトのドライバは、カーネルのバージョンを
どうあわせればいいのかわからなくて、やめた。
rpmばかりだし。

869 :860:03/10/02 22:22 ID:kYPXAIH4
>>867
Thank you !

必死でググって調べたことも、全部書いてました(^^;)


870 :login:Penguin:03/10/03 00:38 ID:4ksm/ra5
>>868
Ultraじゃないけどnforce2で動かしてます(マザボはepoxのEP-8RDA)
最初はDMAが有効じゃなかったり音ならないのでカーネル再構築必須。
kernel-2.4.21以降(?)だとちゃんとATA100になるので結構快適ー。

参考になるサイトを貼っときます。
ttp://home.t-online.de/home/Johannes.Deisenhofer/nforce2linux.html

871 :login:Penguin:03/10/03 08:45 ID:czvHfscT
apt-moveってなんだ?変なコマンドだなぁ

872 :login:Penguin:03/10/03 14:41 ID:t0DZe+Wb
Kernel v2.4.22 Configuration
です
Multimedia devices ---> <*> Video For Linux
Video For Linux ---> <*> BT848 Video For Linux (NEW)
で辿れるはずなのですが、競合してるのかどうかわかりませんが見えなくなりました。

どのオプションをかえるといいでしょうか?

873 :login:Penguin:03/10/03 14:49 ID:t0DZe+Wb
>>872
解決
出ました。うまくセーブ出来てなかった様子です。
でも変。


874 :login:Penguin:03/10/03 16:22 ID:OuSbZD17
>>862
> つーかtestingつかうなら、
> stableつかって新しいパッケージが欲しいのを
> testing,unstableからひっぱってくるか、
> いっそこのとunstable使うことをお勧めする。

素麺流しみたいなもんで
上流で地雷が除去されたあとで
下流に編入される、
が、stableに到着する頃には
鮮度が落ちて、おいしくなくなってる。

漏れはtestingつかって、
新しいパッケージが欲しいのをunstableからひっぱってきて
古いパッケージが欲しいのをstableからひっぱってきていた

が、きのうSidにした。

875 :login:Penguin:03/10/03 18:01 ID:hlKWCyOG
まあ、sidも昔ほどの地雷感はなくなったからなあ。
壊れたglibcを入れてしまった時はどうしようかと思ったよw

876 :868:03/10/03 18:46 ID:bcI9r4yp
>>870
とりあえず、woodyのままで、カーネルだけ2.4.22にしました。
jigdoは化石になるくらい時間がかかってしまうので。

nforceの設定項目は忘れずにチェックいれ、構築しました。
これで、nforceに最適化したものと思うので、

ここのnicとsound用のドライバをmake installしました。
http://www.nvidia.com/object/linux_nforce_1.0-0261.html

modprobe nfnet; modprobe nfaudio

で、見事インストール成功しましたよ!
今は早速apt-get dist-upgradeしてます。

今度は2.6.0-test4に挑戦するつもりです。
nforce2 ultraってオンボードビデオじゃないんですね。
ビデオカード買うはめになってしまった。あと、
最後の32bitAthlonチップセットとしてはなにか切ないものがある。

877 :login:Penguin:03/10/03 19:36 ID:mD4m0ZoD
debian使い始めてから、つねにsidをdist-upgradeし続けてるけど、
幸か不幸か大きくハマったことはないな・・・
ちょっとツマンネ(w


878 :870:03/10/03 22:59 ID:n2/KK1yU
>>868
おめ。
dmesgで、ATA100なんたらとか出てたら幸せです。

USB2.0に対応してるので2.6入れてみるかなあ・・・
2.0対応のCD-ROMとかフラッシュメモリとか試したいし。


879 :login:Penguin:03/10/03 23:34 ID:OuSbZD17
http:// dri.sourceforge.net/snapshots/README.Debian
に書いてあったapt-lineから佛をひっぱってきたら、
i810でglxgearsが倍になりました。既出デスカ?
-------
Debian packages (currently for powerpc, i386 and alpha) based on CVS snapshots
are available via

deb http://people.debian.org/~daenzer/dri-trunk/ ./
(for stable) and

deb http://people.debian.org/~daenzer/dri-trunk-sid/ ./
(for testing and sid)
-----

ii xlibmesa-gl1-dri-trunk 2003.08.07-1 Mesa 3D graphics library [DRI trunk]
ii xserver-xfree86-dri-trunk 2003.08.07-1 The XFree86 X server [DRI trunk]

880 :login:Penguin:03/10/04 00:00 ID:82Sybk73
>>875
新stableリリース前は、sidも変化が鈍るからだよ。
woodyが出るまでの1年くらいも、sidは馬鹿みたいに安定してた。

俺はFreeBSDも好きでけっこう使ってるが、FreeBSDのports的なものは求めな
い方がいいだろうな。
Debian stableはすべて正常にインストールできて正常にrebuildできる状態が
維持され、バージョンもセキュリティ上不可避な理由が無い限り上げられない。
対してFreeBSD portsはstableのcurrentの区別すらない。makeはよくコケる。
そんかし新しいものがstable releaseでも使える。

一言で言うなら、Debian stableはパッケージもOSの一部として管理されてい
るが、FreeBSD portsはユーザーが好き勝手に入れるもの。
頭切替えんとな。


881 :login:Penguin:03/10/04 01:06 ID:dcbmQzlH
>>880
そんなあなたに Gentoo Linux

882 :login:Penguin:03/10/04 01:30 ID:/cRIIFPl
>>881 そうだろうね。*BSD likeに使いたいんならgentooになるんだろうね。Debianは各パッケージも全てDebianの一部なのが、長所でもあり、短所でもある。

883 :login:Penguin:03/10/04 02:20 ID:UqV1HFcY
sid でこんなん出るんですが、どしてかわかりますか?

# apt-move localupdate

Updating from local Packages files...

Moving files...
Error closing sort > /tmp/MOVE_PBNvMh/movefiles/deb/mozilla-snapshot_mozilla-snapshot_content_1
Unknown error: domove: 1.
#

884 :login:Penguin:03/10/04 02:33 ID:/cRIIFPl
>>883 apt-moveのmovefile()の中のsortでエラーになってるみたいだけど...
手元の4.2.18じゃ特に問題が出てなかったり


885 :login:Penguin:03/10/04 03:01 ID:CUSb3ryD
サーバーはstable、クライアントはsidにしている。


886 :login:Penguin:03/10/04 03:54 ID:HqOUohxJ
根性ないのでtestingです。それでも動かなく
なった時は結構時間食ってしまいますが、
sid使う兵はupgrade失敗時の格闘にどれくらい
費やしているのでしょうか?


887 :login:Penguin:03/10/04 07:16 ID:SbN44m/y
xconfigやmenuconfigと入力してもコマンドノットファウンドとでます、
標準で使えるコマンドじゃないのでしょうか?

888 :login:Penguin:03/10/04 07:45 ID:9zxDwybH
>>887

ttp://debian.fam.cx/?Tips#content_1_3

889 :login:Penguin:03/10/04 09:43 ID:OPtv0NgO
sidの回復の時間は僅か。
ただし、aptが動かなくなったりするので、スキルがいる。

890 :login:Penguin:03/10/04 09:46 ID:hNtSpK08
スキルがないなら、再インストールする覚悟があればよい。

891 :login:Penguin:03/10/04 10:17 ID:nBClkLnr
http://www.debian.org/security/
このへんとかみてると、stable,unstableについては言及されてるけど、
testingについてはなにもないね。
testingはあとまわしになるのかな

892 :login:Penguin:03/10/04 10:50 ID:f12g+590
積極的にbug取りに参加すること以外、testing使う意味があんまりないな。


893 :login:Penguin:03/10/04 12:01 ID:A5GU9w9K
>>881-882
Gentooは「glibcも全てPortageの支配下」なんで、これまた*BSDとは違うよ。
GNU/Linuxで、「本体」と「追加パッケージ群」が別々になっているのってなんだろ。


894 :login:Penguin:03/10/04 12:32 ID:f12g+590
>>893
そのばやいは、GNU/linuxとは言わん罠。

895 :login:Penguin:03/10/04 13:44 ID:z4njib5F
Athlon64用のdebianインストーラある?

896 :login:Penguin:03/10/04 14:01 ID:4fni2jR0
sargeのインストール方法を解説したサイトってないですか?

897 :login:Penguin:03/10/04 14:16 ID:LuaMUgMK
>>896
ttp://debian.fam.cx/?AptGet

sarge (testing) 用 /etc/apt/sources.list
ってあります
apt-get update
apt-get dist-upgrade
で終り。

898 :login:Penguin:03/10/04 14:22 ID:4fni2jR0
>>897
アップグレードでなくて、初めからがよいのですが。。。。。
ナビックとかORCAのようなサイト。。。。

899 :login:Penguin:03/10/04 14:35 ID:LuaMUgMK
ttp://debian.fam.cx/
に「便利なサイト集」ってありますがもっと他にも欲しいの?

900 :login:Penguin:03/10/04 14:51 ID:4fni2jR0
sargeをインストーラー使ってインストールしてる人いないかなと。
さっきネットワークインストールしようとしたけど、よくわからんかった。

便利サイト集ってwoody関連だと思ってましたが。。。

901 :login:Penguin:03/10/04 15:00 ID:LuaMUgMK
woodyをtaskselとか使わない(最小?)でインストした後
/etc/apt/sources.listを書き換えて
apt-get update と apt-get dist-upgrade で
終りですよ。

#的はずれなのかなあ、、、

902 :login:Penguin:03/10/04 15:10 ID:xoQQQpi0
sargeを入れたいときは、まずwoodyを入れてそれをdist-upgradeするのが基本です。

903 :login:Penguin:03/10/04 15:10 ID:f12g+590
sargeの新インストーラが試したいのかな?
旧式のを使うなら、sargeでもwoodyとやりかたは一緒だろ。


904 :login:Penguin:03/10/04 15:10 ID:kJTkoyyw
>4fni2jR0
おまいには無理。
素直にwoody入れてsargeにupgrade汁。

905 :login:Penguin:03/10/04 15:11 ID:Sx83D9sa
>>896
sarge用のisoイメージ落としてきてそれを使えばいいんでないの?


906 :login:Penguin:03/10/04 16:14 ID:4fni2jR0
>>902
ですよね。

ちょっとsarge用のiso落としてインストールしてみた。
うまくいかなかったけど。
もうすこし挑戦。

NIC(intel pro100)が認識してくれなくて、aptできない。
だから新しいカーネルのsargeならいけると思ってみたんですけど。。。。

907 :login:Penguin:03/10/04 16:19 ID:Sx83D9sa
>>906
自動認識はしないから手動で選択する必要があるけど?


908 :login:Penguin:03/10/04 19:00 ID:mf8lx0im
"Jigdo"とゆーのを初めてつかってみた。
tp://home.in.tum.de/~atterer/jigdo/
* Windows用あり

Sargeの場合:
$ wget tp://ftp.fsn.hu/pub/CDROM-Images/debian-unofficial/sarge/jigdo/sarge-i386-1.jigdo
$ wget tp://ftp.fsn.hu/pub/CDROM-Images/debian-unofficial/sarge/jigdo/sarge-i386-1.template

# apt-get install jigdo-file
$ jigdo-lite sarge-i386-1.jigdo

古いバージョンのCDがあればそれをマウントしたディレクトリを指定すると、差分だけダウソする。
URLは適当にそこらへんのミラーを指定。

909 :login:Penguin:03/10/04 19:01 ID:mf8lx0im
これをつかって、SidのisoのダウソをTryしてみた。
[結果]
.......
.......
Successfully created `debian-20030921-i386-binary-1.iso'

-----------------------------------------------------------------
Finished!
The fact that you got this far is a strong indication that `debian-20030921-i386-binary-1.iso'
was generated correctly. I will perform an additional, final check,
which you can interrupt safely with Ctrl-C if you do not want to wait.

OK: Checksums match, image is good!
$ ls
debian-20030921-i386-binary-1.iso jigdo-file-cache.db sid-i386-1.jigdo sid-i386-1.template

910 :login:Penguin:03/10/04 19:59 ID:dcbmQzlH
>>893-894
Gentoo は全部パッケージ管理下だけど、ベースシステムは
system という特別な名前がついて管理されているので、
これは *BSD 的。(*BSD ならこの部分を make world なり
で作るが、Gentoo だと emerge system がこれ相当)

というか続きは Gentoo スレで…

911 :login:Penguin:03/10/04 20:35 ID:mf8lx0im
さっきapt-get updateしたら
libbonobo-activation-devでエラーになって

/var/cache/apt/archives/ 以下を見ると
"libbonobo-activation-dev%20libeel2-dev_1%3a2.2.4-1_i386.deb"
という超合金合体パッケージがあるようなのですが

Sidというのはよく、こういう愉快なことになるのでしょうか?

# dpkg -f /var/cache/apt/archives/libbonobo-activation-dev%20libeel2-dev_1%3a2.2.4-1_i386.deb package
libbonobo-activation-dev

# apt-get -f upgrade
dpkg: error processing libbonobo-activation-dev libeel2-dev (--configure):
no package named `libbonobo-activation-dev libeel2-dev' is installed,
cannot configure

912 :login:Penguin:03/10/04 20:51 ID:/cRIIFPl
>>911 む、珍しい。記念に取って置くといいかも(わら


913 :???:03/10/04 21:08 ID:6nBOeY91
 DebianにMplayerをインストールする方法が、書かれているHPを教えていただけないでしょうか。(日本語の説明で。)

914 :login:Penguin:03/10/04 21:14 ID:mf8lx0im
>>912
ミラー替えたらなおりました。
寝ます。

915 :login:Penguin:03/10/04 22:14 ID:MkzjgdMn
>>913
http://debian.fam.cx/?AptGetSpecific#content_1_39

916 :login:Penguim:03/10/04 22:16 ID:JFusoCO2
スレちがいだったらスマソ。
マ板のSourceForgeスレに出てくる、やなPとは
やなP=yochiでFA?

917 :868:03/10/04 22:56 ID:hfsj6K3m
>913
正直、mplayerはソースからコンパイルしたほうがいいよ。

>878
こっちはudma100ってでてますた。dmaもataも同じ意味らしいですね。
調べてわかった。

918 :login:Penguin:03/10/04 23:35 ID:kakuCk2M
Libretto L5にwoodyをinstallしようとしています.

pxeを使ってbootして,drivers.tgzのdownload,展開まではできたんですが,
「デバイスドライバモジュールの設定」のところで,

/target/lib/modules/2.4.18-bf2.4には設定可能なモジュールが見つかりませ
んでした."デバイスドライバの設定"を実行して,最初にモジュールを
インストーッしてください.

と言われて先に進めません.

主よ,お導きを.



919 :login:Penguin:03/10/04 23:39 ID:UeM4LTmP
インストーッ!

920 :login:Penguin:03/10/04 23:54 ID:hNtSpK08
>>918
ほんとにないのかシェルに降りてのぞいてみるとか。
ほっといて次に進めるなら、進めてみる。
で、何のモジュール組み込むつもり?

921 :login:Penguin:03/10/05 00:07 ID:NXa/pXSp
>>919

本当にそう書いてあるんですもん.

>>920

別に何かモジュールを組み込みたい訳ではありません.
インストーラの「次へ」に従ってきただけです.

シェルに降りてみたところ,
/target/lib/modules/2.4.18-bf2.4
なんて存在しておらず,代わりに?
/target/lib/modules/2.2.20
というのがありました.

downloadしてきた tftpboot.imgかroot.binが間違っていたのかな.
それとも 2.4.18-bf2.4の drivers.tgzを探せばいいのかな.

とにかく参考になりました.おおきに.





922 :login:Penguin:03/10/05 00:23 ID:bHriJS+c
>>917
ごめん、UDMA100だった。
dmesg見たら

AMD_IDE: nVidia Corporation nForce2 IDE (rev a2) UDMA100 controller on pci00:09.0

ってなってた。

923 :login:Penguin:03/10/05 00:44 ID:LZ9lgL5/
>>921
bf2.4のtftpboot.imgと同じところにあるdrivers.tgzを使うこと。


924 :login:Penguin:03/10/05 00:54 ID:5yXl/ywB
>>913

英語だけど、コマンド中心だからいけるだろ

http://lwn.net/Articles/49967/

の一番上。

925 :924:03/10/05 00:56 ID:5yXl/ywB
てゆーか短いので訳してみる

deb http://marillat.free.fr stable main
を/etc/apt/sources.listに追加

$ apt-get update
$ apt-get install mplayer


926 :login:Penguin:03/10/05 01:43 ID:+wBzuzkD
Linuxを大して使い込めてるわけではないですが
Vine2.6→Turbo8w→RedHat8→RedHat9とLinuxを使ってきて
現在マサにLinuxって感じのDebianに興味が沸いてます。
乗り換えるに当たって何か心構えとか有るでしょうか?
あるいは注意事項とか有りますか?
何かコメント頂けると嬉しいです。

927 :login:Penguin:03/10/05 01:46 ID:pwNv6Sgo
転んでも泣かない

928 :login:Penguin:03/10/05 01:47 ID:x/jr2ZuV
rpm どっぷりな環境から移ると、rpm に帰りたくなることかも。
そんなぼくは rpm こさえてから alien して dpkg しているヘタレです。

929 :login:Penguin:03/10/05 01:59 ID:5rqL1/Xx
まず自分で試してみる。
なんでも人に聞こうとしない。

930 :login:Penguin:03/10/05 02:00 ID:x/jr2ZuV
>>929
つまらん。

931 :login:Penguin:03/10/05 02:22 ID:kTyiYqgF
>>928
そこまでしてrpmにこだわる理由ってなに?
なんかいいことでもあるん?


932 :login:Penguin:03/10/05 02:26 ID:x/jr2ZuV
>>931
deb を作るためのシステムが、いろいろと気に入らないので。

933 :login:Penguin:03/10/05 02:38 ID:1lE6iU6k
ならRedHat使っとけ


934 :login:Penguin:03/10/05 02:43 ID:Km/bM4le
まぁ慣れてるもの使った方が精神衛生上良いのでは。
debのパッケージ数が多いといったって、存在するあらゆる
プログラムのdebがある訳でもないし。
別に/usr/localにぶちこもうがrpmそのままでぶちこもうが
portage移植してぶちこもうが、本人が分かってやっていれば
問題ないと思われ。


935 :login:Penguin:03/10/05 02:49 ID:kTyiYqgF
すまん、よみまちがえてた、
既にdebがあるパッケージをrpmになおして入れてるんじゃなくて
自分でパッケージを作るときにrpmで作ってからdebにしてるってことか、
まぁ、自分の作りやすい方でいいんでないか?


936 :login:Penguin:03/10/05 07:39 ID:a1GaMYhi
stableで、一部だけsidのパッケージを使いたいときにはどうしたらいいですか、
ftpサイトまわってみたけど、どこにあるのかわからず・・・。


937 :login:Penguin:03/10/05 09:16 ID:Km/bM4le
>>936 ttp://debian.fam.cx/?AptGet#content_1_24


938 :login:Penguin:03/10/05 09:44 ID:SHjxrXmu
>>900
http://gluck.debian.org/cdimage/testing/netinst/i386/

ちゃんとインストールできるのかどうかはわからんが。

939 :login:Penguin:03/10/05 11:01 ID:a1GaMYhi
>>937
ありがとうございます。たすかりました

940 :login:Penguin:03/10/05 11:15 ID:fWqtozl/
woodyのインストーラってたまに失敗する・・・
taskselを立ち上げずにNOを選ぶと、基本パッケージのダウンロード(eximやsshなど)まですっ飛ばしてくれる、
ことがある。


941 :login:Penguin:03/10/05 12:37 ID:qYgv05j7
>>940
それはsecurity.debian.orgからのアップデートが飛ばされる、ということ?
蛇足だがsshは基本パッケージではないよ。


942 :login:Penguin:03/10/05 12:46 ID:RWuBROts
>>794
自己リプライです.
mozilla 関連全部 purge して netscape7.1 を入れたら, flush ページを見て
も落ちなくなりました. netscape はレスポンスも早いし快適です.


943 :login:Penguin:03/10/05 13:16 ID:fWqtozl/
いわゆるbaseのパッケージ(basedebs.tar)じゃなくて、
taskselでなにも選択しなくても、そのあとに自動的に入るやつのことなんだけどね。
インストーラに普通に答えてると、gccやsshとかeximがDLされてインストールされるんだけど、
失敗したときはそれらがない状態で終わってしまう。
最初の時は自分で入れりゃいいか、って思ってたけど、
パッケージ名が分からんから結局最初からやり直す方が早いんだよね。

sarge以降はjigdo使ってイメージを作成するわけだから、vfatやext2などからインストールできるようになるんだろうなぁ。


944 :login:Penguin:03/10/05 14:26 ID:03KInqas
Sidのgimp1.3、フライングか?

gimp1.3 is uninstallable
Date: Sat, 4 Oct 2003 23:18:02 UTC

gimp1.3 version 1.3.20-2 depends on versions newer than
those present in unstable, and hence is uninstallable.
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=214140

945 :login:Penguin:03/10/05 14:52 ID:qloCv13v
2.4.22
make menuconfig
で、
tuner を探してます。
どのセクションでしょうか?

#恥かしい

946 :941:03/10/05 15:04 ID:pO3FMkoL
>>943
>taskselでなにも選択しなくても、そのあとに自動的に入るやつ
? 俺は一度もそんな経験ないけど。


947 :login:Penguin:03/10/05 15:06 ID:kCTEKTT0
>>943
dselect ならPriority 毎に項目が分かれてるぞ

apt-cache あたりでも、Standard packages だけ抽出するとか
できそうだが、オレはしらん


948 :login:Penguin:03/10/05 15:15 ID:M0qv81Tv
>>943
woodyでeximはダウンロードしなくても勝手にインスコされるが。
gccとかsshはインスコされないけど。

949 :login:Penguin:03/10/05 18:59 ID:UclRUpnZ
洩れは、taskselをとばして起動しない場合とtaskselを起動してなにも選ばずに
taskselを終了した場合とでは、入るパッケージに差が出た記憶があった・・
ような気がする。

950 :わむて ◆wamuteW7DE :03/10/05 19:35 ID:xT5Oas42
   ___
  <_葱看>
/ i レノノ))) \
 (人il.゚ ヮ゚ノ人    みる、みる
   ヽ Yi/
   く_ :|〉
    し'ノ

   ___
  <_葱看>、
/ (ハ((iヽl, i \
  人゚ヮ ゚∠イ)     みるまらー
   ヽiY /
    〈|: _>
    .ヽ∪

951 :???:03/10/05 19:42 ID:hCsOprGp
 御返事ありがとうございます。その後、以下のようになりました。
mplayerのk7なのか686なのか386なのか選択を迫られました。
適当に686をインストールしようとしましたら、インストールされていなかったり、バージョンが古いモジュールがインストールされていますといった、警告がでます。
たとえば、
mplayer-686:Depends: libasound2 (>0.9.3)but 0.9.0beta10a-3 is to be installed
です。よろしくお願いいたします。

952 :login:Penguin:03/10/05 19:44 ID:YjEwOd/p
exim嫌いな人!あつまれ!

953 :login:Penguin:03/10/05 20:01 ID:bDq4vW97
>>952
嫌いならほかのやつapt-getすりゃすむ話ではw


954 :???:03/10/05 20:31 ID:hCsOprGp
 debianにRealPlayerをインストールすることになってしまいました。
しかし、RPで、MPEGファイルを開くことが出来ません。
エラーコード2147745815Xを表示しています。
この先どうなってしまうのでしょう。


955 :login:Penguin:03/10/05 20:36 ID:THWAl18j
>>954

> エラーコード2147745815Xを表示しています。
> この先どうなってしまうのでしょう。

あなたの努力次第ですw
いや,マジで.
情報少なすぎ.


956 :login:Penguin:03/10/05 23:05 ID:ve2/BYrF
>>945
/lib/modules/2.4.22/kernel/drivers/media/video/tuner.o
でした。

957 :login:Penguin:03/10/05 23:27 ID:A5+nSggS
素朴な質問だけどDebian GNU/*BSD使ってる人いる?

958 :login:Penguin:03/10/05 23:30 ID:k6vcrbxH

nataulisで表示するビューアがないとアラートがでました。
何をインストールすべきですか?


959 :login:Penguin:03/10/05 23:33 ID:4OzfTgQl
>>958
なんのビューワだよ。
↓以後はこっちでどうぞ。

くだらねえ質問はここに書き込め! Part59
http://pc.2ch.net/test/read.cgi/linux/1065052264/

960 :login:Penguin:03/10/05 23:35 ID:qloCv13v
>>956
ども、です
>>tuner を探してます。
/usr/src/kernel-source-2.4.22/drivers/media/video/tuner.c
は、あります。
modules じゃなくて組み込みたくて探してました
どこかのオプションを有効にすれば出てくる思ったのですがわかりませんでした
xawtv で tvを見たくてやってます。

961 :login:Penguin:03/10/06 00:00 ID:1jgCMFm/
>>960
BT848 をいれるとついて来る。(というのがMakefileを見ればわかると思うよ)

962 :login:Penguin:03/10/06 00:10 ID:A1QQKWbw
Debianを新しくインストールしてkernel2.6を入れたいんですが、
どういう手順が必要か教えていただけますか?

Debianは全く使ったことがないSlackユーザです。

963 :login:Penguin:03/10/06 00:11 ID:aOOdJimQ
>>962
>>1

964 :login:Penguin:03/10/06 00:20 ID:C7rC1m9A
>>961 BT848 をいれるとついて来る

ありがとございます
Makefileを読みきれなかったす。*見た*だけでした。

以前tvをでびあんで見てたのですが設定メモを残したなかったす。
今度は組み込んでしまえ、って思ったのが回り道かも。

りぷらいありがと。


965 :962:03/10/06 00:22 ID:A1QQKWbw
>>1を見ましたが、どこら辺にあるか見つかりませんでした。
mod-init-toolsなどのバージョンは気にしなくて大丈夫なんでしょうか。

966 :login:Penguin:03/10/06 00:29 ID:qSGVTlwZ
Documentation/Changes
の"Current Minimal Requirements"
の項目に書いてあるソフトウェアが入っていて
ちゃんと動く状態であればOK。

967 :login:Penguin:03/10/06 00:30 ID:aOOdJimQ
>>965
必要なもののバージョンはカーネルソース付属のドキュメントに書いてある。
読んだ事ないのか?

968 :962:03/10/06 00:34 ID:A1QQKWbw
>>966-967さん
たぶんWoodyではmodule-init-toolsなどのバージョンが
ドキュメントの条件に満たないと思います。
make installすればいいんですが、それだとパッケージ管理が崩れると思うので、
debian的にはそれをどう解決すれば良いのか知りたいんですが。。

969 :login:Penguin:03/10/06 00:36 ID:aOOdJimQ
>>968
だから>>1嫁っていってるだろ。
ttp://debian.fam.cx/?AptGet#content_1_24

970 :login:Penguin:03/10/06 00:37 ID:M88ZJH8W
>>962
モノには順序ってもんがあるだろ。
まず Debian 入れてある程度使い方覚えれ。

971 :login:Penguin:03/10/06 00:41 ID:sBjw0pI/
http://linux-life.net/program/cc/kde/app/kannadic/
↑コレつかうにはどうしたらいいでしょうか?
初心者ですがやさしく教えてください。。

972 :962:03/10/06 00:47 ID:A1QQKWbw
わかりました。とりあえず入れてみることにします。

973 :login:Penguin:03/10/06 00:48 ID:aOOdJimQ
>>971
ttp://debian.fam.cx/?Tips#content_1_21

974 :login:Penguin:03/10/06 01:03 ID:EMLhudTq
>>962
# apt-get install fakeroot kernel-package tk8.2-dev kernel-source-2.6.0-test4
$ tar jxvf /usr/src/kernel-source-2.6.0-test4.tar.bz2
$ cd kernel-source-2.6.0-test4
$ make xconfig
$ make-kpkg clean
$ fakeroot make-kpkg --revision hogehoge kernel_image
# dpkg -i ../kernel-image-2.6.0-test4_hogehohe_i386.deb
# reboot

975 :login:Penguin:03/10/06 01:13 ID:pYX/et9X
>>918
直接の回答ではないけれど同じの使ってるので関連で少し。

無線付きの方に Debian sid 入れてるけど、USB floppy 使った方が PXEboot より
も楽かもしれない。あと音ならすには IRQ を強制でわりあてる必要がある
(2.4.x, カーネルパッチ、2.6.x だと必要ない)。

976 :login:Penguin:03/10/06 01:13 ID:HjDqHZkY
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=211804
助けて(´-Å)…
せめて削除するときのプロセスがわかればいいんですけど…

977 :login:Penguin:03/10/06 01:20 ID:HjDqHZkY
あれ,治った
/var/cache/apt/archives/ にあったxfwm4関係のパッケージを
dpkg --unpack xfwm4_4.0.0+cvs.20030421-1_i386.deb
して,それから削除したら消えました
うーん?

978 :login:Penguin:03/10/06 01:41 ID:aOOdJimQ
次スレ立ては>>990踏んだ人でよろしいか?



979 :login:Penguin:03/10/06 01:50 ID:M88ZJH8W
>>980 でいいのでは。

980 :login:Penguin:03/10/06 02:08 ID:hwOVmVB6
(・∀・)

981 :login:Penguin:03/10/06 02:09 ID:hwOVmVB6
(・∀・)

982 :login:Penguin:03/10/06 02:10 ID:hwOVmVB6
(・∀・)

983 :login:Penguin:03/10/06 02:11 ID:hwOVmVB6
(・∀・)

984 :login:Penguin:03/10/06 02:12 ID:hwOVmVB6
(・∀・)

985 :login:Penguin:03/10/06 02:13 ID:hwOVmVB6
(・∀・)

986 :login:Penguin:03/10/06 02:14 ID:hwOVmVB6
(・∀・)

987 :login:Penguin:03/10/06 02:15 ID:hwOVmVB6
(・∀・)

988 :login:Penguin:03/10/06 02:26 ID:M88ZJH8W
次スレ

Debian GNU/Linux スレッド Ver. 19
http://pc.2ch.net/test/read.cgi/linux/1065374560/

989 :login:Penguin:03/10/06 03:09 ID:WDS5v6Pc
test

前スレ
Debian GNU/Linux スレッド Ver. 19
http://debian.fam.cx/pc.2ch.net/test/read.cgi/linux/1065374560/
http://pc.2ch.net/test/read.cgi/linux/1065374560/

過去ログ
00 http://cocoa.2ch.net/unix/kako/970/970632381.html
01 http://cocoa.2ch.net/linux/kako/980/980163775.html
02 http://cocoa.2ch.net/linux/kako/992/992323048.html
03 http://pc.2ch.net/linux/kako/999/999724231.html
04 http://pc.2ch.net/linux/kako/1006/10062/1006278960.html
05 http://pc.2ch.net/linux/kako/1011/10117/1011766081.html
06 http://pc.2ch.net/linux/kako/1015/10151/1015174417.html
07 http://pc.2ch.net/linux/kako/1018/10184/1018445203.html
08 http://pc.2ch.net/linux/kako/1020/10209/1020967965.html
09 http://pc.2ch.net/linux/kako/1024/10240/1024031354.html
10 http://pc.2ch.net/linux/kako/1027/10274/1027442221.html
11 http://pc.2ch.net/linux/kako/1030/10301/1030178687.html
12 http://pc.2ch.net/linux/kako/1033/10330/1033049225.html
13 http://pc.2ch.net/linux/kako/1036/10361/1036184754.html
14 http://debian.fam.cx/pc.2ch.net/test/read.cgi/linux/1040637707/
15 http://debian.fam.cx/pc.2ch.net/test/read.cgi/linux/1045176646/
16 http://debian.fam.cx/pc.2ch.net/test/read.cgi/linux/1051790435/
17 http://debian.fam.cx/pc.2ch.net/test/read.cgi/linux/1056885910/
18 http://debian.fam.cx/pc.2ch.net/test/read.cgi/linux/1061600500/

990 :login:Penguin:03/10/06 09:45 ID:vjE47wba
>>988
モツカレ〜

991 :login:Penguin:03/10/06 10:51 ID:FnxD1rUP
DWNの翻訳スピード早くなってる…。

sumikaとかpupaパッケージが本家に入ったみたいだね。

992 :次スレ案内:03/10/06 11:17 ID:+EmZWm0f
Debian GNU/Linux スレッド Ver. 19
http://pc.2ch.net/test/read.cgi/linux/1065374560/l50


993 :次スレ案内:03/10/06 11:17 ID:+EmZWm0f
Debian GNU/Linux スレッド Ver. 19
http://pc.2ch.net/test/read.cgi/linux/1065374560/l50


994 :次スレ案内:03/10/06 11:18 ID:+EmZWm0f
Debian GNU/Linux スレッド Ver. 19
http://pc.2ch.net/test/read.cgi/linux/1065374560/l50


995 :次スレ案内:03/10/06 11:18 ID:+EmZWm0f
Debian GNU/Linux スレッド Ver. 19
http://pc.2ch.net/test/read.cgi/linux/1065374560/l50


996 :次スレ案内:03/10/06 11:18 ID:+EmZWm0f
Debian GNU/Linux スレッド Ver. 19
http://pc.2ch.net/test/read.cgi/linux/1065374560/l50


997 :次スレ案内:03/10/06 11:19 ID:+EmZWm0f
Debian GNU/Linux スレッド Ver. 19
http://pc.2ch.net/test/read.cgi/linux/1065374560/l50


998 :次スレ案内:03/10/06 11:19 ID:+EmZWm0f
Debian GNU/Linux スレッド Ver. 19
http://pc.2ch.net/test/read.cgi/linux/1065374560/l50


999 :次スレ案内:03/10/06 11:19 ID:+EmZWm0f
Debian GNU/Linux スレッド Ver. 19
http://pc.2ch.net/test/read.cgi/linux/1065374560/l50


1000 :次スレ案内:03/10/06 11:20 ID:+EmZWm0f
Debian GNU/Linux スレッド Ver. 19
http://pc.2ch.net/test/read.cgi/linux/1065374560/l50


1001 :1001:Over 1000 Thread
このスレッドは1000を超えました。
もう書けないので、新しいスレッドを立ててくださいです。。。

263 KB
★スマホ版★ 掲示板に戻る 全部 前100 次100 最新50

read.cgi ver 05.04.00 2017/10/04 Walang Kapalit ★
FOX ★ DSO(Dynamic Shared Object)