5ちゃんねる ★スマホ版★ ■掲示板に戻る■ 全部 1- 最新50  

■ このスレッドは過去ログ倉庫に格納されています

Kernel 2.4にしました

1 :名無しさん@お腹いっぱい。:2001/01/21(日) 22:44
インストールにあたってどんな作業をしたかとか
どこにはまったとか
2.4そのものにつっこみたいひとは別のスレたててぷりーず

2 :>1:2001/01/21(日) 23:00
じゃ何に突っ込めというんじゃ?

3 :名無しさん@お腹いっぱい。:2001/01/22(月) 01:53
それでどうなの?
調子いいの?

4 :名無しさん@お腹いっぱい。:2001/01/22(月) 02:03
1じゃないが順調に動いているぞ。それなりに。
USBマウスとか意味も無く繋げてみている。

5 :名無しさん@お腹いっぱい。:2001/01/22(月) 02:25
>2
まんこに突っ込んでくれ

6 :名無しさん@お腹いっぱい。:2001/01/22(月) 04:51
コンパイラとか、他に注意することはあったか?

7 :名無しさん@お腹いっぱい。:2001/01/22(月) 05:49
え。みんなさくっとはいってるのか。鬱だ氏のう。
1はどうしたんだ?

8 :名無しさん@お腹いっぱい。:2001/01/22(月) 05:53
plamo2.1に入れた人いる?

9 :名無しさん@お腹いっぱい。:2001/01/22(月) 06:12
>>6
Debianだけど、コンパイラとかは全く気にしないでできた。
漏れはdevfsつかてるけど、他につかてるひといない?


10 :名無しさん@お腹いっぱい。:2001/01/22(月) 07:14
Kondara2000いれてJiraiにあげてkernel24でブート。
>漏れはdevfsつかてるけど、他につかてるひといない?
おれもつかてる。

11 :名無しさん@お腹いっぱい。:2001/01/22(月) 14:32
>8
ニ、、ソ. 、ェ、、ャナャナ、ヒサネ、テ、ニ、ネマーマ、ヌ、マフオフ萃


12 :11:2001/01/22(月) 14:39
sumanu, shippai shita.


13 :名無しさん@お腹いっぱい。:2001/01/22(月) 15:00
2.4にして2G超のファイル作ったらlsもrmもできんぞ。
仕方ないのでddで消しました。
全部コンパイルし直さないと駄目なのか?

14 :名無しさん@お腹いっぱい。:2001/01/22(月) 15:04
駄目だ

15 :名無しさん@お腹いっぱい。:2001/01/22(月) 16:09
そうか!

16 :名無しさん@お腹いっぱい。:2001/01/26(金) 07:31
マルチメディア方面に使えそうで、よろし。

そういう使いかたしている人、いますか?
(たとえば、DVD、テレビ、MP3、Divx;-)、FMラジオ、アマ無...)

17 :名無しさん@お腹いっぱい。:2001/01/26(金) 11:12
2G以上のファイルを扱えるようになるんだっけ。
じゃぁVMWareの仮想マシン用のハードディスクも大きく取れる?
#あれってVMWareが仕切ってたような気も…

18 :名無しさん@お腹いっぱい。:2001/01/28(日) 04:09
>>16
USBで俺のRio500にmp3転送できたよぉ。
感涙。

ちなみに、Intelの顕微鏡も使えるようになったらしいぞ。

19 :16:2001/01/30(火) 17:42
>>18
羨ましい・・。USBが使えたんだ。
俺のは何か動かなくてさ。インテルの方もそれじゃない方も起動時に動かないんだよね。
何か、設定で重要なところってあるのかな?
ちなみに、オレ、Vine2.1。

20 :名無しさん@お腹いっぱい。:2001/01/30(火) 19:18
2.4.1がでましたね。ただいまmake installちう。reiserfsはoffさ。

21 :16:2001/01/30(火) 20:14
とかなんとか言って、うまくいくようになった。

22 :名無し2.2.18:2001/01/30(火) 21:00
>>19
特別な設定は無いですよ。
http://www.powerbook.org/linux/usb.html
がお勧めだすよ。

でも、まだまだUSBカメラの性能フルには引き出せません。
メーカがドライバを作ってくれたら楽なのになぁ・・・

23 :19:2001/01/30(火) 23:36
>>22
どうも。USB、うまくいくようになりました。
OHなんとかと、UHなんとかの両方をモジュールにしたのがよかったみたいです。
今、2.4.1のパッチを当てて、コンパイルしながら2chです。

24 :名無しさん@お腹いっぱい。:2001/01/31(水) 15:42
CLIEとUSBでプレイしたいんだけど情報ある?


25 :名無しさん@お腹いっぱい。:2001/02/01(木) 17:52
2.4.0ac12と2.4.1ってどっちが安定してるの?


26 :名無しさん@お腹いっぱい。:2001/02/01(木) 17:58
2.5.1がブランチした後のものが安定

27 :名無しさん@お腹いっぱい。:2001/02/01(木) 19:50
2G以上のファイルを扱うにはglibcが2.1.3以降でないとだめよ

28 :名無しさん@お腹いっぱい。:2001/02/02(金) 05:32
しかも2G以上のファイルに対応したカーネルでコンパイルしたglibcね。

29 :名無しさん@お腹いっぱい。:2001/04/26(木) 01:31
age

30 :名無しさん@お腹いっぱい。:2001/04/29(日) 02:16
2.4.4が出たぞぉー
http://www.kernel.org/

31 :名無しさん@お腹いっぱい。:2001/05/01(火) 09:01
2.4.4にしたらSCSI使えなくなった

32 :名無しさん@お腹いっぱい。:2001/05/04(金) 00:34
2.4.4にしたらpcmciaが使えなくなった。

33 :名無しさん@お腹いっぱい。:2001/05/04(金) 00:36
2.4.4にしたら彼女ができた。

34 :名無しさん@お腹いっぱい。:2001/05/04(金) 02:05
2.4.4にしたら宝くじが当たった

35 :名無しさん@お腹いっぱい。:2001/05/04(金) 02:55
2.4.4にしたら、kernel が Mach な MK になっていた

36 :名無しさん@お腹いっぱい。:2001/05/06(日) 10:08
2.4.4にしたら不当たりだした。
きっと銀行のシステムが2.4.3だったからに違いない!

37 :名無しさん@お腹いっぱい。:2001/05/06(日) 11:30
よし、俺も2.4.4にするぞ

38 :名無しさん@お腹いっぱい。:2001/05/06(日) 19:19
別スレッドにも書いたけど 2.2.4 にしたところが PPxP が使えなくなった。
2.2.3 までは CVS で落とした snapshot で問題なく動作していたので、
目下調査中……なんだが未だによくわかんない。

39 :名無しさん@お腹いっぱい。:2001/05/06(日) 23:13
おれも
2.4.3に戻して様子見てます.


40 :名無しさん@お腹いっぱい。:2001/05/06(日) 23:46
ppxp使わなければ問題なし.


41 :名無しさん@お腹いっぱい。:2001/05/07(月) 12:34
XFS 1.0 release 下らしい。
誰か人柱きぼ〜ん
http://linux-xfs.sgi.com/projects/xfs/

42 :名無しさん@お腹いっぱい。:2001/05/11(金) 11:36
Alan Cox ブランチ ってなに?

43 :名無しさん@お腹いっぱい。:2001/05/11(金) 12:11
KernelメンテナのAlan Coxさんが安定性のために、ブランチを出した
ものじゃないの?kernel2.*.* AC1とか・・・

44 :名無しさん@お腹いっぱい。:2001/05/11(金) 18:56
2.4.xは未だに不安定要素が多いね
安定性取るなら2.2.19が一番良い。

45 :名無しさん@お腹いっぱい。:2001/05/11(金) 18:58
2.4.4 どうも network まわりがおかしい。fs まわりも
ReiserFS は使わないほうがいいし。
Debian の unstable だと 2.4.3 kernel に戻すことが
出来ない(2.2.19 に戻すことはできるけど) ので、しょう
がないからこのまま使うけど…。

46 :名無しさん@お腹いっぱい。:2001/05/11(金) 20:46
>>45
どんなふうにおかしのでしょうか。
詳細キボーン。


47 :名無しさん@お腹いっぱい。:2001/05/12(土) 01:18
2.4.4 で問題発生してる人って結構多い?
かくいう自分も pcmcia にエラー発生鬱。

48 :名無しさん@お腹いっぱい。:2001/05/12(土) 01:31
>>47
どんなの?
うちエラーないな。

49 :名無しさん@お腹いっぱい。:2001/05/12(土) 05:35
>>45
>2.4.4 どうも network まわりがおかしい。fs まわりも
>ReiserFS は使わないほうがいいし。
なんで?詳細キボーン。

>Debian の unstable だと 2.4.3 kernel に戻すことが
>出来ない(2.2.19 に戻すことはできるけど) ので、しょう
自分で 2.4.3 kernel コンパイルすればいいじゃん。-> make-kpkg


50 :名無しさん@お腹いっぱい。:2001/05/12(土) 05:47
2.4.4 にしたらppxp使えん

51 :名無しさん@お腹いっぱい。:2001/05/12(土) 06:02
>>50
そなの?詳細キボーン。(みんな詳細書こうよ。)


52 :50:2001/05/12(土) 06:05
詳細も何も無いけど


53 :51:2001/05/12(土) 06:07
>>52
ppxp が何かメッセージ出してたりしない?
あるいは /var/log/messages に何か出てたり。


54 :50:2001/05/12(土) 06:12
忘れちゃったよ。
ppxp ***で起動すると
ppxpプロンプトが出てこないし
ps にppxpdは残っているのに、
で結局2.4.3に戻した

55 :51:2001/05/12(土) 06:16
>>54
そんなんじゃ linux 使えないぞ。
message 見たり、strace かけたりして調べなきゃ。


56 :50:2001/05/12(土) 06:34
messageもppxpのログもチェックしたよ
動かない原因探るより、ppxp使えることのほうが
大事だから、2.4.3に戻した。
そのうち調べようとカーネルは残してあるけど
他に解決したいこともあるし放置してある状態

57 :名無しさん@お腹いっぱい。:2001/05/12(土) 06:50
だーかーらー
2.4.4-ac3以降で修正されてるってばー
最新版だけど「安定版」じゃないよー、2.4
雑誌とかでノセられていれるんだろーけどさー

2.4.4-ac8が出てるけどー

58 :名無しさん@お腹いっぱい。:2001/05/12(土) 07:13
>57
雑誌でも2.4が実用レベルの安定性って言ってるのはないぞ
それに実態はどうあれ「安定版」なのは事実
使う側の心がけとしては57に賛成するが
一応雑誌関係者(^^;なので,こういう発言は好かんな


59 :50:2001/05/12(土) 07:14
そうなの?
Debianのソースは2.4.4-ac3より前のって事か?

雑誌でノセられていれる、って言うより
再構築するとき、新しいのにしたくなっちゃう。

60 :名無しさん@お腹いっぱい。:2001/05/12(土) 09:08
>>54
ppxpを使わないといけない理由ってあるの?
pppdとwdialあたりを使っておけば、(世界的には)
ユーザも多いし、なにかあっても対応が早くていいよう
に思えるのだけど。

61 :54:2001/05/12(土) 09:50
うちのTA、ppxpじゃなきゃ繋げられない。
(WIN2kでも調子が悪い)
pppdは、上手く言ってるときはいいけど
一度失敗すると、2度と繋がらん。

62 :名無しさん@お腹いっぱい。:2001/05/12(土) 09:54
まさか、カーネルは再構築したけど、userlinkは再構築していないって事はないよね。

63 :54:2001/05/12(土) 11:20
ethertap 使ってる
2.4 ってuserlink使えるの?
ppxpのページに対応していないって書いてあった
と思うけど

64 :名無しさん@お腹いっぱい。:2001/05/12(土) 11:52
ethertap より tun


65 :名無しさん@お腹いっぱい。:2001/05/12(土) 18:28
RedHat7.1(カーネル2.4.2)にてalsaを使いたいと思うのですが、alsa-driver
からしてmakeの途中で止まってしまいます。
どなたかうまくいった方いませんか?

66 :名無しさん@お腹いっぱい。:2001/05/12(土) 18:40
>>65
どこで止まったかによるけど、おおかたヘッダがないとかそんなとこだと。
2.4用のalsa-driverを拾ってきてます?

67 :名無しさん@お腹いっぱい。:2001/05/12(土) 19:03
>>58
2.5.1がブランチされるまでは「現行版」でしかない
雑誌記者がそんな知識だから、クソ雑誌がはびこる

68 :67:2001/05/12(土) 19:04
雑誌記者とは言って無いな関係者としておこ

69 :名無しさん@お腹いっぱい。:2001/05/12(土) 19:39
雑誌についてたホロン入れようかと思うんですが
引き止める人とかいますか?

70 :名無しさん@お腹いっぱい。:2001/05/12(土) 19:59
死して屍、拾う者なし.

71 :50:2001/05/12(土) 20:10
>>59
>そうなの?
>Debianのソースは2.4.4-ac3より前のって事か?
-ac? てバージョンは含まれてないんじゃ?

それに、どうせコンパイルするんだし、
自分で make-kpkg つかって kernel 構築するといいよ。

ちなみに自分は pppd を使用。pon で起動してる。


72 :名無しさん@お腹いっぱい。:2001/05/12(土) 20:34

Linux評価

優良OS            普通            クソOS
 ┝━━━━━━━━━━┿━━━━━━━━━━┥

                         88彡ミ8。   /)
                        8ノ/ノ^^ヾ8。( i )))
                         |(| ∩ ∩|| / /   <ココ!
                        从ゝ__▽_.从 /
                         /||_、_|| /
                        / (___)
                       \(ミl_,_(
                         /.  _ \
                       /_ /  \ _.〉
                     / /   / /
                     (二/     (二)

73 :65:2001/05/12(土) 22:06
>>66
え!? すいません、2.4用のalsaって出てるんですか?
0.9ってやつのことですか? 0.5.10でやってました。

74 :名無しさん@お腹いっぱい。:2001/05/12(土) 23:03
>>65>>73
RedHat7.1のkernel2.4.2のヘッダがおかしいみたい。kernel2.4.3
ならalsa-driver-0.5.10bをうまくコンパイルできて、ちゃんと
動作しているよ。ちなみにalsa-driver-0.9.0beta3も2.4.2では
うまくコンパイルできていないっす。

75 :名無しさん@お腹いっぱい。:2001/05/12(土) 23:26
>>58
日経の末●さんなら許す

他の記者ライターは雑魚

76 :名無しさん@お腹いっぱい。:2001/05/13(日) 02:45
>>74
ありがとうございます。そうですか……

何度も何度もカーネル2.4.3を入れても古い2.4.2-2でしか立ち上がらなくて、
何故なんだと思っていたら、/etc/lilo.confを見てみたら、
vmlinuz-2.4.2-2が直接指名されてる!
/bootでは、ちゃんとvmlinuz→vmlinuz-2.2.xというリンクが張られているのに!
意味無いじゃないか! 何故なんだ、RedHat!

今日はもう寝よ。

77 :名無しさん@お腹いっぱい。:2001/05/13(日) 04:44
だからさぁ/sbin/installkernelを使えよぉ
あと/etc/init.d/rc.sysinitでも/bootのリンク弄ってるよぉ

78 :名無しさん@お腹いっぱい。:2001/05/13(日) 17:39
>>77
そういえばそんなコマンドがあるみたいですね。まだ初心者なので
分からないことだらけなのです。ありがとうございます

79 :名無しさん@お腹いっぱい。:2001/05/15(火) 19:51
Debian の 2.4.4 にしたら、なぜか www.canon.co.jp 等多数の
site に connection を張れなくなった…。これじゃ使いものにならない。

80 :anonymous coward:2001/05/15(火) 20:02
>>79

新しい規格でECNというのがあるんだけど、ルータとかOSが古いと、昔の規約で明示的に「予約」と書いてあるビットを勝手に使ってて、ECNを誤解してしまうのだ。そういう時はそのサイトに「新しい規約に違反してる」って教えてあげましょう。ルータとかのアップデートは無料であるんだから。

ちなみに、あまりにも腐ってるサイトが多いので、ECNはdefault で disableになったよ、当分は


81 :名無しさん@お腹いっぱい。:2001/05/15(火) 21:17
>>80
Thanks!
echo 0 >/proc/sys/net/ipv4/tcp_ecn
して ECN を切ったら OK になりました。これで安心して
2.4.4 を使える…。

82 :名無しさん@お腹いっぱい。:2001/05/16(水) 23:41
>>65
>>74
どうやら、version.h と modversions.hがひっかかるようです。
/usr/include/linux/version.h を使い、driver.c から
#include <modversions.h>
をコメントアウトしたらビルドはできました。
bugzilla.redhat.comを検索してみますかねぇ。
何か情報あるかも。。。

83 :名無しさん@お腹いっぱい。 :2001/05/16(水) 23:45
え。な〜んにも苦労なくインストールできてますが。

ベースはVine2.1で。

84 :82:2001/05/17(木) 00:05
driver.cじゃなくて、driver.hでした。。。

85 :名無しさん@お腹いっぱい。:2001/05/17(木) 03:18
kernelのppoe使ってる人います?
まあ1Mぐらいの速度ならユーザスペースでも変わらないのかな。

86 :名無しさん@お腹いっぱい。:2001/05/17(木) 10:23
DRIの機能がカーネルに入ってるんだけど、これとXFree86のDRIの機能の関係は
どうなっているんだろ。誰か教えて。

87 :82:2001/05/17(木) 10:42
RedHatLinux7.1で無事ALSAビルドできました。
kernel-sourceのrpmをインストールした後、
カーネルをビルドしてしまうと、"make mrproper"の
時点でversion.hがなくなってしまうためみたいです。

88 :名無しさん@お腹いっぱい。:2001/05/17(木) 17:54
>>86
カーネルに入ってるのはDRIのドライバで、その機能を
利用してゴニョゴニョやってるのがXFree86ってことじゃない?


89 :名無しさん@お腹いっぱい。:2001/05/19(土) 22:12
age

90 :名無しさん@お腹いっぱい。:2001/05/19(土) 23:03
MLよりこっちの方が読んでてためになるよage

つーかML寒いよ…

91 :名無しさん@お腹いっぱい。:2001/05/19(土) 23:13
やっとRedHat7.1でALSAが入った。
というか、全部再インストールした後、普通にやれば素直に入った。
カーネル2.4.3のソース拾って来て再構築とかしてるのがいけなかったようだ。
技量不足と言われればそれまでだが。ううう。

92 :U-名無しさん:2001/05/20(日) 02:20
>90さんは、ダラーズですか?

93 :名無しさん@お腹いっぱい。:2001/05/20(日) 06:59
http://www.digitalfactory.co.jp/



94 :名無しさん@お腹いっぱい。:2001/05/21(月) 00:34
age

95 :名無しさん@お腹いっぱい。:2001/05/21(月) 03:39
まだ2.4にしてないけど。age


96 :名無しさん@お腹いっぱい。:2001/05/21(月) 12:03
みんな早く2.4を使おう。で、バグがあったら各ディストリに
伝えよう!(こういう時は赤帽が一番かな)そうすれば、
もっと早く安定するかも?

97 :名無しさん@お腹いっぱい。:2001/05/21(月) 12:20
赤帽はマージしないことが多いのでダメと思われ

98 :名無しさん@お腹いっぱい。:2001/05/21(月) 21:58
2.4カーネル移行記念age


99 :名無しさん@お腹いっぱい。:2001/05/22(火) 04:58
初めてカーネル上げました。
よくわからずにやったので失敗もしましたが、
VMware上のDebianで、念のためディスクファイルを
保存してからやったので何の心配もなかったです。
少し成長したような気分。


100 :名無しさん@お腹いっぱい。:2001/05/24(木) 04:19
2.4でのネットワークカーネルについての解説文書を
お持ちの方はいらっしゃいませんか。
BSDとも違うし2.2と比べてもかなり異なる。
勝手にWindow Sizeを変えないでくれ.....

138 KB
■ このスレッドは過去ログ倉庫に格納されています

★スマホ版★ 掲示板に戻る 全部 前100 次100 最新50

read.cgi ver 05.04.02 2018/11/22 Walang Kapalit ★
FOX ★ DSO(Dynamic Shared Object)