5ちゃんねる ★スマホ版★ ■掲示板に戻る■ 全部 1- 最新50  

■ このスレッドは過去ログ倉庫に格納されています

bootstrap-pkgsrc(Zoularis)

1 :名無しさん@お腹いっぱい。:03/10/05 23:50
諸君 私はBSD makeが好きだ
諸君 私はBSD makeが好きだ
諸君 私はBSD makeが大好きだ

Solaris で Linux で FreeBSD で
OpenBSD で Darwin で IRIX で

諸君 私はパッケージ管理を 最強のパッケージ管理を望んでいる
諸君 私に付き従う root 諸君 君達は一体 何を望んでいる?
*.rpm や *.deb を望むか?
情け容赦のない糞の様な pkgadd や webstart を望むか?
./configure の限りを尽くし config.h を書き換える autoconf の様な野良 build を望むか?

BSD make!
BSD make!
BSD make!

よろしい ならば bootstrap-pkgsrc だ

http://www.netbsd.org/Documentation/software/packages.html
ftp://ftp.netbsd.org/pub/NetBSD/packages/bootstrap-pkgsrc

征くぞ 諸君

2 :名無しさん@お腹いっぱい。:03/10/05 23:56
良スレだな。

3 :名無しさん@お腹いっぱい。:03/10/06 00:03
そういや http://www.openpackage.org は消えたな
http://web.archive.org/web/20030215041538/http://www.openpackage.org/

4 :名無しさん@お腹いっぱい。:03/10/06 02:18
Solaris上ではまだまだ安定して使えていないなぁ。
pkgsrc/devel/binutilsのmake installで

/bin/ksh libtool --mode=install /bin/ksh ../install-sh libopcode.la /usr/pkg/lib/libopcode.la
libtool: install: `/usr/pkg/lib/libopcode.la' is not a directory

とか怒られたりとか。
理由はsh(1)とksh(1)の非互換性(mk/defs.SunOS.mkではSH?=/bin/ksh)
っぽいのだが、libtoolもinstall-shも長文ウザいし、なかなか原因にたどり着かん。
bootstrap-pkgsrcにinstall(1)も入れて、install-shを使わん方がいいんじゃないかなぁ。

他にもPKGLOCALEDIRの置換がされない
(*.moのインスコ先がPLISTではlib/localeなのに実際にはshare/locale)ので、
make packageがコケまくりとかの現象も発生してるな。


5 :名無しさん@お腹いっぱい。:03/10/06 03:05
とうとう建ったな。

6 :名無しさん@お腹いっぱい。:03/10/06 03:31
OpenPKG使ってるんだけど

2 KB
■ このスレッドは過去ログ倉庫に格納されています

★スマホ版★ 掲示板に戻る 全部 前100 次100 最新50

read.cgi ver 05.04.00 2017/10/04 Walang Kapalit ★
FOX ★ DSO(Dynamic Shared Object)